×
Kunena 5.2.9 released and Kunena 6.0.0 (08 Jun 2022)

The Kunena team has announce the arrival of Kunena 5.2.9 [K 5.2.9] which is now available for download as a native Joomla extension for J! 3.10. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of previous version of K5.2.

The Kunena team has announce the arrival of Kunena 6.0.0 [K 6.0.0] which is now available for download as a native Joomla extension for J! 4.1.x. Only the module kunena latest and the discuss plugin which are still in beta are working in Joomla! 4.1 with Kunena 6.0.

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Modules assigned to forum page dont show

More
3 months 2 weeks ago - 3 months 2 weeks ago #1 by derekk
I am using a dev site and have imported the database tables from our live site.
Below is the summation of the versions we have changed to
  •  Version:5.2.6 on dev site Template : Crypsis /5.1.7 on live site Template : Canvas/ 5.2.8 is latest version

    The Kunena template we used on the live site is no longer available 


We are using Rocketheme template called Supra
After creating the menu item  in our main menu for Kunena forum with an alias menu type, I chose the rocketheme template in the menu item field
I saved it

Then there are a few issues
,   
Typically I see it filled for example like      
2. The modules I assigned to the menu item do not show
3. The layout is not formatted the search button is covered or overlapped in z-index or padding issue
4. In the tools section using diagnostics I see about 100 issues reported in dev  site and almost the same in live site
4A.  Can I see those issues before hitting the fix link?
4B. Should I fix all of them by hitting the fix links?

Thank you 


 
Last edit: 3 months 2 weeks ago by derekk.

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #2 by rich

Version:5.2.6 on dev site Template : Crypsis /5.1.7

On the dev side, why don't you have the same Crypsis version as the Kunena version?

I am using a dev site and have imported the database tables from our live site.

If you have other software installed on the dev side and only import the database, it will cause errors. Better would be to clone the live site, and then update everything. 

We are using Rocketheme template called Supra

I think the Rocketheme Supra is written for Bootstrap 5. If so, it will not work, because we don't have a Bootstrap 5 capable template for Kunena 5.2.x. That is only available for Joomla 4 and Kunena 6.0.

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #3 by derekk

f you have other software installed on the dev side and only import the database, it will cause errors. Better would be to clone the live site, and then update everything. 


The live site is malfunctioning old and huge and I can not clone it nor do I want to.

On the dev side, why don't you have the same Crypsis version as the Kunena version?

The Kunena template we used on the live site is no longer available in the new Kunena version 

I think the Rocketheme Supra is written for Bootstrap 5. If so, it will not work, because we don't have a Bootstrap 5 capable template for Kunena

Ok I will verify with Rockettheme, however Kunena is working fine except:
If I use a menu alias that is standard practice for Kunena it works and looks fine however  It does not show assigned modules
If I dont use menu alias then the inner nav bar tabs do not show and the formatting is wrong , I have written CSS to override it and it works but this is not good practice because every Kunena update will overwrite it.

That is why I asked you above 

4. In the tools section using diagnostics I see about 100 issues reported in dev  site and almost the same in live site
4A.  Can I see those issues before hitting the fix link?
4B. Should I fix all of them by hitting the fix links?

If I click those links on the dev site or find out what the fixes are I may fix the issue, could you reply to those questions please?

Thank you




 

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago - 3 months 2 weeks ago #4 by rich

The live site is malfunctioning old and huge and I can not clone it nor do I want to.

If the live page is too large, then the imported database is also too large. This then contains everything that you actually no longer want. Or have you only imported the Kunena tables?

The Kunena template we used on the live site is no longer available in the new Kunena version

This has nothing to do with other templates. Crypsis is the system template of the Kunena 5.x series, and no matter which Kunena version is installed, the same Crypsis version must always be present. So something is wrong.

4. In the tools section using diagnostics I see about 100 issues reported in dev  site and almost the same in live site

It displays orphaned database entries. This function should be used with caution because it deletes database entries. 
docs.kunena.org/en/manual/backend/tools/diagnostics
Last edit: 3 months 2 weeks ago by rich.

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #5 by derekk

If the live page is too large, then the imported database is also too large. This then contains everything that you actually no longer want. Or have you only imported the Kunena tables?

Correct I only  imported very specific tables including Kunena

This has nothing to do with other templates. Crypsis is the system template of the Kunena 5.x series, and no matter which Kunena version is installed,

Template  is called Canvas/ version is  5.1.7 on live site .
I do not see a template called Canvas on the dev site

the same Crypsis version must always be present. So something is wrong.

The Crypsis template is present and available on both the dev and the live site 
The template i am using on the dev site  is Crypsis  
On the live site the template I am using is Canvas and yes the Crypsis template is present and available bit I am not using it I am using  Canvas.
The issue is I dont have Canvas template available on the dev site because the Kunena version is a newer version and the canvas template does not come with it installed

It displays orphaned database entries. This function should be used with caution because it deletes database entries. 

Yes I will back up first however my question was can I see the errors before clicking the links to fix them?

Thank you

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago - 3 months 2 weeks ago #6 by rich

Yes I will back up first however my question was can I see the errors before clicking the links to fix them?

In principle, it is possible to check this in advance, but it is not always easy. You have to see the context. 
Example: You have orphaned attachments in the list. In the #__kunena_attachments table you will find some entries with mesid 0, i.e. these attachments are not associated with any message. If you click Repair, these entries will be removed.
Or category missing alias, then you will find a missing entry in #__kunena_aliases. This must be repaired manually. Not all can be repaired automatically with the FIX button.
 
Last edit: 3 months 2 weeks ago by rich.

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #7 by derekk
Thank you for the clarification.
Can you tell me which types can be fixed automatically if I provide you with the list?
Returning to the original and important issue 

I think the Rocketheme Supra is written for Bootstrap 5. If so, it will not work, because we don't have a Bootstrap 5 capable template for Kunena

i asked Rockettheme and they replied that the Supra version I am using on Joomla 3 is bootstrap 2.3.2 

This leaves these issues still unresolved
   
2. The modules I assigned to the menu item do not show
3. The layout is not formatted the search button is covered or overlapped in z-index or padding issue
4. In the tools section using diagnostics I see about 100 issues reported in dev  site and almost the same in live site

Thank you
Attachments:

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #8 by rich
In principle, these can be fixed if there is a "Repair" button next to this message.
However, this can also lead to the next message.
Example:
If you remove an orphaned message, the next message "messageBodyMissingMessage" may appear. This must then be fixed as well.
I don't know your errors and I don't know all the errors that are possible. 
First recount the statistics and see if there are fewer messages.
In my tests I never had problems with this option, but something can always happen.

The modules I assigned to the menu item do not show

Please check the module positions again, they are not the same for all templates. And also in the module itself, whether this is assigned to all menu items.

The layout is not formatted the search button is covered or overlapped in z-index or padding issue
i asked Rockettheme and they replied that the Supra version I am using on Joomla 3 is bootstrap 2.3.2 

In this case, Crypsis should work. But you can try in the Crypsis setting "Load bootstrap css = Yes".
Crypsis = bootstrap 2
Crypsisb3 = bootstrap 3
Crypsisb4 = bootstrap 4

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago - 3 months 2 weeks ago #9 by derekk
Edit:
I have found the issue.
It is because you must select all the sub menu and the parent menu item in the module assignments tab
Then unpublish the module instance in the outline if you dont want it to show two or pick either module assignment or module instance in the outline

Hopefully this will help others in the future

Now the remaining questions are for fixing the errors in the list below and the search bar overlapping the button behind it?
for search field 
#kunena .layout .search-query {
    width: auto;
    margin-top: 30px;
}
Of for button 
.form-search .input-append .btn {
    /* -webkit-border-radius: 0 14px 14px 0; */
    -moz-border-radius: 0 14px 14px 0;
    border-radius: 3px;
    margin: 10px;
    min-width: 50px;
}
Change the tooltip to say click the button this needs work or remove the button completely with the following CSS

.form-search .input-append .btn {
    /* -webkit-border-radius: 0 14px 14px 0; */
    -moz-border-radius: 0 14px 14px 0;
    border-radius: 3px;
    margin: 10px;
    min-width: 50px;
    display: none;
}


This is the list
messageMissingMessageBody TEST FAILED 1 issues DELETE BROKEN ITEMS
topicMissingMessages TEST FAILED 2 issues DELETE BROKEN ITEMS
messageOrphaned TEST FAILED 4 issues DELETE BROKEN ITEMS
attachmentOrphaned TEST FAILED 85 issues DELETE BROKEN ITEMS
userReadWrongCategory TEST FAILED 1 issues FIX ISSUES
userTopicWrongCategory TEST FAILED 1 issues FIX ISSUES

I verified with Rockettheme the module is assigned properly
I set the Crypsis setting "Load bootstrap css = Yes" as requested the result was minor spacing but overlap and still no modules

Thank you
Last edit: 3 months 2 weeks ago by derekk.

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #10 by rich
Not much can happen there. Most of them are orphaned attachments. How you get orphaned attachments you can test it. Orphaned attachments also are displayed in the diagnostic, when users upload attachments sloppy. It means, that the user had uses the browser back button and again the forwards button before save. Kunena register this as abort and enter no message ID for this image.
Or a user do not use the cancel button if he not send after image upload his message. All this attachments get the mesid 0 in the table #__kunena_attachments.
You can see in the frontend in the message "You do not have permissions to access this page." instead of this image.

The rest are just some messages. I do not see any problem.

As for Crypsis, does it work with the Joomla template Protostar?

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.104 seconds