×
Kunena 5.1.12.1 Released - Security release (22 Apr 2019)

The Kunena team has announce the arrival of Kunena 5.1.12.1 [K 5.1.12.1] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a security release.

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question How to play mp3 files in a topic?

More
4 months 4 weeks ago #1 by mp3player
Hi,

I wonder how I can start a topic that automatically plays a mp3 file (or at least offers a player) from URLs and LOCAL from my server?

I present animal pictures and want to play their voices.

Thanks and regards
mp3player

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago #2 by 810
We have only a default html5 player support.

You can add mp3 on the attachments extension list, then you can insert the mp3 into the message. That will load the default html5 player from your browser.

if you want auto play ect, you can edit \components\com_kunena\template\crypsis\layouts\attachment\item\audio.php

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago #3 by mp3player
Thanks for your reply!

But doesn´t editing audio.php mean that you afterwards ALWAYS have autoplaying and cannot decide about autoplaying/not autoplaying when you create the message?

Do Videos work in the same way?
What is the difference between PROVIDER and VIDEO when you click on the video icon in the editor?

Thanks in advance!

Greetings
mp3player

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago - 4 months 4 weeks ago #4 by mp3player
Meanwhile I have found an older message here from sozzled :
www.kunena.org/forum/97-K-10-Common-Ques...music-in-forum#13836

What ist the correct bbcode for inserting the attached mp3 or videofiles locally stored on the server on which Kunena is running on?

Thanks and greetings
mp3player
Last edit: 4 months 4 weeks ago by mp3player.

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago #5 by 810

mp3player wrote: Thanks for your reply!

But doesn´t editing audio.php mean that you afterwards ALWAYS have autoplaying and cannot decide about autoplaying/not autoplaying when you create the message?

Yes that's true. is set for all audio.

Do Videos work in the same way?

Yes, only its the video.php file.

What is the difference between PROVIDER and VIDEO when you click on the video icon in the editor?


Provider = example "Youtube"
Video = "Video Id"

What is the correct bbcode for inserting the attached mp3 or videofiles locally stored on the server on which Kunena is running on?


Depends on the plugin that you use. usually like {mp3}url{/mp3} or something you should check the plugin author site.

But make sure that kunena system plugin is enabled and has the both option set enabled.
The following user(s) said Thank You: mp3player

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago - 4 months 2 weeks ago #6 by mp3player
Hi,
I had to add the extension mp3 to the list of allowed ones and to change the known settings in the kunena system plugin (message & body). Additionally I changed the path for Allvideo´s LOCAL AUDIO FOLDER to kunena´s attachments path.
Then I could use the {mp3}-Tag from Allvideos to play local stored MP3 audio files.
But what does NOT work yet: playing remotely stored MP3-Files by using {mp3remote} and an external URL like domain.tld/audiofile.mp3 .
What can I have missed? Why can i still not used {mp3remote}?

EDIT:
Obviously disabling AUTO-LINK-URLS in KUNENA-CONFIGURATION-BBCODE-Settings solves the problem.
But now you have the disadvantage that AUTO-LINK-URLS does not work anymore for the users.

Greetings
mp3player
Last edit: 4 months 2 weeks ago by mp3player.

Please Log in or Create an account to join the conversation.

More
3 weeks 1 day ago #7 by Manika
Disabling AUTO-LINK-URLS in KUNENA-CONFIGURATION-BBCODE-Settings solves the problem.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.087 seconds