×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Registered users can't edit own posts any longer

More
2 years 7 months ago #1 by KennethHansen
Hi community and Kunena staff.

We're facing a problem with our Kunena-board, and it all came out of the blue.
Our registered users suddenly can't any longer edit their own post or topics. People says that the "Edit" button doesn't even appear.

Strange thing is, I didn't edit any settings or configurations prior to the problem.
Checking Kunena > Configuration > Frontend > "Let users edit the subject", it is indeed still ticked as "Yes".

Also went to the individual categories, to see if I by mistake had changed the rules, but all seems correct.
To cross-check, I also tried to register a new user myself, and logged in as this new user, I'm perfectly fine allowed to edit both my own posts and topics, which leads me to think the problem only exists for registered users prior to some specific date of whatever event occured, that caused the problem.


Any ideas?
Any file or configuration I can check directly too see, what could be going on?

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #2 by WolfgangOWL
The following user(s) said Thank You: KennethHansen

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #3 by KennethHansen
Oh, a bug with the latest Kunena-update?

Thanks, will try it right away!

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #4 by rich
@Wolfgang

With K 5.1 it should work again. It's now added additional to the others options.
github.com/Kunena/Kunena-Forum/pull/5715
github.com/Kunena/Kunena-Forum/pull/5720

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.103 seconds