×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Les sujets sont déplacés dans ce domaine ne sont fermés parce qu'ils se rapportent à des versions non prises en charge de Kunena.

Question Erreur 500 si l'utilisateur est déconnecter

More
8 years 3 months ago #1 by Sissou
Bonjour a toute la communauté kunéna ;)

Je vient vers vous car je rencontre un petit probléme avec mon forum:

Description:
Lorsque un utilisateur non connecter, accéde a l'index du forum le forum affiche en haut de page le message suivant:

Kunena Erreur interne: Veuillez contacter l'administrateur du site pour résoudre ce problème!


Lorsque un utilisateur non connecter, essaye d'acceder a un sujet du forum celui-ci renvoi:

500 Internal Server Error
Fatal Error was detected!
Fatal Error: Class 'KunenaParser' not found in components/com_kunena/funcs/view.php on line 597
The error was detected in the Kunena Component.


Note: Il n'y a aucun probléme pour les utilisateur connecter.

Voici le raport de configuration de kunena:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 32M | Max file upload: 2M

Kunena menu details:
Warning: Spoiler!

Joomla default template details : rt_crystalline | author: RocketTheme, LLC | version: 1.1 | creationdate: December 13, 2011

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.2 | creationdate: 2012-01-31

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: CommunityBuilder 1.8 | UddeIm 2.6

Third-party SEF components: sh404sef: The file doesn't exist sh404sef.xml !

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None


J'ai deja réinstaller kunena à plusieurs reprise mais rien n'y fait, si vous avez une solution je suis prenueur ;)

Salutation
Sissou

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #2 by xillibit
Bonsoir,

vérifie que le fichier \administrator\components\com_kunena\libraries\html\parser.php est bien présent

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #3 by Sissou
Bonjour, xillibit

Merci pour votre réponce, le fichier paraser.php est bien présent sur le ftp.

Si vous souhaiter avoir un aperçu du probléme je vous invite a vous diriger vers le Forum puis cliquez sur nimporte quel sujet, vous pouvez constater l'erreur 500.

Si vous vous connecter Login: testou ; Pass: testou vous remarquerez qu'il n'y a plus aucune erreur.

Si vous avez une quelconque idée ou suggestions je suis preneur ;)

Sur ce je vous souhaite a tous un bon week-end B)

Salutation
Sissou

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #4 by xillibit
Ajoute ça ligne 596 :
require_once (JPATH_ADMINISTRATOR.'/administrator/components/com_kunena/libraries/html/parser.php');

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #5 by Sissou
Re,

J'ai rajouter:
require_once (JPATH_ADMINISTRATOR.'/administrator/components/com_kunena/libraries/html/parser.php');

Dans le fichier components/com_kunena/funcs/view.php a la ligne 597

Voici un extrai:
//meta description and keywords
		$metaKeys = kunena_htmlspecialchars ( "{$this->first_message->subject}, {$objCatParentInfo->name}, {$this->config->board_title}, " . JText::_('COM_KUNENA_GEN_FORUM') . ', ' . $this->app->getCfg ( 'sitename' ) );
 
		// Create Meta Description form the content of the first message
		// better for search results display but NOT for search ranking!
		require_once (JPATH_ADMINISTRATOR.'/administrator/components/com_kunena/libraries/html/parser.php');
		$metaDesc = KunenaParser::stripBBCode($this->first_message->message);
		$metaDesc = strip_tags($metaDesc); // Now remove all tags

Le probléme étant toujours présent j'ai repasser kunena un mode debug qui me retourne maintenant:

Fatal Error: require_once() [function.require]: Failed opening required '/homepages/46/d230100672/htdocs/tutoprod/www/administrator/administrator/components/com_kunena/libraries/html/parser.php' (include_path='.:/usr/lib/php5') in components/com_kunena/funcs/view.php on line 597

J'ai donc modifier en:
require_once (JPATH_ADMINISTRATOR.'/components/com_kunena/libraries/html/parser.php')

Les post du forum sont bien visible lorsque l'utilisateur est déconnecter. Merci :)

Ce pendant le forum affiche toujour le message(pour les visiteur):

Kunena Erreur interne: Veuillez contacter l'administrateur du site pour résoudre ce problème!


De plus je vient de constater que les icones personaliser des catégorie du forum, ne s'affiche pas pour les utilisateur non connecter.

Avez vous une idée?

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #6 by xillibit
Active le mode debug dans le panneau de contrôle de Kunena.

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #7 by Sissou
Re,

j'ai activer le Mode debug ;)

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #8 by xillibit
ça t'affiche un message d'erreur plus précis ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #9 by yuri1982

Sissou wrote: Re,

J'ai rajouter:

require_once (JPATH_ADMINISTRATOR.'/administrator/components/com_kunena/libraries/html/parser.php');

Dans le fichier components/com_kunena/funcs/view.php a la ligne 597

Voici un extrai:
//meta description and keywords
		$metaKeys = kunena_htmlspecialchars ( "{$this->first_message->subject}, {$objCatParentInfo->name}, {$this->config->board_title}, " . JText::_('COM_KUNENA_GEN_FORUM') . ', ' . $this->app->getCfg ( 'sitename' ) );
 
		// Create Meta Description form the content of the first message
		// better for search results display but NOT for search ranking!
		require_once (JPATH_ADMINISTRATOR.'/administrator/components/com_kunena/libraries/html/parser.php');
		$metaDesc = KunenaParser::stripBBCode($this->first_message->message);
		$metaDesc = strip_tags($metaDesc); // Now remove all tags

Le probléme étant toujours présent j'ai repasser kunena un mode debug qui me retourne maintenant:

Fatal Error: require_once() [function.require]: Failed opening required '/homepages/46/d230100672/htdocs/tutoprod/www/administrator/administrator/components/com_kunena/libraries/html/parser.php' (include_path='.:/usr/lib/php5') in components/com_kunena/funcs/view.php on line 597

J'ai donc modifier en:
require_once (JPATH_ADMINISTRATOR.'/components/com_kunena/libraries/html/parser.php')

Les post du forum sont bien visible lorsque l'utilisateur est déconnecter. Merci :)

Ce pendant le forum affiche toujour le message(pour les visiteur):

Kunena Erreur interne: Veuillez contacter l'administrateur du site pour résoudre ce problème!


De plus je vient de constater que les icones personaliser des catégorie du forum, ne s'affiche pas pour les utilisateur non connecter.

Avez vous une idée?


Where is that file in Kunena 2.0 ???? Thanks a lot

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.208 seconds