×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× This is not a support forum for any of the products contained herein. For product support you should visit the developer's website.

The information given in this category is intended to guide users who want to use various third-party products with Kunena and, mostly, was written by Kunena users. The information here is not necessarily accurate, up-to-date nor is it intended to replace the support given by the developers of other Joomla extensions.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved CjBlog issues with Kunena

More
6 years 8 months ago #1 by matps
Hi There,

Firstly, I've read www.kunena.org/forum/K-2-0-General-Quest...ad-this-first#127255 and tried all the suggestions given in www.kunena.org/docs/Common_causes_of_Moo...29_issues_and_Kunena

However I am still having issues with being able to edit a users profile (I also have the issue where if I can on a user's name instead of viewing there profile it gives me the url ending forum/recent#)

I also cannot use the the 'Profile' tab unless I change it to 'not intergrate' under the Kunena 'Profile' menu item.

My website is www.craftkeg.com/index.php/forum/index and I've tried numerous options of disabling jquery and changing the template from beez5 to atomic and nothing has worked.

I've also used Firebug and viewed the page source and Kunena seems to be loaded before Hikashop, the other plugin I'm using.

Any suggestions would be greatly appreciated.

Kind Regards,

Matthew

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #2 by matps
Replied by matps on topic CjBlog issues with Kunena
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 120 seconds | Max execution memory: 128M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : beez5 | author: Angie Radtke | version: 2.5.0 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.3 | creationdate: 2013-10-20

Kunena version detailed: Kunena 3.0.3 | 2013-10-20 [ Bifrost ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #3 by sozzled
Replied by sozzled on topic CjBlog issues with Kunena
G'day, matps, and welcome to Kunena.

The bigger problem is what happens when people click a username in your forum. This does not look like a Javascript issue to me. This looks more like a Joomla menu problem.

1) Learn how to implement Joomla SEO properly by reading Search engine optimisation (SEO) in the Wiki.

2) Learn how to use a standard Kunena menu with Kunena menu issues .

3) J! 2.5.11 is out-of-date, vulnerable to security issues, and not supported by Joomla. You should update to J! 2.5.16.
Last edit: 6 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #4 by matps
Replied by matps on topic CjBlog issues with Kunena
Hi There,

Thanks for the information, but I'm afraid it hasn't helped too much.

1) I tried running through the pointers for Joomla 2.5 but changing 'Use URL rewriting' to yes causes the menu to have a 404 error.

2) I deleted all menu instances and created a new menu with the method provided.

3) I've upgraded to 2.5.16.

I'm confusing with how this isn't a Javascript error when everything on the forum about not being able to edit a user profile suggests that it's javascript related?

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #5 by sozzled
Replied by sozzled on topic CjBlog issues with Kunena

matps wrote: 1) I tried running through the pointers for Joomla 2.5 but changing 'Use URL rewriting' to yes causes the menu to have a 404 error.

You will get 404 errors if you do not gave a valid .htaccess file. It's all explained in the article I referred you to.
Last edit: 6 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #6 by matps
Replied by matps on topic CjBlog issues with Kunena
I'm just looking at my .htaccess now and it all appears to be fine. I assume changing it to .htaccess! means it doesn't need the .txt on the end still?

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #7 by sozzled
Replied by sozzled on topic CjBlog issues with Kunena
If you want you use Joomla SEO properly, with Use URL rewriting = Yes, you need a valid .htaccess file. It's all explained in the Wiki.
Last edit: 6 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #8 by matps
Replied by matps on topic CjBlog issues with Kunena
and I'm saying that I've followed the Wiki and I still got 404 errors. Does this "Use URL rewriting" really affect my original problem of not being able to edit a profile or view a users profile?

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #9 by xillibit
Replied by xillibit on topic CjBlog issues with Kunena
Hello,

You may have a javascript conflict somewhere, is it possible to have a test account on your site ? Put the infos into
This message contains confidential information

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #10 by sozzled
Replied by sozzled on topic CjBlog issues with Kunena

matps wrote: I also have the issue where if I can on a user's name instead of viewing there profile it gives me the url ending forum/recent#

This problem is caused by how you set up Joomla SEO and how you set up your menu.

matps wrote: I also cannot use the the 'Profile' tab ....

I am assuming that you have problems with the Profile menu item of the Kunena menu, yes? This, too, has nothing to do with Javascript.

matps wrote: ... unless I change it to 'not integrate' under the Kunena 'Profile' menu item

We are still discussing an issue involving a Joomla menu item. We are still talking about what you do using the Joomla Menu Manager. Again, this has nothing to do with Javascript.

What makes you think that Javascript is involved? Perhaps you could show us your updated configuration report and a screenshot to illustrate the problem? :dry:

What is more, we are not even discussing J! 2.5.11 any more, either.

It looks to me that many Kunena URLs on your site are being re-routed in an unexpected manner - possibly by an SEO product that's unknown to us or some special, custom .htaccess file that you have hidden somewhere. Try using the standard .htaccess file that is included in the Joomla distribution kit.
Last edit: 6 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.138 seconds