×
Kunena 5.2 RC 1 Released (25 Oct 2020)

The Kunena team is thrilled to announce the first public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This is not a support forum for any of the products contained herein. For product support you should visit the developer's website.

The information given in this category is intended to guide users who want to use various third-party products with Kunena and, mostly, was written by Kunena users. The information here is not necessarily accurate, up-to-date nor is it intended to replace the support given by the developers of other Joomla extensions.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved Easyblog module causes Kunena Latest to not display avatar?

More
7 years 1 month ago #1 by Tryweryn
Hi i had the latest post mod showing avatars. Anywhere I add the easeyblog show module on the site seems to cause the latest posts mod to stop showing the avatars. Any ideas please? It can be seen on www.britmovie.net

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 2M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : yoo_nano3 | author: YOOtheme | version: 1.0.7 | creationdate: Unknown

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 3.0.2 | creationdate: 2013-08-18

Kunena version detailed: Kunena 3.0.2 | 2013-08-18 [ Nocturne ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: Jomsocial 3.0

Third-party SEF components: None

Plugins: Search - Kunena Search 3.0.1 | JomSocial - My Kunena Forum Menu 2.0.3 | JomSocial - My Kunena Forum Posts 2.0.3 | JomSocial - Kunena Groups 2.0.3

Modules: Kunena Latest 3.0.1

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago - 7 years 1 month ago #2 by sozzled
I'm about to make a wild guess based in part on your configuration settings and based on another discussion that we're having on this forum about the Kunena Latest module and JomSocial ( Kunena Latest: How to show JomSocial avatars and link to user profile? )

It is my guess that the Kunena Latest module can only display the avatar images from the Kunena user profile. I may be quite wrong but it's again my guess that if you set the Kunena - Kunena plugin to display avatars, the Kunena Latest module will display an avatar image ... the Kunena avatar image (which is probably not what you want to display).

I would like to see the result of that test. Could you try it for us, please?
Last edit: 7 years 1 month ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #3 by Tryweryn
Many thanks for that. Yes when changed it shows the kunena avatar which are all blank as I take it before they were coming from jomsocial. But may i ask why before adding easyblog show module did it show the avatars and when easyblog show was added it stopped? I left it set as u said at www.britmovie.net so you can see the result.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #4 by Tryweryn
Is the a fix to the latest post mod not getting the jomsocial avatars?

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #5 by Jiminimonka
I have made a test site with Kunena 3 and JomSocial 3.0.1 and the Latest module is displaying the correct JomSocial Avatars. The problem is being investigated however.

Please read the FAQ.
Only one question per topic.
Search before you ask a question.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #6 by Tryweryn
If I can just mention as it may help. The problem did not occur until i placed easeyblog show module on the front page. Removing this module and the latest posts module displays the joomla avatars. Hope this helps a bit.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago - 7 years 1 month ago #7 by sozzled
It helps a bit but we don't have a solution.

There are a couple of workaround suggestions posted in Kunena Latest: How to show JomSocial avatars and link to user profile? . This might be something that, unfortunately, people will have to live with for a little while until or unless

(a) we figure out what's causing the problem and we someone figures out how to solve it (and writes the coded solution in GitHub); or

(b) if the problem is solvable in a future release of Kunena Latest module, then people will have to accept that the solution won't be available until the Kunena Latest module is updated, tested and released. In anticipation of a likely next question (namely, when is this likely to happen), I have no idea when this is likely to occur; it could be days, weeks or months away. Finding a permanent solution depends on who can work solidly to identify the cause, who has the required mix of software components to test the ideas to solve the problem, and when it would be opportune to announce that we are confident that we've licked the problem once and for all.

In the grand scheme of things, this particular problem is more of a nuisance than a complete show-stopper. Overall, the Kunena Latest module works in delivering information about the latest messages posted on a Kunena forum on other parts of a user's website. One small part of that module - the part relating to the display of user avatars in the module - does not seem to work correctly in all circumstances. We understand that. Sorry.
Last edit: 7 years 1 month ago by sozzled.
The following user(s) said Thank You: Tryweryn

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #8 by Tryweryn
Not a problem....its amazing work u do. Its a minor problem.
The following user(s) said Thank You: sozzled

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #9 by Tryweryn
Actually I narrowed this down. Turning the avatars on in the easeyblog module stops the jomsocial avatars being shown in kunena latest posts mod. Turning them of and the avatars in kunena latest posts show. No errors shown.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #10 by Tryweryn
Found the problem i removed K2 and it works great...by the way removing k2 also cured my site breaking up in explorer 9. Hope this helps someone.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.142 seconds