×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

× This is not a support forum for any of the products contained herein. For product support you should visit the developer's website.

The information given in this category is intended to guide users who want to use various third-party products with Kunena and, mostly, was written by Kunena users. The information here is not necessarily accurate, up-to-date nor is it intended to replace the support given by the developers of other Joomla extensions.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved Xmap xml page :: topic links end in "/list" and access denied result

More
7 years 1 month ago #1 by myopicseer
Newest 3.0.1 version installed. Found a "fixed" kunena xmap plugin, and seems to work well now.

On the xml page that was submitted to Google, Google reports "HTTP ERROR 404" for links in the xmap page. When I follow the link causing Google the issue, I discover kunena says:

ACCESS DENIED
You do not have permissions to access this page.

and the xml provided URL includes an extra (and unnecessary) "/list" at the end of it. It also includes a "categories" in the middle of the URL.

XML SITE MAP URL:
/boating-forum/categories/boat-repair/18-what-type-of-gear-oil-do-i-need

IT REDIRECTS TO: (which is what google finds)
/boat-repair/18-what-type-of-gear-oil-do-i-need/list
WHICH RESULTS IN "ACCESS DENIED". (Note "categories" removed, "list" added on redirect)

IF I REMOVE "/LIST" FROM THE URL,
IT WORKS:
/boat-repair/18-what-type-of-gear-oil-do-i-need
(Note: both categories and list are removed from the URL)

What do I need to do to prevent these bad URLs from showing in the Xmap sitemap, or what can I do to allow permission so that they are not 404's? I have public (user group) access and allow secondary groups set for this category. Confused!

forum.aboatsale.com is the site.

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #2 by indeepblue

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #3 by sozzled
We suggest that you discuss your problem with the developers of the Xmap extension. Let's hear what they have to advise you (and others who may be having the same problems). Thanks.

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago - 6 years 10 months ago #4 by Regulated
I beleive it is because you will have a redirect to remove index.php from your URL or something else to shorten the URL (mine has /index/ in the URL from XMAP but it not in the URL in a browser). I have had it for a while on my site but haven't been able to google a fix. I'm pretty sure it worked fine when I didn't have the redirect on.

EDIT:

I just found this post by Smirnov and the plug in seems to work. www.kunena.org/forum/9-Extensions-Module...lems?start=10#144847
I published the xmap content, kunena and weblinks plugins.

Cheers
Last edit: 6 years 10 months ago by Regulated. Reason: Added fix and index reference

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.079 seconds