Kunena 6.0.8 Released (17 Jan 2023)

The Kunena team has announce the arrival of Kunena 6.0.8 [K 6.0.8] which is now available for download as a native Joomla extension for J! 4.2.x. This version addresses most of the issues that were discovered in K 6.0 and issues discovered during the development stages of K 6.0.

Solved Bekomme CKEditor nicht auf deutsch umgestellt

More
1 year 7 months ago #1 by Lollo_C
Hallo Zusammen,
ich wollte gemäß der Anleitung [url] www.kunena.org/docs/en/faq/ckeditor-configuration [/url] die Sprache des CKEditors (zunächst auf meiner lokalen Testseite) auf deutsch umstellen. Zunächst habe ich die customckeditor_config.js erstellt. Dann das genannte Sprachpaket von [url] ckeditor.com/cke4/addon/language [/url] heruntergeladen, entpackt und die de.js nach media\kunena\core\js\lang kopiert. Anschließend die Änderungen gemäß des Beitrags [url] www.kunena.org/forum/107-Translations/16...itor-in-kunena-5-2-1 [/url] in der customckeditor_config.js vorgenommen. Leider wird danach der Editor nicht mehr angezeigt. 
Mir ist aufgefallen, dass die de.js nur 1KB groß ist, während die en.js 12KB hat. Daraufhin habe ich eine deutsch Sprachdatei aus einem Installationspaket genommen. Sie ist immerhin 5KB groß, löst aber auch nicht mein Problem. Momentan bin ich sehr ratlos.
Kann mir vielleicht jemand genau angeben, welche Sprachdatei ich in den Ordner kopieren muss und welche Änderungen an welche Stelle mit welcher Syntax in die customckeditor_config.js gemacht werden müssen.
Vielen Dank im voraus. 
Hier noch mein Konfigurationsbericht:

This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |
        

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 240 seconds | Max execution memory: 128M | Max file upload: 32M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : jsn_corsa2_pro | author: JoomlaShine.com | version: 1.0.2 | creationdate: 04/23/2018

Kunena default template details : Crypsisb3 | author: Kunena Team | version: 5.2.4 | creationdate: 2021-04-04

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.2.4 | 2021-04-04 [ Koios ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.6.0 | UddeIM 3.9

Third-party SEF components: None

Plugins: Search - Kunena Search 5.1.2

Modules: Kunena Latest 5.2.2 | Kunena Stats 5.2.2 | Kunena Search 5.2.2

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #2 by rich
Wenn du die Schritte in der Dokumentation befolgst, sollte es funktionieren, ich habe das mehrfach getestet (auch jetzt noch einmal).
Aber vielleicht wartest du auch ab, voraussichtlich kommt in der nächsten Kunena-Version der andere Editor wieder zurück. Der CKEditor macht einfach zu viele Probleme.
The following user(s) said Thank You: Lollo_C

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #3 by rich
Nachdem inzwischen einige Fehler im CKEditor behoben werden konnten, bin ich nicht mehr so sicher, ob der anderer Editor in der nächsten Version wieder enthalten ist. Deshalb melde ich mich wieder.

Momentan bin ich sehr ratlos.
Kann mir vielleicht jemand genau angeben, welche Sprachdatei ich in den Ordner kopieren muss und welche Änderungen an welche Stelle mit welcher Syntax in die customckeditor_config.js gemacht werden müssen.

Ich habe dir das Sprachfile und eine customckeditor_config Datei in eine Zip verpackt und hochgeladen. Lade  diese runter und entpacke sie.
Die  de.js muss  in den Ordner /media/kunena/core/js/lang/de.js

Folgender Code muss in die customckeditor_config.js eingetragen werden (du findest diesen in meiner angehängten Datei in Zeile 11).
Code:
CKEDITOR.lang.languages={"en":1,"de":1}
Diese customckeditor_config.js muss sich in diesem Ordner befinden: /media/kunena/core/js/

Jetzt musst du nur noch in deinem Crypsisb3 (tab BBcode) ganz untten das Wort custom eintragen. Das ist alles. Möglicherweise musst du danach den Browser Cache leeren, oder mit Strg+F5 neu laden.
Attachments:
The following user(s) said Thank You: Lollo_C

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #4 by Lollo_C
Hallo Rich,
vielen Dank. Damit hat es geklappt. 

Please Log in or Create an account to join the conversation.

Time to create page: 0.274 seconds