×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

Solved How to translate the new CK editor in Kunena 5.2.1?

More
8 months 3 weeks ago #1 by ciklon
Hello,
How to translate the new CK editor in Kunena 5.2.1?
I uploaded the required language .js  files from /ckeditor_4.15.1_standard/ckeditor/lang/ to site directory /media/kunena/core/js/ but the text of standard CK editor buttons remains in English.

Best Regards
The following user(s) said Thank You: Charles

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago - 8 months 1 week ago #2 by rich

from /ckeditor_4.15.1_standard/ckeditor/lang/ to site directory /media/kunena/core/js/ 

Should be /media/kunena/core/js/lang/ (but I think you only forgot to write here this complete path).
Afterwards should be this code in the ckeditor_config.js like this for German
config.language = 'de';
But I've tried it and are also not able to switch the language.
Last edit: 8 months 1 week ago by rich.

Please Log in or Create an account to join the conversation.

More
5 months 3 weeks ago - 5 months 3 weeks ago #3 by ciklon
Yes, I forgot to write the complete path.
CKeditor UI language can be changed with the "config.defaultLanguage" option. Example  in the ckeditor_config.js
config.defaultLanguage = 'de' ;

or
   CKEDITOR.lang.languages.de = 1;
   config.language='de';

But language auto-detect  for multilingual sites does not work.
Last edit: 5 months 3 weeks ago by ciklon.

Please Log in or Create an account to join the conversation.

More
5 months 3 weeks ago #4 by rich
config.defaultLanguage = 'de' ;
This should be the right code for multilingual web pages. But it's browser related and has nothing to do with the web page language.
Example: If the browser default language is German, you see the buttons in German language, also in the English section of your web page.
You can test it by change in your web browser the default language. You will see, it works.

Please Log in or Create an account to join the conversation.

More
5 months 3 weeks ago - 5 months 3 weeks ago #5 by ciklon
Hello,
The language of the editor remains the one set with this option regardless of the language of the browser or site.

Example (Screenshoot): Browser language - Bulgarian, selected site language - English, config.defaultLanguage = 'ru' ; (Russian) - Editor language remains Russian

An automatic browser language detection solution:
/media/kunena/core/js/ckeditor.js

On the last line
CKEDITOR.lang.languages={"en":1}

Replacement with
CKEDITOR.lang.languages={"af":1,"sq":1,"ar":1,"az":1,"eu":1,"bn":1,"bs":1,"bg":1,"ca":1,"zh-cn":1,"zh":1,"hr":1,"cs":1,"da":1,"nl":1,"en":1,"en-au":1,"en-ca":1,"en-gb":1,"eo":1,"et":1,"fo":1,"fi":1,"fr":1,"fr-ca":1,"gl":1,"ka":1,"de":1,"de-ch":1,"el":1,"gu":1,"he":1,"hi":1,"hu":1,"is":1,"id":1,"it":1,"ja":1,"km":1,"ko":1,"ku":1,"lv":1,"lt":1,"mk":1,"ms":1,"mn":1,"no":1,"nb":1,"oc":1,"fa":1,"pl":1,"pt-br":1,"pt":1,"ro":1,"ru":1,"sr":1,"sr-latn":1,"si":1,"sk":1,"sl":1,"es":1,"es-mx":1,"sv":1,"tt":1,"th":1,"tr":1,"ug":1,"uk":1,"vi":1,"cy":1}

For multilingual sites, when choosing a site language, the Kunena language is changed. I think that the editor should have the same language as the one chosen for the site and the forum - I need this in my case.

 
Attachments:
Last edit: 5 months 3 weeks ago by ciklon.

Please Log in or Create an account to join the conversation.

More
5 months 3 weeks ago - 5 months 3 weeks ago #6 by rich
config.defaultLanguage = 'de';
You're right, doesn't work as it should.



CKEDITOR.lang.languages={"af":1,"sq":1,"ar":1,"az":1,"eu":1,"bn":1,"bs":1,"bg":1,"ca":1,"zh-cn":1,"zh":1,"hr":1,"cs":1,"da":1,"nl":1,"en":1,"en-au":1,"en-ca":1,"en-gb":1,"eo":1,"et":1,"fo":1,"fi":1,"fr":1,"fr-ca":1,"gl":1,"ka":1,"de":1,"de-ch":1,"el":1,"gu":1,"he":1,"hi":1,"hu":1,"is":1,"id":1,"it":1,"ja":1,"km":1,"ko":1,"ku":1,"lv":1,"lt":1,"mk":1,"ms":1,"mn":1,"no":1,"nb":1,"oc":1,"fa":1,"pl":1,"pt-br":1,"pt":1,"ro":1,"ru":1,"sr":1,"sr-latn":1,"si":1,"sk":1,"sl":1,"es":1,"es-mx":1,"sv":1,"tt":1,"th":1,"tr":1,"ug":1,"uk":1,"vi":1,"cy":1}
This seems to be a good solution. I've added this code in the ckeditor_config.js, and it works as it should. It shows the buttons with the browser language.
It's better if you add this code to the config.js, because you can use the customized configuration file with a prefix. Then it will not override during Kunena upgrades (see here) .

For multilingual sites, when choosing a site language, the Kunena language is changed. I think that the editor should have the same language as the one chosen for the site and the forum - I need this in my case.

It does not work, because the CKEditor use an own script instead of .ini files for each language.
Last edit: 5 months 3 weeks ago by rich.
The following user(s) said Thank You: ciklon

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.167 seconds