×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

× Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese gestellt werden.
Aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern. Eröffnet dazu bitte ein eigenes neues Thema.

Question [noch nicht erledigt] Fehlermeldung nach login - fatal error: allowed memory size...

More
10 years 1 month ago - 10 years 1 month ago #1 by jamer
hallo leute!

ich habe ein problem mit meinem kunena forum. nach dem einloggen erscheint die fehlermeldung:

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 24 bytes) in /www/htdocs/w00ced05/libraries/joomla/html/html/select.php on line 36

also auf dem localhost lief es. dann war ich bei one.com, da gab es 34mb memory limit, da kam die gleiche meldung mit 34xxxxxx bytes, woraufhin ich dachte, es liegt am zu kleinen memory limit (da auch sämtliche hilfeforen immer nur einträge haben, in denen steht, dass man das memory limit erhöhen soll bei eigenem server oder einen provider mit höherem mem.limit suchen. letzteres habe ich getan. bin zu all-inkl.com, dort gibt es 64mb mem.limit und nun kommt die gleiche meldung. daher denke ich, dass es gar nicht am mem.limit liegt. das forum geht uneingeloggt einwandfrei, alle kategorien und öffentlichen beiträge sind zu sehen, nach dem login fehlt dann das css und es sind nur die reiterlinks zu sehen. dazu obige meldung. :unsure:

bevor ich den versuch mache und mein forum deinstalliere und ein leeres neues kunena installiere, um zu testen, ob ich mich problemlos einloggen kann, wollte ich fragen, ob das problem bekannt ist und ob mir jemand vielleicht weiterhelfen kann.

danke schonmal im voraus.
Last edit: 10 years 1 month ago by rich.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago - 10 years 1 month ago #2 by rich
Hallo jamer,

an all-inkl.com liegt es sicher nicht (mein Neffe betreibt bei denen eine Joomlaseite samt Forum). Ebenso kann ich mir nicht vorstellen, dass Kunena so viel Speicher verbraucht, dass das Limit überschritten wird.
Es könnte alles mögliche sein, was es verursacht. Hast du zusätzliche Plugins, oder Galerien installiert? Vielleicht wird auch durch ein zu großes Bild das Limit überschritten.

Die Anmeldung erfolgt über Joomla und wenn du die Standardeinstellungen beibehalten hast, landest du auf der Joomla Startseite. Ich kann es nicht mit Sicherheit sagen, ob dabei Kunena überhaupt schon mitgeladen wird.

Versuche mal alles, was du zusätzlich installiert hast, zu deaktivieren und auch nur die Standardtemplates zu verwenden. Wenn du Kunena zwecks testen deinstallierst, verlierst du keine Beiträge, wenn du es anschließend wieder installierst. Welche Versionen Joomla und Kunena benutzt du?

PS: Ich habe deinen Beitrag in die richtige Rubrik geschoben.

Gruß, rich
Last edit: 10 years 1 month ago by rich. Reason: Fehler behoben

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #3 by jamer
nun ja, in der hoffnung, dass alles besser wird, erstelle ich mein kunena forum neu. ich glaube, die fehlersuche würde genauso lange dauern. ich hatte nach dem exportieren auf den webserver so viele probleme, dass ich wahrscheinlich am besten fahre, wenn ich das alles auf dem webserver neu bearbeite. der all-inkl support tippt auf scriptfehler und ich glaube auch, dass es daran liegt. da ich nicht so viel ahnung von den details habe und gerne möchte, dass alles reibungslos läuft, bin ich jetzt schon dabei, alles neu zu machen. nach ersten versuchen kann ich mich auch ins kunena forum einloggen und alles läuft. habe aber auch erst 3 unterforen und keine posts und noch kein jomsocial drauf. vielleicht kommt der fehler nochmal. ich glaube und hoffe es aber nicht. danke trotzdem.

meine joomla version ist 1.5.20 und kunena war 1.5.11, jetzt 1.5.12.

eine frage hätte ich aber noch, auch wenn sie nicht hier her gehört. was ist das für ein login modul hier in diesem forum? das gefällt mir besser als der standard login, da ich auch jomsocial verwende.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #4 by rich
Danke für deine Rückmeldung. Vielleicht ist ja wirklich bei der Übertragung auf deinen Webserver etwas daneben gegangen.
Wenn du das Login-Modul meinst, welches hier im Forum zu sehen ist, dieses gehört zu Kunena 1.6.Nebenbei wird hier auch noch JomSocial verwendet.

Gruß, rich

PS: Habe dieses Thema in den "Erledigt" Bereich verschoben.
The following user(s) said Thank You: jamer

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #5 by jamer
verdammt, das thema ist leider noch nicht abgeschlossen. also wie schon erwähnt, habe ich mein kunena forum neu eingerichtet. jetzt bei ca. 3000 foren und unterforen wollte ich in der forum administration die listenansicht verändern von 20 auf alle, da kam plötzlich die gleiche fehlermeldung, die bei meinem alten forum nach dem einloggen im frontend auftauchte:

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 8026175 bytes) in /www/htdocs/w00ced05/libraries/joomla/document/html/html.php on line 389

ich wieder die listenansicht auf 20 gestellt. da ging es wieder. nochmal auf 100 probiert, kam die fehlermeldung wieder. danach nochmal auf 20 gestellt, dann bin ich aus der forum administration raus, bin in die konfiguration (wußte aber nicht, was ich da sollte, hab nix verändert), habe dann wieder versucht in die administration zu gehen und da kam auch obige meldung. von eben auf gleich, ohne dass ich was verändert habe. woran kann denn das liegen?

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago - 10 years 1 month ago #6 by rich
Hallo Jamer,

jetzt wo du schreibst "3000 Foren", nehme ich an, dass das Forum vorher richtig gelaufen ist. Deshalb wäre es gut zu wissen, seit wann es diesen Fehler gibt. Ist es erst seit Joomla 1.5.20.? Wenn ja, verwendest du ein anderes Temoplate als eines der Joomla Standard Templates? Ist JoomSocial auf dem neuesten Stand?

Joomla 1.5.19 und höher brauchen zum Betrieb Mootools 1.2 und es gibt einige Erweiterungen und Templates, die damit noch nicht zurecht kommen. Allerdings wäre deine Fehlermeldung in diesem Zusammenhang etwas ungewöhnlich.

Verzichte vorerst zum testen auf sämtliche Erweiterungen und schalte diese erst nach und nach dazu, vielleicht lässt sich so der Fehler rausfinden.

Da du auch eine lokale Installation betreibst, gehe ich davon aus, dass du schon etwas Erfahrung hast. Hast du schon mal Kunena 1.6 versucht?

Gruß, rich

Ps: Habe das Thema wieder zurück geschoben.
Last edit: 10 years 1 month ago by rich. Reason: Tippfehler korrigiert

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #7 by jamer
also richtig gelaufen ist es eigenltich nur auf dem localhost. wie beschrieben, hatte ich dann nach dem export auf one.com die ersten probleme. da ich dachte, deren memory limit von 34mb ist nicht ausreichend, bin ich zu all-inkl. dort lief das forum nach dem export auch nicht, woraufhin ich es neu erstellt habe. nun kommt diese meldung im backend und nicht, wie vorher, im frontend nach dem einloggen. der all-inkl support meinte, ich soll die listeneinstellung im backend auf 20 lassen, da "alle" zu viel speicher benötigt (wie ja auch diese meldung sagt). puh, nun gut, wenn es auf 20 einwandfrei funktioniert, ist es ok. ich vermute aber trotzdem irgendeinen fehler oder 3000 foren und unterforen sind tatsächlich zu viel. wenn ich im frontend mein forum aufrufe, dauert es auch 5 sekunden, bis es geladen ist. geht also nicht so fix wie hier :(

ich verwende das ja_purity template. kunena 1.6 habe ich noch nicht probiert, aber da die RC1 version nun da ist, wäre das mal nen versuch wert.

also solange im frontend alles funktioniert, bin ich ja beruhigt. aber die meldung gesatern bei der umstellung auf "alle" hat mich schon etwas nervös gemacht, da ich ja noch nicht fertig bin. ich probiere mal kunena 1.6, vielleicht hilft es.

ach ja, brauche ich dieses mootools 1.2 unbedingt? ich höre davon zum ersten mal. was kann denn das?

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago - 10 years 1 month ago #8 by rich
Naja, wenn du auf "alle" umstellst, wird zwar wirklich sehr viel (3000) angezeigt, aber der Fehler tritt bei dir bei 100 auch schon auf. Bei mir tritt dieses Problem bei all-inkl nicht auf, aber es gibt auch noch keine 3000 Foren. Vielleicht hängt es auch vom abonnierten Paket ab?

Ja, Joomla brauchst diese Mootools für den Betrieb (zu finden unter Plugins), aber es dürfte für dich kein Problem sein, da du das ja_purity Template verwendest.
Hier eine Beschreibung: de.wikipedia.org/wiki/MooTools

Falls du Kunena 1.6 samt JoomSocial verwenden willst, musst du vorher auf Jomsocial 1.6 upgraden, was (je nach deinen individuellen Einstellungen oder Änderungen) mit Aufwand verbunden sein kann.
www.kunena.com/forum/11-jomsocial/56706-...s-jomsocial-16#56706

Mindestvoraussetzung für K1.6 sind
PHP >= 5.2.3
MySQL >= 5.0.0
https://docs.kunena.com/index.php/Technical_Requirements

Aber auch diese müssten bei dir erfüllt sein, denn auch bei mir läuft K1.6 anstandslos.
Last edit: 10 years 1 month ago by rich. Reason: Ergänzung geschrieben

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago - 10 years 1 month ago #9 by jamer
also auf 100 kann ich umstellen, nur alle geht nicht. kunena 1.6 hat auch nicht geholfen, abgesehen davon, dass der aufruf des forums mit 1.6 fast 10 sekunden gedauert hat und noch paar kleine bugs zu sehen waren (u.a. bei der login funktion "remeber me" im frontend stand mod_login_irgendwas). habe es wieder deinstalliert und mein 1.5 backup installiert. ich hatte ja keine ahnung, dass die anzahl der foren nun doch so auf das memory limit schlägt. das scheint wohl nun die quintessenz des problems und der fehlermeldung zu sein. brauche wohl meinen eigenen server :D
Last edit: 10 years 1 month ago by jamer.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #10 by rich
Naja, 3000 Foren ist aber auch schon extrem viel. :D
Oder handelt es sich um Themen? Diese müsste der Server leicht schaffen.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.127 seconds