×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

Idea [Gelöst] SQL: Kompatibilität

More
11 years 7 months ago - 11 years 7 months ago #1 by dazzafact
Ok, das ganze zum noch mal in Deutsch. :silly:
Erhalte Fehler Sql Meldungen beim Forumabruf, jedoch nicht bei allen Seiten des Forums.
(php:5 mysql:5.0.67: Joomla:1.5.9)

Fehler auch hier zu sehen:
szczepan.info/joomla/community.html


Versuch der Behebung
-Frische Installation, nach Deinstallation des Fireboards und Löschung aller zugehörigen Ordner Tabellen etc von Fireboard.
-Unbennung der Präfixe bewirkt leider auch nichts in den Files:
components/com_kunena/template/default_ex/showcat.php
&
components/com_kunena/template/default_ex/latestx.php:
-Standart Präfix der Konfiguration: joomla_

Ähnliche Probleme andere Benutzer:
www.kunena.com/index.php?option=com_kune...nc=view&catid=4&id=9
www.kunena.com/index.php?option=com_kune...=view&id=800&catid=4



Fehlermeldungen:

variable value
$0 "
key value
$file "/www/htdocs/*****/joomla/components/com_kunena/lib/kunena.debug.php"
$line "36"
$function "debug_callstackinfo"
[args] Nested Array
"
$1 "
key value
$file "/www/htdocs/*****/joomla/components/com_kunena/lib/kunena.debug.php"
$line "45"
$function "trigger_dberror"
[args] Nested Array
"
$2 "
key value
$file "/www/htdocs/*****/joomla/components/com_kunena/template/default/latestx.php"
$line "61"
$function "check_dberror"
[args] Nested Array
"
$3 "
key value
$file "/www/htdocs/*****/joomla/components/com_kunena/kunena.php"
$line "763"
[args] Nested Array
$function "include"
"
$4 "
key value
$file "/www/htdocs/*****/joomla/libraries/joomla/application/component/helper.php"
$line "162"
[args] Nested Array
$function "require_once"
"
$5 "
key value
$file "/www/htdocs/*****/joomla/includes/application.php"
$line "124"
$function "renderComponent"
$class "JComponentHelper"
$type "->"
[args] Nested Array
"
$6 "
key value
$file "/www/htdocs/*****/joomla/index.php"
$line "68"
$function "dispatch"
$class "JSite"
$type "->"
[args] Nested Array
"

Fatal error: Unable to load messages.\nDB function failed with error number 1064
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT thread, MAX(time) AS lastpost FROM joom SQL=SELECT a.thread, a.subject, b.lastpost FROM joomla_fb_messages AS a JOIN ( SELECT thread, MAX(time) AS lastpost FROM joomla_fb_messages WHERE time >'1231500912' AND hold=0 AND moved=0 AND catid IN (1,2,3,5,4,6,7,8,9,10) GROUP BY 1) AS b ON b.thread = a.thread WHERE a.parent=0 AND a.moved=0 AND a.hold=0 GROUP BY a.thread ORDER BY b.lastpost DESC LIMIT 100
SQL =

SELECT
a.thread,
a.subject,
b.lastpost
FROM
joomla_fb_messages AS a
JOIN ( SELECT thread, MAX(time) AS lastpost
FROM joomla_fb_messa in /www/htdocs/*****/joomla/components/com_kunena/lib/kunena.debug.php on line 37

Last edit: 11 years 7 months ago by Lintzy.

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago - 11 years 7 months ago #2 by Lintzy
Replied by Lintzy on topic Re:SQL: Kompatibilität
Hast du mal versucht, Kunena direkt aus dem /tmp Verzeichnis heraus zu installieren?
Punkt 5.2.
Last edit: 11 years 7 months ago by Lintzy.

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago - 11 years 7 months ago #3 by dazzafact
Replied by dazzafact on topic Re:SQL: Kompatibilität
OK, vielleicht noch zu erwähnen: die Kompatibilität mit Jo! ist nicht gegeben bei der
kunena Version (Erweiterungen->Installieren/deinstallieren->Komponenten). Zeigt er mir jedenfalls an (rote Kreuz). Das hat aber sicherlich nichts zu sagen(?)

Also die Installation aus dem Verzeichnis hat auch nichts gebracht....
Last edit: 11 years 7 months ago by dazzafact.

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago - 11 years 7 months ago #4 by Lintzy
Replied by Lintzy on topic Re:SQL: Kompatibilität
Das rote Kreuz bedeutet nur, dass es nicht native kompatibel ist, sondern nur im legacy Modus läuft. Von welcher Version Fireboard (alt) hast du installiert? Wenn das kleiner als Fireboard 1.05 war, dann hättest du erst auf 1.05 upgraden müssen, um die Datenbankstruktur zu erhalten.

Hast du dieselben Fehler bei einer vollkommenen Neuinstallation?

1. Erst mal Kunena über das Joomla Backend deinstallieren.

Dann nachschauen ob noch Reste der alten Installationen vorhanden sind: Also folgende files/Ordner auf dem Server löschen:

2. Ordner com_kunena in / components/
3. Ordber com_kunena in /administrator/components

Fireboard Reste löschen (bitte vorher sichern, falls du sie noch brauchst)

4. Ordner com_kunena in / components/
5. Ordber com_kunena in /administrator/components

Und in der Datenbank (6. immer vor Arbeiten an der Datenbank eine Sicherung machen!)

7. Alle Tabellen die mit jos_fb_ beginnen löschen

und du hattest geschrieben, den Präfix verändert zu haben,
8. diese Tabellen auch löschen

9. Testen ob dein Joomla so noch funktioniert, falls nicht mehr, dann gesicherte Datenbank wieder importieren :side: und noch mal oben genannte Tabellen löschen, vielleicht hattest du vorher irgendwas zuviel gelöscht.

10. Dann über den /tmp Ordner auf dem Server Kunena neu installieren. Ich drück dir die Daumen.
Last edit: 11 years 7 months ago by Lintzy.

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago - 11 years 7 months ago #5 by dazzafact
Replied by dazzafact on topic Re:SQL: Kompatibilität
Ok, habe jetzt mal alles Frisch aufgesetzt Joomla 1.5.9 + Kunena 1.06
Siehe da,..... auch das geht nicht. :laugh:

Mein Hoster All-inkl.com ist eigentlich sehr Zuverlässig.
.

Mhh,... auf eine manuelle Bugbehebung vom Admin zu warten ist wohl Zeitraubend, der hat sicherlich einiges anderes zu tun. Hoffentlich wird das Problem mit einbezogen in einer neueren Version von Kunena. Habe jedenfalls de, Admin schon mal meine Ftp Daten geschickt in der Hoffnung er kümmert sich drum. Ist ja fast wie Weihnachten, hoffentlich kommt der Weihnachtsmann mit Geschenken.
Last edit: 11 years 7 months ago by dazzafact.

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago - 11 years 7 months ago #6 by Lintzy
Replied by Lintzy on topic Re:SQL: Kompatibilität
Bei Allinkl.com war ich auch mal. Sag mal, das ist jetzt kein Problem mit wwwrun-user und ftp-user oder? :laugh: Also ein Problem mit den Besitzrechten? Allinkl.com hat dazu eine sehr schöne Anleitung erstellt.

Würde in deinem Fall bedeuten, du musst für Joomla die Rechte des kompletten Joomla-Verzeichnisses rekursiv auf wwwrun stellen.
Last edit: 11 years 7 months ago by Lintzy.

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago - 11 years 7 months ago #7 by dazzafact
Replied by dazzafact on topic Re:SQL: Kompatibilität
Wie kommst du darauf? In allen Php Fehlermeldungen ist nicht die Rede von Pemission Problemen, nur von SQL Probs?
Last edit: 11 years 7 months ago by dazzafact.

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago #8 by Matias
Replied by Matias on topic Re:SQL: Kompatibilität
I'm a bit slow to read German (so I just went quickly through all messages), but the error message said that there is a syntax error in SQL query. I ran it in my local computer with MySQL 5.0.67 (Ubuntu) and there was no error. Very odd.

Do you have access to phpMyAdmin or similiar? Try to run these queries in there:

If this doesn't work, your installation has failed:
SELECT * FROM joomla_fb_messages LIMIT 1

These are to locate the problem:

SELECT a.thread, a.subject FROM joomla_fb_messages AS a WHERE a.parent=0 AND a.moved=0 AND a.hold=0 GROUP BY a.thread LIMIT 100

SELECT thread, MAX(time) AS lastpost FROM joomla_fb_messages WHERE time >'1231500912' AND hold=0 AND moved=0 AND catid IN (1,2,3,5,4,6,7,8,9,10) GROUP BY 1

SELECT a.thread, a.subject, b.lastpost FROM joomla_fb_messages AS a JOIN ( SELECT thread, MAX(time) AS lastpost FROM joomla_fb_messages WHERE time >'1231500912' AND hold=0 AND moved=0 AND catid IN (1,2,3,5,4,6,7,8,9,10) GROUP BY 1) AS b ON b.thread = a.thread WHERE a.parent=0 AND a.moved=0 AND a.hold=0 GROUP BY a.thread ORDER BY b.lastpost DESC LIMIT 100

Any results?

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago - 11 years 7 months ago #9 by dazzafact
Replied by dazzafact on topic Re:SQL: Kompatibilität
All works, without the last query.
Here is the Sql Error:

Error

SQL query: Documentation

SELECT a.thread, a.subject, b.lastpost
FROM joomla_fb_messages AS a
JOIN (

SELECT thread, MAX( time ) AS lastpost
FROM joomla_fb_messages
WHERE time > '1231500912'
AND hold =0
AND moved =0
AND catid
IN ( 1, 2, 3, 5, 4, 6, 7, 8, 9, 10 )
GROUP BY 1
) AS b ON b.thread = a.thread
WHERE a.parent =0
AND a.moved =0
AND a.hold =0
GROUP BY a.thread
ORDER BY b.lastpost DESC
LIMIT 100


MySQL said: Documentation
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT thread, MAX(time) AS lastpost FROM joomla_fb_messages WH

Last edit: 11 years 7 months ago by dazzafact.

Please Log in or Create an account to join the conversation.

More
11 years 7 months ago #10 by Matias
@ Lintzy: did you post this one in English? It is installation timeout problem. You need to add php timeout to 60-90 secs during installation.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.114 seconds