×
Kunena 5.1.13 Released (21 Jul 2019)

The Kunena team has announce the arrival of Kunena 5.1.13 [K 5.1.13] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question [Merged Topic] JFolder::create: Could not create directory

More
8 years 10 months ago #1 by Avivatech
please any one know how to avoid this then please reply me.

* JFolder::create: Could not create directory
* Component Install: Failed to create directory.: "/Library/WebServer/Documents/Aetat.info/administrator/components/com_kunena"

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #2 by fxstein
Please post your support requests and questions for the community in the appropriate categories of our site. Dis discussion if for comment about a recent blog post about site updates. Thx!

PS: You problem is permissions related. The permissions in your folders are incorrect, that's why joomla fails trying to install a new component.

We love stars on the Joomla Extension Directory . :-)

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago - 8 years 10 months ago #3 by SEGa
Installation com_kunena_v1.6.0_b3620_2010-10-03 processed without any problems. All worked good exept an error message "JFolder::create: Could not create directory" in all pages with forum. On witch folders I must made permissions to escape this problem?
Attachments:
Last edit: 8 years 10 months ago by sozzled. Reason: Changed subject to improve the relevance in searching

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #4 by sozzled

SEGa wrote: On which folders I must made permissions to escape this problem?

Answer: all folders.

See Securing Kunena

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago - 8 years 10 months ago #5 by SEGa
Witch folders using Kunena? And need to be 777 or may be 775? Thank you
Last edit: 8 years 10 months ago by SEGa.

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago - 8 years 10 months ago #6 by SEGa

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Disabled or not installed | UddeIm: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Disabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed

Modules: Kunena Latest: Disabled or not installed | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Last edit: 8 years 10 months ago by xillibit. Reason: report configuration broken

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #7 by SEGa
please help me! :(
I found that possible problem with folders for avatars, but any idea where is it...

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago - 8 years 10 months ago #8 by xillibit
The directory for avatar aren't created on each kunena page, check this directories and all the subdirectories :

/media/kunena
/administrator/components/com_kunena
/components/com_kunena

I don't provide support by PM, because this can be useful for someone else.
Last edit: 8 years 10 months ago by xillibit.
The following user(s) said Thank You: SEGa

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #9 by SEGa
It work now! Thank you very much!
But here one more q... It is bad for security if I changed permissions to 777 for all this folders? And if yes how to escape this problems?

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago - 8 years 10 months ago #10 by fxstein
No - never use 777 on any folder on any webserver. Its a bandaid to a different underlying problem.

You should be running 644 on most or all folders, but what you need to check is what is the userid and group of your apache server user. You then need to make sure that user is the owner of all files within the httpdocs folder of your server. Lets assume your server uses 'apache' as the user and 'apache' as the group.

JUST AN EXAMPLE:
You would run a recursive
chown -R apache:apache *
against the content of httpdocs as well as
chmod -R 644 *

But you need to replace userid and group with the actual one from your server.

777 means that any and all processes on that server can write and change your website.

As an alternative you can configure Joomla to use ftp to access the underlying file system - in case you cannot change the users to the apache id and group. Please see the Joomla documentation on how to configure and turn this on.

Hope this helps!

We love stars on the Joomla Extension Directory . :-)
Last edit: 8 years 10 months ago by fxstein.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.196 seconds