×
Kunena 5.2.5 and Blue eagle 1.6.5 released (30 May 2021)

The Kunena team has announce the arrival of Kunena 5.2.5 [K 5.2.5] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.5

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with, this template isn't designed to works with Bootstrap 3 and Bootstrap 4.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question Few bugs I have come across as well as anoyances

More
10 years 8 months ago - 10 years 8 months ago #1 by weise
Hello all,

Firstly Iam impressed with the forums style/features (Welldone)

I will start with some issues I have found that are annoying me.

logging in seems to have a few problems , users sometimes have to login twice before they are logged in.

I have tested this extensively and cannot quite see why this happening.




secondly when logged in as std user (admin user not effected) I notice this issue;
which is caused in the lattest forums section module published to the (left) column



I use the latest 1.6 version with community builder
config below;



next formatting / annoying links and other odd things that are not easily fixed;

The (code)etc(/code)
template specific changes make this look hidious...
tags ... have this lite yellow BG with Light Grey Text .... I can not find where to change this hidious combination to my own custom colour settings...possibly through configuration panel?

The (spoiler)etc(/spoiler)
Warning: Spoiler!
tags ... I would like to Change the text to something else but am not able to do so .

the (hide)etc(/hide) feature


Part of the message is hidden for the guests. Please log in or register to see it.


I thought as a addon in the future you could set this up like other type systems where users need to either reply or click on the 'thank you' button to reveal the <hidden> text , also wondering about a hidden moderator type text feature perhaps.

Emoticons: this feature I love and also hate. I like the fact that you can upload smilies and assign them to words like 'omg' and 'a rose' and assign custom smiles to them , as well as being able to not-publish them to the Emo toolbar inside the editor :)

however it is cumbersome and annoyingly slow process to implement. could I suggest that you add a few columns to it with check box's 'tick'/'cross' to enable disable and publish these icon's in the future release?

Finally Branding:

I know how important it is to brand your software but having 10,000 links to this forum is really asking for trouble in a 'forum' situation.

all forums attract the wrong people who have insight into things like , hacking Exploiting and Injecting various attacks to gain access to sensitive data. Personally I remove all Branding so that they do not know what Iam using as this blocks the lamer uneducated hacker types from sploiting the forum . As well as removing Version Specific data from the board so that they can't type into google ;

exploit kunena 1.6 forums

and find a way in through there.

Iam having trouble however removing the email link back to these forums which I also find to be a security risk and notice that you have made it difficult to find all the little links to here...

that is my no.1 priority atm . I know that branding is important but Obfuscation is even more important in this game ..

my 20cents thanks.

just found another problem ,

theres is no delete button to remove attachments; however unticking and submitting seems to be a temp work around for this.


please note that this is a ruff writeup and I inntend to revise it at a later stage.. for the time being Iam trying to find fixes for all of the above problems.
Attachments:
Last edit: 10 years 8 months ago by weise.

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago - 10 years 8 months ago #2 by sozzled
Thank you. Unfortunately your long list of questions will require a fair stretch of time to properly answer. For my part, I would like to deal with them gradually over time - the next few days. In the meantime, I would also invite other users to answer those questions that they feel they can handle. This is such a long and involved topic that it could take several weeks before it is completely dispensed with. This is also one of the main reasons why we encourage users to post a single question per topic.

Because I am not sure which issues are defects (or bugs) and what are issues where something is broken or where some features are, as you described them, mere annoyances, I have decided to move this topic to the Common Questions category.

One very quick matter that I would like to address now is the first question you asked, about login.

Kunena is not responsible for user registration, login or logout. These are Joomla features; these are features that may (or may not) be assisted by additional components that you may have chosen to install and integrate with Kunena; these may be features that are incorporated into components like JomSocial or Community Builder. It is possible that the problems you have may be caused or exacerbated by such other components - components that you have not mentioned in your account. It would be good to know what other components you have installed that may interfere or impact on this user login issue that you described.

We also encourage users to provide a copy of their configuration report. Giving us your configuration report saves you time and saves us the time asking you for it. Please remember this in future when you post messages in the Support category. Thank you. B)

Last, but not least, welcome to Kunena! :)
Last edit: 10 years 8 months ago by sozzled.
The following user(s) said Thank You: weise

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago - 10 years 8 months ago #3 by weise
hi there , thanks for the sugestions :).

where does one find this report mentioned. also yes I think the login part is just a misconfiguration of probably the CB component.

after using these boards Iam wondering if the cb plugin is still needed?.. as you seem to have covered all / most of what it contains in these excellent forums.

Just a off-topic question.

Where are the modules for the about-me/friends & Groups that you have in your profile?.. are these separate components for Kunena or are they from joomsocial/cb?

thanks
Last edit: 10 years 8 months ago by weise.

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago - 10 years 8 months ago #4 by sozzled
Ah yes, well I can see that this one discussion topic could possibly cover several different categories.

weise wrote:

where does one find this [K 1.6 configuration] report?

The details are provided in one of the sticky posts in the Support category - looking at sticky posts is something you will need to develop the habit of doing. You will find more expansive instructions here: K 1.6 Configuration Report .

weise wrote:

I think the login part is just a misconfiguration of probably the CB component.

There's some help here for users of Community Builder but we're not the CB support forum. If the questions you have are not answered by browsing/searching through the Community Builder category , you should address your questions to our good friends at Joomlapolis .

weise wrote:

after using these boards Iam wondering if the cb plugin is still needed?

Community Builder is, strictly-speaking, a Joomla component; the CB component has a number of optional modules, plugins and add-ons that you may or may not find useful. Again, these are a matter of personal choice whether you decide to use or not use any or many of them.

weise wrote:

Just a off-topic question: Where are the modules for the about-me/friends & Groups that you have in your profile?

:laugh: I'm still trying to find what is the topic here! However, your question is a commonly-asked one and is answered by this sticky topic: [Merged topic] Kunena Web Site: What components and modules are used at www.kunena.com?
Last edit: 10 years 8 months ago by sozzled.
The following user(s) said Thank You: weise

Please Log in or Create an account to join the conversation.

More
10 years 7 months ago #5 by weise
Sorry about this sozzled , but your avatar is really annoying :S

After seeing it some 400 times I can't get the ugly thing out of my head (nightmares even) :laugh:

Just thought I'd let ya know.

;)

Please Log in or Create an account to join the conversation.

More
10 years 7 months ago #6 by fxstein

Sorry about this sozzled , but your avatar is really annoying :S

After seeing it some 400 times I can't get the ugly thing out of my head (nightmares even) :laugh:

Just thought I'd let ya know.

;)


Hahahaha... that is too funny. That Iron must be inside my forehead by now... ;-)

We love stars on the Joomla Extension Directory . :-)
The following user(s) said Thank You: weise

Please Log in or Create an account to join the conversation.

More
10 years 7 months ago - 10 years 7 months ago #7 by sozzled
Last edit: 10 years 7 months ago by sozzled.
The following user(s) said Thank You: weise

Please Log in or Create an account to join the conversation.

More
10 years 7 months ago #8 by weise

Please Log in or Create an account to join the conversation.

More
10 years 7 months ago - 10 years 7 months ago #9 by sozzled
Aside from the peanut gallery's running commentary on my avatar image, there has been a resounding silence in response to my puny attempts to deal with the overwhelming number of issues covered by this one topic. It would be nice to know how I've "scored" with any of my earlier answers to weise's questions, should I continue to wait for an answer, or should I go on further?

I will try to deal with one more, for the time being, to see what response follows.

Formatting / annoying links and other odd things that are not easily fixed:

The (code)etc(/code)
template specific changes make this look hideous...
tags have this light yellow BG with light grey text. I can not find where to change this hideous combination to my own custom colour settings.

I infer this as a general comment either about the visual appeal of the template or about the difficulty you are having in changing the colours to suit your needs.

As far as the visual appeal is concerned, as I wrote yesterday, "beauty is in the eye of the beholder" and what may appeal as unattractive or inappropriate to you may be ideal for someone else.

As far as the general approach to changing colours and other formatting attributes is concerned, using Firebug for Firefox makes it child's play to see where and how you can change what's displayed on web pages. The relevant light grey and orange colours (in the above example) are generated by the Kunena template CSS (I've hilighted the relevant lines in red

#Kunena div.kmsgtext pre, #Kunena div.kmsgtext code {
border-color:#BFC3C6 #BFC3C6 #BFC3C6 #F4A94F;
border-left:5px solid #F4A94F;
border-right:1px solid #BFC3C6;

border-style:solid;
border-width:1px 1px 1px 5px;
font-family:"Courier News",Courier,monospace;
font-weight:normal;
line-height:1.5;
margin:3px 0 10px;
max-height:25em;
overflow:auto;
padding:10px 15px;
width:auto;
word-wrap:normal;
}

Browsing either the Templates and Design categories in this forum or the companion Wiki site will provide you with a treasure trove of information to show you how easy it is to change the template.
Last edit: 10 years 7 months ago by sozzled.
The following user(s) said Thank You: weise

Please Log in or Create an account to join the conversation.

More
10 years 7 months ago - 10 years 7 months ago #10 by weise
thanks mate , yep I've got that bit sorted I should have mentioned. However the data is somewhat Squished for some reason... would you be able to upload (attach) a properly formatted version , I assume that it would be caused by some char-set conflict as this is how my Kunena template CSS;
"../../default/images/icons/rss.png") no-repeat left center;width:24px;height:24px;margin:5px 5px 0 -29px;}#Kunena div.krss-block{float:right;}#Kunena span.kforummoderated{background:url("../../default/images/icons/tmoder.gif") no-repeat left center;width:16px;height:16px;}#Kunena span.kreadforum,#Kunena span.knotloginforum{background:url("../../default/images/icons/folder_nonew.png") no-repeat left center;width:32px;height:32px;}#Kunena span.kunreadforum{background:url("../../default/images/icons/folder.png") no-repeat left center;width:32px;height:32px;}#Kunena span.kreadforum-sm,#Kunena span.knotloginforum-sm{background:url("../../default/images/icons/folder_nonew_sm.png") no-repeat left center;width:12px;height:12px;}#Kunena span.kunreadforum-sm{background:url("../../default/images/icons/folder_sm.png") no-repeat left center;width:12px;height:12px;}.kgooglemap{width:100%;background-color:#E5E3DF;display:block;height:480px;overflow:hidden;position:relative;}.kgooglemap img{max-width:none;}#Kunena div.kmsgtext-article, #Kunena div.kmsgtext-quote, #Kunena div.kmsgtext-hide, #Kunena div.kmsgtext-confidential {background:none repeat scroll 0 0 #383535;border:1px solid rgba(0, 0, 0, 0.2);}#Kunena td.kmessage-right div, #Kunena td.kmessage-left div, #Kunena td.kmessage-top div, #Kunena td.kmessage-bottom div {background:none repeat scroll 0 0 #383535;}#Kunena fieldset {background-color:#383535}#Kunena div.kmsgattach {background:none repeat scroll 0 0 #383535;}

so it is a little bit difficult to navigate , however you will notice that I have appended the changes to the bottom.

I have found a away around most of the above issues by simply re-installing and removing CB which tbh is a little outdated and 'not really my style' shall we say.

Only pending issues that Iam having now is more formatting which Iam fixing through the methods you suggested.

how ever I can-not find the spoiler/hide information so that I can customize the message's for each of these.

as well as remove the kunena link from the email.

I don't mind having the powered by Kunena on the Front page of the Forums but in the mail is not a good idea. we have been under alot of attacks lately by certain individuals who feel that DDOS is how you can get attention. And I feel vulnerable knowing that it these idiots sign up and subscribe to my website then it is only a matter of time before they find some way of exploiting the forum... Iam at odds with weather to continue using Kunena or Bridging PHPBB3 into my current site.

I love the look and feel of Kunena but I like the Security of PHPBB3 and if I could afford it I would probably settle for IPB...

However this not the case and I will take what I am given at this stage.

Much appreciated for the Help IRON_MAN ;)

I will go through and see if I can answer the questions I poised earlier at some stage.

I am also wondering if it is my host or the forum as pages are already slowing down (loading) and I haven't even started lol. (couple of posts/sections & Categories) but that's it.

if you would like to see the website in mention then feel free to visit here


Cheers.
Last edit: 10 years 7 months ago by weise.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 1.159 seconds