×
Kunena 5.1.12.1 Released - Security release (22 Apr 2019)

The Kunena team has announce the arrival of Kunena 5.1.12.1 [K 5.1.12.1] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a security release.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved Kunena display component in link instead of forum [RESOLVED]

More
7 years 3 days ago - 7 years 16 hours ago #1 by nesh_bros
Hi Kunena,
I installed Kunena, copy Kunena menu items in main-menu and name it forum.

domain.com/forum - when I click it forum opens, but when I click on any link inside forum I have:
domain.com/component/..

I need forum insted of component in link. I guess its something in menu settings but I try everything for the past 4 hours and nothing.

My config:
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 64M

Kunena menu details:
Warning: Spoiler! [ Click to expand ]

Joomla default template details : natabanu | author: Goran Neskovic | version: 2.0.0 | creationdate: 2012-May-25

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.2 | creationdate: 2012-01-31

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None

Last edit: 7 years 16 hours ago by nesh_bros.

Please Log in or Create an account to join the conversation.

More
7 years 3 days ago #2 by Matias
Looks like your menu is slightly broken. I would remove the item you added and change forum2 in Kunena menu back to forum. Then find unpublished menu item in your default menu (called Forum) and publish it.

Please Log in or Create an account to join the conversation.

More
More
7 years 2 days ago #4 by nesh_bros

Matias wrote: Looks like your menu is slightly broken. I would remove the item you added and change forum2 in Kunena menu back to forum. Then find unpublished menu item in your default menu (called Forum) and publish it.


I have published everything in kunena menu. In main menu I add new menu with external link: domain.com/forum and when I click it I get: domain.com/forum but when I click on any category or link I get component/kunena

Is there any code I can put in .htaccess to rewrite that?

Thanks!

Please Log in or Create an account to join the conversation.

More
7 years 2 days ago #5 by sozzled

nesh_bros wrote: In main menu I add new menu with external link: domain.com/forum ...

We do not recommend using the menu item type of "External URL". By default, when you first install Kunena, the Kunena menu is added for you and a menu item is created (but left unpublished in case you want to move it elswhere). If you want to create your own custom menu then you should read Customised menus . I hope this helps.

Please Log in or Create an account to join the conversation.

More
7 years 1 day ago #6 by nesh_bros
Hi sozzled,
I do external link because I cant use same alias twice, but like you said, I can move your menu and get rid of this menu item BUT I already try this, I still have unwanted "component/kunena" in link instead of just "forum".

Can you advise on this one?

Thanks.

Please Log in or Create an account to join the conversation.

More
7 years 1 day ago #7 by sozzled
I did advise. You don't use External URL. You use Alias Menu, as it says to do in Customised menus

Please Log in or Create an account to join the conversation.

More
7 years 1 day ago #8 by nesh_bros
It would not work, I already try that before I report it on forum.

When I did that and click on link in menu I get domain.com/forum but when I click on every other link in menu its component/kunena..

Please Log in or Create an account to join the conversation.

More
7 years 1 day ago #9 by nesh_bros
Hi,
I used:

redirect /component/kunena/ www.domain.com/forum/

in htaccess file. Is this good solution?

Meny thanks!

Please Log in or Create an account to join the conversation.

More
7 years 21 hours ago #10 by nesh_bros

nesh_bros wrote: Hi,
I used:

redirect /component/kunena/ www.domain.com/forum/

in htaccess file. Is this good solution?

Meny thanks!


No, its not. :) Visitors can not make posts with this solution.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.110 seconds