×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question Category Icons Keep Disappearing

More
8 years 3 months ago - 8 years 3 months ago #1 by AndyInSpain
Hi all,

A weird one this. Our installation of K1.6.5 was chugging away quite happily, using the default (Blue Eagle) template when, for no apparent reason, the category icons disappeared from the front end, even though they were still on the server (i.e. they hadn't been deleted in error).

I failed to find a reason for this. I reinstalled K1.6.5 but no difference - the icons were still missing. So I switched to using the Example template, just to see what would happen. The icons were there. So I decided to use the Example template until I could solve the problem with Blue Eagle.

But then, a few days later, the category icons disappeared from the Example template too. For no apparent reason.

I then tried another template called Euro Blue - and a few days later the same thing happened. Then I tried two more templates and the same thing happened - after a few days (the number of which varies) the category icons disappear.

If I switch from the current template (where the icons are visible) back to one I had problems with, the icons are not visible. In other words, once the category icons are dead in a particular template, they stay dead.

This is such a bizarre problem that I just don't know where to start looking. The path to the category icons remains unchanged ("category_images/").

Does anybody have any idea about solving this one?

Many thanks

Andy

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 10M

This message contains confidential information

Joomla default template details : jsn_epic_pro | author: JoomlaShine.com | version: 4.2.0 | creationdate: 06/22/2011

Kunena default template details : KProSilver | author: ExtensionTemplates.com | version: 1.6.2 | creationdate: 2011-01-01

Kunena version detailled: Installed version: 1.6.5 | Build: 5005 | Version name: Babel | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: UddeIm

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Enabled | System - Mootools12: Disabled

Modules: Kunena Latest 1.6.4

Last edit: 8 years 3 months ago by AndyInSpain.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #2 by sozzled
"Example" template: please read my comments >>> here <<<

Setting up category icons: see Category icons

"No apparent reason": I do not believe in ghosts; everything has a reason. We're here to answer questions about the software that is designed, developed and maintained by the Kunena project. Your configuration report shows that you are using a third-party template. If you have a problem with running Kunena with a third-party template then you should address your issues to the author(s) of that template.

As the release notes for all recent releases of Kunena have consistent stated, "Some users of third-party templates written for older versions of Kunena will find that their templates may not work with this latest release because changes were necessary in order to fit with the new J! 1.6/1.7 CMS." This will probably be more starkly realised when K 1.7 is released soon.

I'm sorry, I don't have any other suggestions at this time, except to advise that you use the Blue Eagle template and follow the advice given in Category icons .

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #3 by AndyInSpain
But as I said in my post, Sozzled, I was using the Blue Eagle template when the problem started. I want to keep using the Blue Eagle template because it's perfect for our use and our site members love it. But as it stands, its category icons don't work. I shall read your comments about category icons.

I said "apparent reason" because that's what it is: a problem which, on the face of it, has no discernible cause, for example changes in site configuration or the addition of extra components. Of course the problem has a cause. And I have only used 3rd party templates in an effort to keep the forums online rather than take them offline while the problem is solved.

Many thanks for your help

Andy

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #4 by sozzled

AndyInSpain wrote: The path to the category icons remains unchanged ("category_images/")

Your images need to be located in <root>/media/kunena/category_images/

Now, when I go to your website (as I did about 2 minutes ago) I see category icons. So, can you please show us what the situation looks like with the Blue Eagle template. I am trying to understand what you mean by these images "disappearing". I mean, do you see nothing, at all?

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #5 by AndyInSpain
The current template is now Blue Eagle. Thanks Sozzled!

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #6 by sozzled
Your site shows the following information:
#Kunena span.kreadforum, #Kunena span.knotloginforum {
    background: url("&amp;amp;quot;../images/icons/folder_nonew.png&amp;amp;quot;") no-repeat scroll left center transparent;
    height: 32px;
    width: 32px;
}

This website ( www.kunena.org ) defines this thing as follows:
#Kunena span.kreadforum, #Kunena span.knotloginforum {
    background: url("../images/icons/folder_nonew.png") no-repeat scroll left center transparent;
    height: 32px;
    width: 32px;
}
Therefore, somewhere, you've got these extra characters being inserted into the "background: url(/ ...)" rule. I don't know how that can happen.

My advice is to put your Kunena configuration settings back to their default values. Do you know how to do that?
The following user(s) said Thank You: AndyInSpain

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #7 by AndyInSpain
That's weird. And those extra characters are being inserted only after using a template for a few days.

I shall indeed try resetting the configuration....yes, I know how to do that.

Many thanks for your help, Sozzled...let's hope that cures it!! If not, I wonder where we go from there.....

Take care

Andy

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago - 8 years 3 months ago #8 by sozzled
Please try it. If it doesn't work, it may mean that there's something missing, changed or incomplete with your Kunena installation. A re-install of Kunena should fix that problem (you won't lose any messages if you follow the K 1.6 and K 1.7 Upgrade Guide )
Last edit: 8 years 3 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #9 by Matias
You must have some kind of caching that messes up our CSS file. The original file is still OK as the URL gets corrected when you change the template. Check what's different in our CSS and the others on URLs..
The following user(s) said Thank You: AndyInSpain

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #10 by AndyInSpain
Thanks guys. I had a nasty operation in hospital today (laptop currently bslanced on knee in hospital bed!) so as soon as I am a bit better I will investigate your suggestions. Broken ankle and tibia, 14 steel pins now holding everything together. And on my 10th wedding anniversary too!

All the best

Andy.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.110 seconds