×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Forum not working: Fatal error: Call to undefined function KUNENA_get_menu()

More
9 years 10 months ago #1 by ae3d
no idea what this is caused by.

i have to do a manual installation of kunena
seems like it worked but let me start this by asking a question

this is version 1.5.12
my DB is 5.1.26
PHP is 5.2.14
joomla version is Joomla! 1.5.15 Stable

when i log into backand and scroll over "COMPONENTS" then down to " KUNENA"
should it have any sub menus inside KUNENA ?
because mine doesnt.

After intallation i created a menu item to get to the forums
when i click it i get this

Fatal error: Call to undefined function KUNENA_get_menu() in /my server root path/my domain name.com/html/site/components/com_kunena/kunena.php on line 490

its just on a white screen.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #2 by xillibit
Hello,

What do you call manual installation ?

Do you have access to the kunena configuration panel in backend ?

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: neli

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #3 by ae3d
i had to upload the kunena folders into the temp directory
then do a install via directory

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #4 by sozzled
Is there some reason that is preventing you upgrading your website to J! 1.5.21? Is this your first Kunena installation on your website? Why did you consider it necessary to install in the way that you did? It seems to me that the installation procedure was unsuccessful. I would also encourage you to consider K 1.6.0 instead of K 1.5.12

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #5 by ae3d

sozzled wrote: Is there some reason that is preventing you upgrading your website to J! 1.5.21? Is this your first Kunena installation on your website? Why did you consider it necessary to install in the way that you did? It seems to me that the installation procedure was unsuccessful. I would also encourage you to consider K 1.6.0 instead of K 1.5.12


not sure of these questions. They dont seem to help with the error but heres your answers mr Led ;)

Is there some reason that is preventing you upgrading your website to J! 1.5.21?
had a problem running it on this server environment and the plugins / modules id like to use ( a few ) wont work with that J Version

Is this your first Kunena installation on your website?
On this particular website yes. Sort of
i tried installing K6 but it didnt work and i realized it was because of the J! version.
So i tired it uninstall it and had problems so i found all the Kunena folders and files and deleted them
then i went into the SQL DB and removed all tables that Kunena 6 creates

Why did you consider it necessary to install in the way that you did?
Because it wouldnt install via the common BROWSE FOR FILE method

It seems to me that the installation procedure was unsuccessful.
I can agree to that. Once i did the installation of Kunena here
i was able to read the SUCCESSFUL INSTALLATION screen that shows up when you have a..well... successful install

I would also encourage you to consider K 1.6.0 instead of K 1.5.12
I cant use that version with this version of J!

i have it working fine together on another server


On my other server i have
Kunena 1.5.12
DB version 5.0.91 community
PHP version 5.2.12
Joomla! 1.5.15 Stable

the only differance between the two is the DATABASE VERSION

Im not sure how any of these answers bring us any closer to the goal?

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #6 by sozzled
From the responses you gave I would have to agree with your basic conclusions. The web server that you are trying to use to host Kunena is not up to the task. If you have Kunena working OK on a different server then this supports those conclusion, too. You have basic problems running Joomla; these are the issues that need your focus. Your Kunena problems are incidental to more serious problems. I strongly suggest that you discuss your Joomla issues at the Joomla support forum ... or look for a webhosting service provider who gives you the assurances that you need in order to run J! 1.5.21.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #7 by ae3d
sorry Led
thats not so ( having problems running Joomla )
im already running J! on this ssrver for a different client
Its been running fine for about 7+ months
that particular installation is not using Kunena

this is the only one im going to be using Kunena on.

I just did a complete removal and install again and i an on this success screen which reads:
I N S T A L L : Successful

php version: 5.2.14 (Required >= 5.0.3)
mysql version: 5.1.26-rc-5.1.26rc (Required > 4.1.19)
Thank you for using Kunena!
Kunena Forum Component for Joomla! © by www.Kunena.com . All rights reserved.

As a matter of curiosity, what is it that makes you believe this installation was incomplete or unsuccessful per your previous statement?
Im asking because maybe you see something i dont which i should know of when doing these installs

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #8 by ae3d
i also wanted to say

when i goto my COMPONENTS after the kunena install
i can click on KUNENA and change its configurations, settings, add forums and so on.

It works
i just cant see it from the front end

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #9 by ae3d
ok i went ahead and upgraded my joomla version to 1.5.21
and removed everything Kunena related ( filee, links, folders, and SQL tables )
then i started the install process for Kunena 1.6.0_b3620

Here is what i got

Upon using the UPLOAD feature under INSTALL / UNINSTALL in the backend
i got this screen

1) Select an Installation or Upgrade Option
The Kunena forum has been taken offline.

bla bla bla
i read down the page and i did NOT tell it to use any old information it found from Kunena 5x

instead i told it to
Install Kunena 1.6.0.
which would take NOTHING from old and setup a new forum with sample data
it went through it steps

1. Prepare Installation
2. Extract Component
3. Install Languages
4. Install Plug-ins
5. Update Database
6. Finish Installation


seems like it all checked out

(Im typing this stuff while the install is happening by the way )

Now i see a bunch of "OK" text next to each line of the process
seems like it all checks out so lets click FINISH




ok its working now nad i can see it from thefront end.but it does take a while to load the page
and i see this little box pop up telling its a script is basically taking too long on this page

/plugins/system/mtupgrade/mootools.js:1

mootools? awww what the heck

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #10 by ae3d
ok seems like we are getting closer

ill start a new thread with the mos recent strange thing happening since this one no lnoger applies to it

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.115 seconds