×
Kunena 5.2 RC3 Released (29 Nov 2020)

The Kunena team is thrilled to announce the third public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC3 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Avatars not loading Kunena 5.1.19 Joomla 3.9.22

More
2 weeks 1 day ago #1 by JC2033
Hi folks, New to Kuena. I'm Looking for help on this issue of Avatars not loading. I have googled extensively and searched the forum and checked the permissions and settings suggested. Not sure where to go next. Appreciate any suggestions.Running Joomla 3.9.22. Thanks in advance.

Please Log in or Create an account to join the conversation.

More
2 weeks 23 hours ago #2 by rich
With this information I can only guess. Go in the backend to Kunena -> Plugins and disable the Gravatar plugin.
If you have more questions, please add also a configuration report: docs.kunena.org/en/faq/configuration-report

Please Log in or Create an account to join the conversation.

More
2 weeks 4 hours ago #3 by JC2033
Thank you for your response and request for more information. Sorry I did not know how to provide that. I can confirm that the Gravatars plugin is disabled. Thanks for your help.


This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 640M | Max file upload: 300M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : shaper_helix3 | author: JoomShaper.com | version: 2.5.6 | creationdate: Jan 2016

Kunena default template details : NTS KSumo | author: Nice Theme Store | version: 1.0.0 | creationdate: 2020-06-07

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.1.19 | 2020-08-15 [ Tethys ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
2 weeks 2 hours ago #4 by JC2033
Hi Folks, some further info. I managed to check the FTP permissions (See attached pic). File path web/plugins/kuena/avatars. Avatar folder is empty and is 0755. Only the owner has write permissions do others need write permissions? What is slightly unexpected is that when I continue on that file path: web/plugins/kuena/avatars/......gallery/users, I cannot select gallery/users or their subfolders to make them show in the right hand pain (where I have options to upload / edit etc) Is that because all those folders are empty. If I could select them then I presume I could upload images....however the solution I am looking for is that members can upload there own images. Thanks for you help.


Mods (I am on an unstable connection if this duplicated please delete this post) - Thanks

Attachment not found

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #5 by rich
You have disabled "Allow Avatar Upload" in your Kunena configuration. Configuration -> tab Avatars -> Allow Avatar Upload must be Yes

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #6 by JC2033


Hi Rich, I appreciate your help. Can you check this screenshot I understand that upload is set to yes. As an aside I have a number of other issues and wondered if I should try reloading. I can't update the date in my profile or post a topic I get a Unclosed string at position: 2784 error. Happy to keep persisting but just thought id mention. Cheers.
Attachments:

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago - 1 week 6 days ago #7 by rich
On your screenshot it's correctly, but your configuration report shows for this option the number 0 and this means disabled.
Please use during the error search the Joomla and Kunena default templates Protostar and Crypsis. Then save the Kunena configuration again (without changes). Then test again.
Maybe it's a problem with the Joomla template. I think you have enabled the optimization for the complete page. Kunena want to load all info from the template cache.
/cache/com_templates/templates/shaper_helix3/...
Try to exclude Kunena or disable this compression.
Last edit: 1 week 6 days ago by rich.

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #8 by rich

Please use during the error search the Joomla and Kunena default templates Protostar and Crypsis. Then save the Kunena configuration again (without changes). I think, afterwards works.

I forgot to write, empty the cache afterwards.
You also could try to set all Kunena configurations back to default (button is on top for this option).
If it works after that, enable only one of this two (Helix or NTS KSumo) and test again.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.793 seconds