×
Kunena 5.1.6.1 Released - Security Release (09 Nov 2018)

The Kunena team has announce the arrival of Kunena 5.1.6 [K 5.1.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

K5.1.6.1 is a install update.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Merged More than 3 links posted in a message causes errrors

More
5 years 9 months ago - 5 years 9 months ago #1 by brigarkee
For some reason, I was thinking I had seen a place in the configuration, or somewhere that allowed me to set the maximum number of links/urls per post.

I have searched the forums over and can't find anything and I'm stumped on this one.

The reason I am asking, I am posting, as administrator, obviouly, on my boards and it won't let me post anymore than 3 links in one post.
As soon as I've exceeded 3 links, it gives me the following message:

Forbidden
You don't have permission to access /htm/index.php/forum on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.



If I only have 3 or less links, everything goes through fine.

I appreciate anyone's help on this, I think more than anything, if this is an error only because this is the max Kunena will allow for anyone posting, than I am totally fine and will do my own work arounds such as just posting a reply to my post with the additional links I need to post, if not, then the error I am getting above means something else and I need to figure out what is wrong with my Kunena install.

Thanks so much everyone!
Last edit: 5 years 9 months ago by brigarkee.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago #2 by butchjax
I too have seen this problem and haven't found anywhere to modify it.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
5 years 6 months ago #3 by sozzled
To both users:

We do not understand the subject "limiting URLs in each post depending on level" because the term "level" has not been properly explained.

There should be no theoretical limit to the number of URLs that can be inserted into a message, as the example I will include here will illustrate.



I am not aware of a configuration setting, in a standard unmodified and supported version of Kunena, that will impact the number of URL links per post but it may assist the process to see your configuration report. It would also help to see an example of this situation on your own websites.

Thank you.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago #4 by butchjax
I don't know what the levels bit means either, I just know if there are 4 or more links, posting fails.
The error says
Not Acceptable

An appropriate representation of the requested resource /forum could not be found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Here are my configuration settings.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 20M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : uneedo | author: arrowthemes | version: 1.0.4 | creationdate: August 2012

Kunena default template details : Uneedo Template | author: arrowthemes | version: 2.0.1 | creationdate: 2012-07-20

Kunena version detailed: Kunena 2.0.4 | 2013-01-18 [ Pharmacopoeia ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: UddeIM 2.6

Third-party SEF components: None

Plugins: Search - Kunena Search 2.0.4

Modules: Kunena Latest 2.0.4 | Kunena Login 2.0.4 | Kunena Search 2.0.4

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
5 years 6 months ago #5 by sozzled

butchjax wrote: I don't know what the levels bit means either ...

:blink: But this is the word you used in your subject! D you remember what the reason was you chose to use this word?

Getting back to your problem, I could not find an example of a HTTP 403 Forbidden error on your site. Your configuration report shows you are using a third-party Kunena template. In this case you will need to discuss your problems with the developer of that template.

There is no configuration setting that limits the number of URLs that people can post in a Kunena forum message. As you saw from in my example in msg #3, you should be able to post as many URLs as you like.

I think the problem is related to the template you are using. Try using the K 2.0 Blue Eagle template instead.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago - 5 years 6 months ago #6 by butchjax
I hit reply, the subject line was automatically filled in. I didn't 'choose' the wording. In any case, The problem is the same it appears for both of us, so I was trying to give you all less threads to read about the same problem.

I'll talk to the developer and see if there's something hiding in the code.

*** Subject changed by moderator to better reflect the description of the problem ***
Last edit: 5 years 6 months ago by sozzled. Reason: Explained in post

Please Log in or Create an account to join the conversation.

More
  • sozzled
  • Visitor
5 years 6 months ago #8 by sozzled
Yes. That works fine here.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago #9 by Matias
@butchjax, your issue looks like there's mod_security rule (or something similar -- could even be IPS rule in firewall) that looks through all POST requests and blocks them if some suspicious patters are found.

I think the purpose is to block spam... You need to ask about it from your VPS provider.

First issue could be related one, but blocking browsers from making too many requests too fast. Maybe your browser is pre-loading all the links?

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago #10 by butchjax
I tested with the default template, the problem remained. I am awaiting a response from my hosting provider to see if there's something on their end. I'll report back in case it helps other people (like the original poster).

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.124 seconds