×
Kunena 5.1.7 Released - Security Release (20 Nov 2018)

The Kunena team has announce the arrival of Kunena 5.1.7 [K 5.1.7] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question J! 1.5.24 menu aliases containing non-Latin characters (SEO enabled) crash site

More
7 years 1 month ago - 7 years 3 weeks ago #1 by nblit
Hi All,
As you can see my site is using Kunena 1.7 with Joomla 1.5.24.
An issue has surfaced where SEF url's are not working properly.

When disabling SEF in Joomla Configuration.php and in Kunena the site and forum work fine.
When enabling "Search Engine Friendly Url's" in site->Global configuration Internet explorer crashes
When enabling both "Search Engine Friendly Url's" and "use apache mod_rewrite" in site->Global configuration internet explorer crashes when clicking on links from mod_kunenalatest and the latest topics menu item in the forum

When enabling both "Search Engine Friendly Url's" and "use apache mod_rewrite" in site->Global and setting "Search Engine Friendly URLs" in the Kunena forum configuration some of the to posts cause internet explorer to crash.

When enabling both "Search Engine Friendly Url's" and "use apache mod_rewrite" in site->Global and setting "Search Engine Friendly URLs" with "Enable UTF-8 Support" (since my site is in Hebrew) in the Kunena forum configuration some of the to post links from the latest topics page cause internet explorer to crash.

I must stress that when "Search Engine Friendly Url's" and "use apache mod_rewrite" are enabled all other components and menus work flawlessly.


This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 45 seconds | Max execution memory: 96M | Max file upload: 24M

This message contains confidential information

Joomla default template details : benzvi | author: | version: 1.0 | creationdate: 2011-03-10

Kunena default template details : HE-IL (default) | author: Kunena Team | version: 1.6.4 | creationdate: 2011-05-07

Kunena version detailled: Installed version: 1.7.0 | Build: 5135 | Version name: Tale | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 1.7

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Enabled | System - Mootools12: Disabled | Kunena Discuss 1.6.4

Modules: Kunena Latest 1.7.0

Last edit: 7 years 3 weeks ago by . Reason: Changed subject to improve relevance for search purposes

Please Log in or Create an account to join the conversation.

  • Visitor
7 years 1 month ago #2 by
K 1.6.4 is not supported (it hasn't been supported since the beginning of September this year, from the release of K 1.7.0) and therefore any problems in that version are most likely fixed by using K 1.7.0.

It's surprising to read that "an issue has surfaced"; these things don't usually happen without some good explanation or are related to some change that's occurred on your site. Has SEO always worked until now and has it, all of a sudden, stopped working? Therefore, the question is what has changed?

Internet Explorer crashes ... hmm ... it could also depend on what version of IE we're talking about. Do you get any error message when IE "crashes"? Do other users of IE see the same issues when they visit your site with SEO enabled? Obviously at this time, we would not be able to see what happens if we visited your website because you have disabled SEO.

I would suggest that you install K 1.7.0.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago - 7 years 1 month ago #3 by nblit
Sozzled,
My version of Kunena is 1.7 as listed in the "Kunena version detailed" and when browsing to Kunena control panel on my site is listed "You are using the latest version of Kunena 1.7.0"

Second i was able to resolve the issue i had internet explorer 8 by runnning the fixit tool, from microsoft.

Not long ago a user of the site reported that in Chrome 15.0.874.106 when using the links from mod_kunenalatest he was redirected to a logout page instead of the post. i was able to verify this on my system, the resolution was to change the alias for the recent posts from hebrew to english.

You are correct in saying an issue has surfaced, therefor something has changed, the answer to that is yes, an update from Joomla 1.5.23 to 1.5.24 according to the release notes the issue resolved was "303 redirections cause page subresources to be reloaded on WebKit browsers".
i assume you are aware that chrome and safari are using the webkit engine.

This might be the root cause and as i mentioned earlier i was able to resolve it by changing the alias for the forum and recent posts kunena menu items from hebrew to english.

This message contains confidential information
Last edit: 7 years 1 month ago by nblit.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #4 by nblit
sozzled,
an issue happened again just now after a user started a new discussion.
In chrome i was able to view the recent-posts list and when clicking on the new topic i was able to view the discussion.
when clicking on the link from mod_kunenalatest the result was a redirection to a logout page.

seems like mod_kunena latest generates a url that contains the "#" character which throws off the browser when the url contains hebrew characters

looks like i might change the way the module generates the link

regards,
nb

Please Log in or Create an account to join the conversation.

  • Visitor
7 years 1 month ago #5 by
Thanks for your updates on your progress. Indeed you may discover something rooted in Joomla that affects RTL languages (e.g. Hebrew) that the Kunena development team should be careful about. But, from the sounds of it, this could also be a minor catastrophe caused by the Joomla development team, too. Maybe the Joomla forum has further information about this?

I'll be keen to see what you find out when I look again at this site tomorrow morning, my time. Cheers. :)

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #6 by Matias
I may have idea on what's going on. Looks like you're in Joomla 1.7 and UTF8 urls are enabled. Maybe there's an issue with IE on those URLs?

Check if disabling UTF8 URLs individually from Joomla and Kunena helps -- to verify if the issue is in Joomla or in Kunena.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago - 7 years 1 month ago #7 by nblit
Hi Matias,
No, My joomla version is 1.5.24.
It seems like the issue is when a new post is made, i'll explain.
When a user posts a message an email is sent out (which works flawlessly, if you remember our discussion in the past)
Since the category is for registered users only when using the link from the email the user is redirected to the login page.
after logging in the user would click the link generated by mod_kunenalatest marked with new messages.
at this point IE users and sometimes chrome users would be forwarded to the logout page.
for now i have disabled all Kunena sef settings and left the Joomla settings, sef url's and use .htaccess are set to yes.
Which seem to may have resolve the issue. but still, you might want to investigate what changed in Joomla 1.5.24 with its redirects.
Also i have noticed that in order for sef url's to work correctly in kunena the "$live_site" parameter should be set in configuration.php, therefor i listed the full site address, is this correct?


mind you, this issue was not there in 1.5.23!
thanks,
NB B)
Last edit: 7 years 1 month ago by nblit.

Please Log in or Create an account to join the conversation.

More
7 years 4 weeks ago #8 by nblit

Please Log in or Create an account to join the conversation.

More
7 years 3 weeks ago #9 by nblit

nblit wrote: this discussion might shed some more light

Matias / Sozzled,

After performing the suggested in the discussion mentioned i activated all the SEF parameters for Kunena in the configuration page, which did not resolve the issue.
You might want to have a look at K1.7 with J1.5.24.

Regards,
nb

Please Log in or Create an account to join the conversation.

More
7 years 3 weeks ago #10 by Matias
I had some time to read the topic again and I think I have an idea what might be going wrong.

I think that the issue is in your menu aliases (Kunena translation) as Joomla 1.5 only allows latin characters in the menu aliases. Please go into Joomla menu manager and go through all menu items in Kunena Menu. In there change 'Alias' to use only letters a-z, 0-9 and -. Then save.

We need to fix these into your language, too, to prevent this from happening again in the next version.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.116 seconds