×
Blue Eagle 5 v1.5.5 has been Released (22 Nov 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.5 which is now available for download. This version addresses most of the issues that were discovered in development.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Merged All users have Administrator privileges

More
9 years 4 months ago - 9 years 4 months ago #21 by sozzled
Thank you. The first thing to note is that your new users do not have "natively" have Administrator rights. This is shown, clearly, in this screen snapshot of your users, below:


However, this does not explain why things are behaving strangely. The reason your site behaved strangely was because you had changed Global Configuration » Permissions. Unless you really know what you are doing, you must be very careful making these kinds of changes.

I believe I have now fixed everything and your site (and forum, in particular) should behave the way that it was intended to. Let us hope that others will not be tempted to fiddle with these settings on a live website unless they have thoroughly tested what those things do on a test site first. ;)
Attachments:
Last edit: 9 years 4 months ago by sozzled.
The following user(s) said Thank You: onajar

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago #22 by onajar
THANK YOU SO MUCH for taking this NOOB step by step. Everything is working great and I can finally launch my site.

I can't say enough positive things about your help!

My name is Oscar and I just left you a great comment on your FB fan page...

www.facebook.com/pages/Kunena/173611642667602

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #23 by Piszi
Hello,

I'm setting up my website and i don't know what happend but in Kunena all user got Administrators. A few days ago everything worked fine registred users were registred admins were admins.
I have Kunena 1.6.4 with J! 1.6 and CB 1.4
In CB's Userprofile or in J! user manager the users are shown as they are, Registred and their Kunena Rank is also OK (Fresh Boarder).

Please Help what should I do to fix this.

Thanks
Last edit: 9 years 4 months ago by Piszi.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago #24 by sozzled
G'day, Piszi, and welcome to Kunena.

I recently fixed a problem like this for someone else - it had nothing to do with Kunena and it took me a few hours to figure out what that person had done: see Every new user has Administrator rights There is something that you've changed from the standard J! 1.6 user group setup that you haven't told us.

I'm prepared to help but, as I've said, this has nothing to do specifically with Kunena. If you would like my help, please contact me by PM.
The following user(s) said Thank You: Piszi

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago #25 by manild
I've had this problem too, and more specifically it was because under

Global configuration -> permissions

The user group registrered had been assigned allowed to super admin. Set this to inherited instead.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago #26 by Piszi
Thanks for reply,

You were right it, has nothing to do with Kunena, accidently i set component access to allow for registred users.

U saved me Thank You.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #27 by domats
Hello
I have make a new install of kunena and i have the same problem :
1 rankspammer.gif Spammer Oui 0
2 rankmod.gif Modérateur Oui 0
3 rankadmin.gif Administrateur Oui 0
4 rank6.gif Posteur Platinum Non 320
5 rank5.gif Posteur Gold Non 160
6 rank3.gif Posteur Senior Non 40
7 rank4.gif Posteur Expert Non 80
8 rank2.gif Posteur Junior Non 20
9 rank1.gif Nouveau Posteur Non 0
10 rankbanned.gif Bannis Oui 0

when a new user créate à post, he appear at "administrator"

an idéa ?
thanks
Stephane
Last edit: 9 years 4 months ago by domats.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #28 by sozzled
G'day, domats, and welcome to Kunena.

I don't think this is a Kunena problem. I don't think the problem is about forum ranks. I think this is a problem relating to user privileges. I think your new users have the administrator privilege when they use Kunena.

Are you using J! 1.6, perhaps? :dry: (I'm betting that you are using J! 1.6).

If you are using J! 1.6, I think there's something that you haven't told us. I think you've been fiddling with Joomla user groups. I think you will find Every new user has Administrator rights may help. Please let us know if that topic addresses your questions. Thank you.
Last edit: 9 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago #29 by domats
Thancks sozzled
Yes, I use Joomla 1.6

You give me the solution !!! thancks a lot
This is the registered group in joomla have too much rights

Stephane - Burgundy - France

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #30 by sozzled
*** Topics merged ***

Just as I thought. This is not about forum ranks; this is about Joomla user rights.
Last edit: 9 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.715 seconds