×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question Administrators Emailed with New Posts Despite Configuration Settings

More
9 years 5 months ago - 9 years 5 months ago #1 by tomfuller2
EDIT: Set subscription box automatically set to Yes, to "No" Another clue: the email was sent to someone not set as a moderator or even a user in the forum and said in part "A new post has been made to a forum to which you have assigned as moderator in the OED Forums Forum"

Settings in configuration Email Administrators: No. When new posts are made to a forum, all site admins are emailed anyway.

Here are the settings, though site is behind a firewall so can't be viewed publically.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Enabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 2M

This message contains confidential information

Joomla default template details : rt_mediamogul_j15 | author: RocketTheme | version: 1.5.3 | creationdate: 12/30/07

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.3 | creationdate: 2011-01-31

Kunena version detailled: Installed version: 1.6.3 | Build: 4344 | Version name: Parlare | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Disabled or not installed | UddeIm: Disabled or not installed

Third-party SEF components: sh404sef: Disabled or not installed | ARTIO JoomSEF: Disabled or not installed | AceSEF: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Disabled or not installed | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Last edit: 9 years 5 months ago by tomfuller2.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #2 by sozzled
G'day, Tom, and welcome back. I remember an earlier question of yours New Posts get sent to all users as moderators (that you didn't reply to) in which we advised you to disable Legacy mode. I see that you have not acted on that advice and you are still using "legacy mode".

Our advice about "legacy mode" has changed. In the past we said that it was not a "good idea" (because, basically, "legacy mode" never really worked properly anyway) but, having seen examples where K 1.6 actually stops working because of legacy mode, the advisory now becomes a clear warning to users. Please read K 1.6 Technical Requirements .

I also see that you asked another question Illegal Characters in Global Data Error , which we responded to, but we have not heard from you on that issue either. And then there was the question you asked Bold, Italic, Poll Options Etc. Missing After Upgrade which, as in the other cases, we did not receive any confirmation that the information posted in those topics had helped you.

I wonder if you could help us out, please. Could you try to disable "legacy mode" and let us know if this fixes your problem ... and could you also post a note about each of the other topics I've mentioned to let us know how things turned out. Thanks :)

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #3 by tomfuller2
Thank you for your quick reply. Apparently I had wrongly assumed I was subscribed to all the topics I had entered! I will do as you suggest and report back. I need to see if anything else on our site depends on legacy mode. And you are so right - with 1.6 there simply isn't a legacy mode so might as well work towards that!

Tom

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago #4 by tomfuller2
Legacy mode disabled, but still all administrators are emailed for all new posts, though setting is not to email them.

Here are new support details:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 4M

This message contains confidential information

Joomla default template details : rt_mediamogul_j15 | author: RocketTheme | version: 1.5.3 | creationdate: 12/30/07

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.3 | creationdate: 2011-01-31

Kunena version detailled: Installed version: 1.6.3 | Build: 4344 | Version name: Parlare | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Disabled or not installed | UddeIm: Disabled or not installed

Third-party SEF components: sh404sef: Disabled or not installed | ARTIO JoomSEF: Disabled or not installed | AceSEF: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Disabled or not installed | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #5 by sozzled
Can I make a suggestion, please? Can I suggest that you read and use the advice given in Search Engine Optimization (SEO)

From your settings:

mailmod 1
mailadmin 0

Yes, in your case admins are mailed (even though you have explicitly set them to not receive emails) because you have enabled mail for moderators. Admins are automatically moderators.

Therefore the following combinations are valid:

mailmod = 0; mailadmin = 0 => no mail to admins
mailmod = 0; mailadmin = 1 => mail to admins
mailmod = 1; mailadmin = 0 => mail to admins (this is your case)
mailmod = 1; mailadmin = 1 => mail to admins
Last edit: 9 years 4 months ago by sozzled. Reason: Corrected broken link to SEO

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago #6 by tomfuller2
For this site I will just remove administrators and make them managers.

It might be a good feature to make a distinction between moderators and administrators.

The link the SEF information was broken for some reason.

Thanks again for an awesome component!

Tom

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago - 9 years 4 months ago #7 by sozzled

tomfuller2 wrote: It might be a good feature to make a distinction between moderators and administrators.

Would you like to help me rewrite the documentation? Please? :)

I fixed the broken link. Thanks for pointing it out to me. I wonder how many other people have had the same problem, too! :blush:
Last edit: 9 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 4 months ago #8 by tomfuller2
Thanks, again.

Would love to help - if you have a moment to let me in on the process.

I will work with my IT partner about the SEO recommendations. I tried to set mod_rewrite to ON in .htaccess but it killed the site. So we'll work on that.

Tom

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.141 seconds