×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

Question Bad Request after Migration

More
12 years 3 months ago #1 by asniza
Hi,
I have upgraded my FB to Kunena.. below is the 'wrong' process that I have done.

1. FB 1.0.4 to FB 1.0.5 (on J 1.0.15)
- uninstall FB 1.0.4 and install FB 1.0.5
- no error, I'm using this for more than a year. But after more than a year, my hosting company complaint that my site (query from FB) overloading their shared server. So I decided to upgrade to Kunena. I just uninstall FB and then install Kunena without using any converter.
- After upgraded to Kunena, I still have the overloading problem. So I decided to upgrade my Joomla 1.0.15 to J1.5

2. J1.0.15 to J1.5
- I upgrade my Joomla using mtwMigrator. i can migrate the core component, but failed to migrate FB to the new database.
- So, I uninstall Kunena and reinstall FB because the migrator have FB plugin not Kunena.
- Still cannot migrate... So I decided to do it using phpmyAdmin. I uninstall the FB, install back Kunena. And then export the jos_fb_xxxx from Joomla 1.0.15 Database to my new Joomla 1.5 Database.
- It works fine to me until I discover that I can't use both the mod_latestkunena and mod_latest_kunena that I downloaded from Joomla Extension website. If I use this module, sometimes my browser will give me 'Bad Request' message. And, If I search forum using the 'search' button, it will give this error

Fatal error: Call to undefined function mb_substr() in /home/ratuhati/public_html/components/com_kunena/class.kunena.php on line 1282
Search Results Searched for: forum


So what can I do to repair my new Kunena forum? I can't start fresh installation because I have over 44K posts and nearly 10K members. Please help.

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #2 by grumblemarc

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #3 by asniza
grumblemarc,
thank you so much for your reply.

I have replace the files uploaded xillibit (code fixed by Matias). But I still have the problem... the same error message, but diferent lines

Fatal error: Call to undefined function mb_substr() in /home/ratuhati/public_html/components/com_kunena/class.kunena.php on line 1289


and one more thing, what about the BAD REQUEST message by the browser?

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #4 by xillibit
Hello,

do you have tried this : www.kunena.com/forum?func=view&catid=93&...it=10&start=20#17062

About the bad request, what browser do you use ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago - 12 years 3 months ago #5 by asniza
I use mozilla firefox - newest version. and I'm also using Internet Explorer.
I try to remove cache/offlien files from my browser, also the same problem.

I have to remove mod_kunena_latest and mod_kunenalatest to prevent my browser and other members browser from getting the Bad Request message..

I will try link that you give. Hope it will work. I really need this module fo my site.

Thank You xillibit. Will update after this.

One more thing... after I remove/comment this line, the search function work as I want.. But not sure whether it will give another problem or not.

//return mb_substr($str, $start, $length, $encoding);

Last edit: 12 years 3 months ago by asniza.

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #6 by asniza
xillibit wrote:

Hello,

do you have tried this : www.kunena.com/forum?func=view&catid=93&...it=10&start=20#17062

About the bad request, what browser do you use ?


I have tried this suggestion, it's not working. 1282

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #7 by mraab
Asniza and Matias,

I am going through the same loop with errors in line 1282 and 1289, depending on which patch I am applying (used all class.kunena.php files from the other thread).

The only solution for me also is to comment out line 1282, which at least fixes the search error - but not sure what other error this may cause further down the track...

Matthias

Deutsche in Melbourne | Deutsche in Perth |
Deutsche in Brisbane |

Please Log in or Create an account to join the conversation.

More
12 years 3 months ago #8 by Matias
Quick workaround: instead of commenting out that line, use this:

return substr($str, $start, $length);

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.117 seconds