×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

× This is for users to help other users, to discuss topics that relate to migrating from other web-based forums and converting the data into a form that will operate with Kunena.

It is important to note that the Kunena team does not have a standard, recommended or supported protocol for these ideas and that posting questions in this category may not receive advice from team members.

Solved Trying to migrate from phpBB to Kunena: user profiles are all messed up

More
5 years 9 months ago - 5 years 8 months ago #1 by Lazaruso
I am experiencing some very weird issues with Kunena. Honestly, it is quite frustrating. I thought I got it all working until I migrated to 3.06. Everything worked great in Kunena 1.72 but the user IDs g0t messed up after upgrading to 3.0. I even tried 2.04 but same problem as 3.06. I also tried jupgrade with no luck. I tried the kunena importer but that lacks alot. It is only good for minor forums.
How then do we import users from 1.7 to 3.0 without getting the user IDs messed up? And by "messed up", I mean users assigning to wrong profiles and wrong forum posts.
Last edit: 5 years 8 months ago by 810.

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #2 by 810
what you can try, install every version. until the broken one, then we can take a look at it. why its broken.

So first try to install k2.0 :
joomlacode.org/gf/project/kunena/frs/?ac...&frs_package_id=6337

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #3 by xillibit
Hello,

You have upgraded form a Joomla! version to an another or you have just upgraded your Kunena version ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #4 by Lazaruso

810 wrote: what you can try, install every version. until the broken one, then we can take a look at it. why its broken.

So first try to install k2.0 :
joomlacode.org/gf/project/kunena/frs/?ac...&frs_package_id=6337


Just to be sure, i tried all the versions on that page with no luck. 2.0, 2.01, 2.02, 2.03 and ofcourse 2.04. None of them worked. 2.03 was just a complete mess.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #5 by Lazaruso

xillibit wrote: Hello,

You have upgraded form a Joomla! version to an another or you have just upgraded your Kunena version ?


It is a test site with fresh joomla installation. I tried on both joomla 1.5 and Joomla 2.5. the Kunena 1.7 works great on both joomla versions. However, the problem starts when I try to upgrade Kunena. I imported the forum from fireboard to kunena 1.0 and it worked great. From there, I migrated to Kunena 1.7 without any major issue. Now, I am trying to upgrade Kunena 1.7 and that is when the problem starts

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #6 by 810
try when you migrated from fireboard. remove the *_fb_* tables. and try to update

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #7 by Lazaruso

810 wrote: try when you migrated from fireboard. remove the *_fb_* tables. and try to update


I tried that 3 times but unfortunately that did not work

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #8 by 810
Try Clean joomla 1.5.26 Use jfusion: www.jfusion.org/component/ars/repository...ckage-zip?format=raw

Sync the users. Then do the migration. Then upgrade to K2.0.4.

Migrate to J3.3.6, export the *_kunena_* database to you new database for J3.3.6
Install lasted kunena version.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #9 by Lazaruso

810 wrote: Try Clean joomla 1.5.26 Use jfusion: www.jfusion.org/component/ars/repository...ckage-zip?format=raw

Sync the users. Then do the migration. Then upgrade to K2.0.4.

Migrate to J3.3.6, export the *_kunena_* database to you new database for J3.3.6
Install lasted kunena version.


By "sync" u mean from a phpbb forum? that doesn't seem to work why because phpbb has a different user ID structure. Kunena's user ID structure starts at 62 for Admin. Phpbb User ID structure starts at 1 for admin. The same with the other forums. Also, there is no jfusion plugin for either fireboard or kunena so there is no way to sync users using jfusion.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #10 by xillibit
Do-you have tried all versions in K3.0.x series ?

It's not Kunena which set the admin ID to 62 but Joomla! 1.5 itself, since Joomla! 1.6 and later it's 62 and since Joomla! 3.1 it randomise this ID

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.111 seconds