×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This category is for the module developed, endorsed, maintained and supported by the Kunena project team. The topics in this category only relate to the plugin developed for K 3.0 and later versions.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Important Latest Module Linking To Wrong Menu Item/Alias

More
4 years 6 months ago - 4 years 5 months ago #1 by Slippery Jim
Thread can be deleted. Figured out how to solve the problem on my own. :woohoo:
Last edit: 4 years 5 months ago by Slippery Jim.

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #2 by xillibit
Hello,

Can-you explain please for others users how do-you have solved this issue ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago - 4 years 5 months ago #3 by Slippery Jim
Recently I did a fresh install of Joomla and the Kunena Latest module wasn't behaving like it did before.

When I click a post in the Kunena Latest module I want the forum to be displayed full screen without any other modules showing. For some reason when I clicked one of the posts shown in the Kunena Latest module it wasn't linking to the forum's alias (which is "forum"). Instead it was linking to the alias used in the MAIN MENU (which is "kunena-2016-03-27").

This caused a problem since it was not using the menu assignment of Kunena Latest module like it should. The forum wasn't being displayed full screen when you clicked the Kunena Latest but it did work fine when you clicked the forum link in the MAIN MENU.

I had to edit the Main Menu entry that had the "kunena-2016-03-27" alias and change the menu assignments for that.

To add to the confusion when you clicked on the link to the author shown in the Kunena Latest it used the proper alias to link to and used the menu assignments from the Kunena Latest module properly. Go figure.

This is what the link should be when I click the Kunena Latest:
fakewebsite.com/index.php/forum/discussion/1-link-to-a-post

This is what I was getting and was ignoring the menu assignments of Kunena Latest:
fakewebsite.com/index.php/kunena-2016-03-27/discussion/1-link-to-a-post
Last edit: 4 years 5 months ago by Slippery Jim.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.128 seconds