×
Kunena 5.2 RC 1 Released (25 Oct 2020)

The Kunena team is thrilled to announce the first public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This category is for the plugin developed, endorsed, maintained and supported by the Kunena project team. The topics in this category only relate to the plugin developed for K 3.0 and later versions.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Activated "Show on Articles: Posts" not displayed

More
3 years 10 months ago #1 by MarcoT
Hello,
Show on Articles: Link - works fine
after switching to:
Show on Articles: Posts

the rendered page is empty:
test364.mazdaznan.de/at/avesta-2020/2342-av-d2020-002

There should be displayed 2 replies!

Discuss Debug says:
[KunenaDiscuss debug: Constructor called in com_content ]
[KunenaDiscuss debug: createTable: Check if plugin table exists. ]
[KunenaDiscuss debug: onPrepareContent.Parent category ID is: 1 ]
[KunenaDiscuss debug: onPrepareContent.Allow: Category 63 is in the category map using Kunena category 23 ]
[KunenaDiscuss debug: onPrepareContent: we are viewing an article. ]
[KunenaDiscuss debug: onPrepareContent: Article 2342 ]
[KunenaDiscuss debug: onPrepareContent: Custom Topics disabled ]
[KunenaDiscuss debug: showPlugin: Loading Stored Topic 36 ]
[KunenaDiscuss debug: showPlugin: Displaying form ]
[KunenaDiscuss debug: showTopic: Rendering discussion ]
[KunenaDiscuss debug: onAfterDisplayContent: Returning content for article 2342 ]

I activated Joomla Debug System Mode and it says below the article:
Rendering Error in layout Topic/Item: Property "topic" is not defined in /.../components/com_kunena/template/crypsis/layouts/topic/item/default.php on line 15
Layout was rendered in /.../libraries/kunena/layout/base.php on line 183

I have un- and reinstalled the discuss plugin.
Tried nearly every setting in the plugin, all works fine, except:
"Show on Articles: Posts"

Any idea whats the error about and how to solve it?

Thanks for your help!

Best regards
Marco

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.106 seconds