×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This category is for the plugin developed, endorsed, maintained and supported by the Kunena project team. The topics in this category only relate to the plugin developed for K 3.0 and later versions.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Getting ERROR Cannot save message: Email address is required when Kunena discuss is enabled

More
5 years 5 months ago #1 by ajb1967
hi,

If I enable the Kunena discuss plugin i get the Joomla error ... "ERROR Cannot save message: Email address is required"

Has anyone come across this ? and if so how do i solve it

Thanks,
Andy

Please Log in or Create an account to join the conversation.

More
5 years 5 months ago #2 by sozzled
Does this problem happen everywhere in your forum for everyone who tries to post a message in your forum?

I'm not sure I understand the problem because I do not understand your environment. I'm going to take a wild guess that you allow anonymous or guests to post in your forum. Is that correct? It may help if we could see your configuration report but, if you decide not to give it to us, that's OK (although I don't know if anyone can help you).

Sorry, I never allow anonymous or guests to post in any forums that I manage; I have never encountered this issue before and I am not sure how you go about "solving" the problem.

Please Log in or Create an account to join the conversation.

More
5 years 5 months ago #3 by ajb1967
Thanks for your reply.

The problem happens everywhere in the website for everyone.

The plugin is set for PUBLIC at the moment, but you have to login to comment.

Interestingly, you dont get the error message if

1. I set the plugin to "registered" OR

2. there is already a topic created for the article in Kunena OR

3. Create Topic on is set to First Reply (instead of first visit)

So I am gathering there is an issue with Kunena automatically creating a new topic when users aren't logged in.

Is there a Kunena setting I'm missing somewhere so that the topic can be created automatically when you first visit an article even when you're not logged in ?

thanks!
Andy

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.093 seconds