×
Blue Eagle (1.5.0) for K5.1 is released (20 Jul 2018)

Please update the Kunena Blue Eagle to 1.5.0 if you use Kunena 5.1.
We made several bug fixes and improvements. Also Blue Eagle has now all the features from Crypsis.
Download: www.kunena.org/download/templates/category/blue-eagle-5

×

Please Read This First:


This category is only for reporting defects with K 3.0.

Do not use this category:
  • to ask general questions about how to use K 3.0 or to ask when new versions of Kunena will be released;
  • to ask about other (older) versions of Kunena; or
  • if you have tried to install K 3.0 on J! 1.5; or
  • if you installed K 3.0 on a live, production site and you want your site restored to its previous state; or
  • if this website ( www.kunena.org ) works but works differently to how you expected.

You must include your K 3.0 configuration report; if you do not include your configuration report, your topic may be closed (locked) or deleted without any further warnings from the moderators.

Topics that have been closed (resolved) will be archived and no further discussion on those topics will be allowed.

Question Recurrent error - Could not connect to mysql database!

More
3 years 4 months ago - 3 years 4 months ago #1 by Afdhaal
Hi there,

I'm using kunena for more than 3 years. I was and I'm so happy using it in my educational website as the forum solution. :) But recently few weeks ago I'm getting recurrent mysql error which says "Could not connect to mysql database". Initially I thought that it could be due to restrictions of the shared hosting. So I moved my site to a VPS (1GB ram & 1 core) in digitalocean!
But still I'm getting the error. As soon as I restart the mysql, everything comes back to normal. Also when I repair and optimize the mysql database of the site everyday, the incidents of the error is less. But still I couldn't figure out the problem why I'm still getting it.

I have only installed Kunena, akeeba backup & akeeba admin tools as extensions.

My forum:
https://istudyroom.com/Forum

Configuration:
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 20M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : isrsapphire | author: Kyle Ledbetter | version: 1.0 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.7 | creationdate: 2015-02-01

Kunena version detailed: Kunena 3.0.7 | 2015-02-01 [ Galah ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: sh404sef 4.4.6.2271

Plugins: Search - Kunena Search 3.0.1

Modules: Kunena Latest 3.0.1


Mysql error log:
Warning: Spoiler! [ Click to expand ]


Eagerly waiting for your response!
Last edit: 3 years 4 months ago by Afdhaal.

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #2 by xillibit
Hello,

Do-you have empty space on hard disk ?

In your log, i can see that MySQL has been not shutdown correctly, i think it's you that you have tried to restart mysql :

150331 22:12:14 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.


I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: Afdhaal

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #3 by Afdhaal
Hi xillibit,

I have allocated 10Gb for the joomla website with the forum and I have more than 8Gb free space.

The error used to occur every other day. When I get the error, I restart the mysql. As soon as I restart it, everything comes back to normal.

I'm pretty confused because I had the same problem when I was using shared hosting at ipage. Now the same problem is with my VPS. (To host the sites, I'm using webmin control panel.)

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #4 by xillibit
I think it will more helpfull to ask directly on ubuntu forums or dba.stackexchange.com because i'am bit stick with your issue

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: Afdhaal

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #5 by Afdhaal
Thanks for the reply xillibit!
I'll ask it at ubuntu forum!
Have a great day!
:)

Please Log in or Create an account to join the conversation.

More
3 years 3 weeks ago #6 by raunharman
Which table in the database are the reply messages stored?

Please Log in or Create an account to join the conversation.

More
3 years 3 weeks ago #7 by xillibit
Hello,

The messages are stored into #__kunena_messages

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.106 seconds