×
Blue Eagle 5 v1.6.2 has been Released for Kunena 5.2 (20 Jan 2021)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.6.2 which is now available for download. This version addresses most of the issues that were discovered in development.

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with

× Topics that are moved into this category are considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved Fatal Error: Class 'CKunenaLink' not found in components/com_kunena/template/orao/html/category/default.php on line 37

More
7 years 7 months ago - 7 years 7 months ago #1 by Maurointer
Hi, I made the mistake of updating my Kunena 2.X to 3.X, since I did, I had nothing but trouble, templates and rendered inaccessible error that gave the forum, some sections inaccessible (even created from scratch with clean install) and template no longer be changed, for the same problem Fatl error 500.
After all disistallato Kunena, I try to install Kunena 2.X, but it tells me that it is impossible to downgrade to 2.x when there is no Kunena Kunena installed.
I'm really disappointed, I'm thinking about changing the forum and I am sorry, because with Kunena I have always had a great time, I hope to resolve here.

The error is as follows:

500 Internal Server Error

Fatal Error was detected!

Fatal Error: Class 'CKunenaLink' not found in components/com_kunena/template/orao/html/category/default.php on line 37

The error was detected in the Kunena Component.

For support click here: Kunena Support

non è sempre la linea 37 ma cambia


Sorry for the English, but it's not my original language


update:

If I go with the hidden navigation, always using google chrome, does not give me the error, what can it be?

update 2:

I emptied the cache, and does not give me more problems going into sections , but continues to make mistake in editing the templates

How come there are these problems?
Last edit: 7 years 7 months ago by Maurointer.

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #2 by sozzled
You have these problems because you were not using a Kunena template that is compatible with K 3.0. You would not have those problems if you were using the Kunena Blue Eagle template designed for K 3.0.

You have these problems because you did not read K 3.0 Upgrade Guide . If you uninistall K 3.0 you cannot "downgrade" to K 2.0. What you need to do is to restore your site from the backup that you took before you upgraded K 3.0 "by mistake". Good luck and I hope you get your site running again very soon.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #3 by Nookman
Hi, When I click on any link in my forum I get a 500 Internal Server error message.

I've enabled debug mode and am getting this message:
Fatal Error: Class 'CKunenaLink' not found in components/com_kunena/template/ja_mendozite/html/category/default.php on line 35

The error was detected in the Kunena Component

I've just upgraded to Kunena 3.0.1 and also Joomla 2.5.13

How do I resolve this issue? Many thanks in advance. :huh:
Last edit: 7 years 6 months ago by Nookman.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #4 by Jiminimonka
Your template is probably not designed for Kunena 3.0.1, ja_mendozite is not the Blue Eagle default Kunena 3.0.1 template. Contact the person/provider for that template to get them to update it, in the mean time try using the Blue Eagle template and see if that corrects the issue.

If it does not, then please post your un-edited Kunena Configuration Report.

Please read the FAQ.
Only one question per topic.
Search before you ask a question.
The following user(s) said Thank You: Nookman

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #5 by Matias
Here's the bug report for it:
github.com/Kunena/Kunena-Forum/issues/1847

We accidentally removed legacy feature which allowed some of the 3rd party templates to work. Will put the support back into Kunena 3.0.2

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #6 by Matias
Looks like the template uses still legacy class which we removed. I will put it back into 3.0.2..

Here's the bug report:
github.com/Kunena/Kunena-Forum/issues/1847

Please Log in or Create an account to join the conversation.

More
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.095 seconds