Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

Solved Sunglass-icon displayed after punctuation mark in Descriptions and Categories

More
6 months 1 week ago #1 by sthop
Hello, 
After installing Kunena 6.2.0 as Forum-extension in Joomla 5.0.0, I had noticed that there were many black-yellow Sunglass-icons in the text of readymade categories and posts in the Main Forum (out-of-the-box).
I thought it was a pun of a Kunena-developer who created the 'Welcome Visitor' message and the 'Suggestion Box' categories and posts.
But after creating some categories myself with explanatory texts (in Description, and Category Header), I noticed that this sunglass-emoticon (9.png from Kunena) shows up all over the place!
It seems as if the sunglass-icon is stamped (not-by-me) in between the text I had made, after a colon ':',
after a comma ',' a question mark '?' and a dot '.' etc.
My guess is that every punctuation mark in Descriptions or Category Headers is always followed by the sunglass-icon in the frontend (but not in the backend).

How/where can I correct/remove/adjust this exaggerated charade of sunny smileys?

Regards, sthop
WAMP: Windows 11pro, Apache 2.4.54 (Win64), MariaDB 10.10.2, PHP 8.2.0 .
Attachments:

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #2 by Leen
mm strange I don't recognize this
but have you already looked at kunena > Tools > Diagnostics
did they all pass the test?
And maybe reinstall Kunena 6.2.0 Language Package

L.v.d.A

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #3 by sthop
Hello Leen,
I ran Kunena Diagnostics and all 'TEST PASSED - No issues found!'
I have not installed the Kunena Language package.
Is that necessary?
regards, sthop

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #4 by Leen
would give that a try anyway.

L.v.d.A

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago - 6 months 1 week ago #5 by sthop
I installed the Kunena Language Pack, and restarted WampServer.
Result: the sunglass-icon  is still overall present in the Kunena Forum Categories and Posts.

Could it have something to do with the fact that I use MariaDB as DBMS? Character map? Collation?
Attachments:
Last edit: 6 months 1 week ago by sthop.

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago - 6 months 1 week ago #6 by Leen
I have looked at all the test sites but I don't see this phenomenon anywhere.
And your smileys from kunena are just the standard installation, nothing has been changed?
this is what the text in my category looks like

L.v.d.A
Attachments:
Last edit: 6 months 1 week ago by Leen.

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago - 6 months 1 week ago #7 by rich
Go to Kunena -> Emoticons in the backend and edit this smilie. This error occurs when the field for the code is empty. Enter this code and save. This should solve the problem.
Code:
:-)
Last edit: 6 months 1 week ago by rich.
The following user(s) said Thank You: Leen, sthop

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago - 6 months 1 week ago #8 by sthop
Hello Leen,
Backend: I had to manually add many Kunena-emoticons in order to get them in the Kunena-list (see image).
Frontend: This way, I would get some of them appear in the (previously empty) Smiley-popup of the Text-editing box of a New Topic (see other image).
Attachments:
Last edit: 6 months 1 week ago by sthop.

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #9 by sthop
Hello rich,
Sorry, I did not see your answer.
Your solution works!
I filled all the empty Code fields with the same code :-)
Thanks, sthop
Attachments:

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #10 by rich
In principle, each smiley should have its own code, as the smileys are also displayed if you enter the code directly in a post without opening the smiley dialogue box.

Please Log in or Create an account to join the conversation.

Time to create page: 0.644 seconds