×
Migration of kunena.org to Joomla! 4.x and Kunena 6.x on 30 january on evening (Yesterday)

Tomorrow 30. January we will carry out the migration to Joomla 4.x and Kunena 6.x. So we will starting to be offline at 19h00 UTC until 23h00 UTC.

Solved 500 error when attempting to access categories from backend

More
1 year 1 week ago - 1 year 1 week ago #1 by webgobe
Hi!
I have a site I recently migrated from Joomla 3.10.4 to 4.0.6, and also upgraded Kunena to latest available version. All working ok, but if I want to access the Categories page from the backend, when the site (a Joomla core based multilingual site) throws an 500 error:Call to a member function getTag() on null in (line 229)
Check the attached screenshoot.

The line highlighted in red seems to be the culprit.

Internet craftsman carrying on the heritage of European manufacturing traditions through original Web designs. If you want a great looking, handmade, custom-tailored Joomla site, look no further. We can provide a one-stop shopping experience that offers design, programming, maintenance, protection.
Attachments:
Last edit: 1 year 1 week ago by webgobe. Reason: code insertion fucked up the page

Please Log in or Create an account to join the conversation.

More
1 year 1 week ago #2 by xillibit
Hello,

Can-you please said which Php version are-you using ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
1 year 1 week ago #3 by webgobe
7.4.27

Internet craftsman carrying on the heritage of European manufacturing traditions through original Web designs. If you want a great looking, handmade, custom-tailored Joomla site, look no further. We can provide a one-stop shopping experience that offers design, programming, maintenance, protection.
Attachments:

Please Log in or Create an account to join the conversation.

More
1 year 1 week ago #4 by xillibit
Hello,

Are-you using Kunena 6.0 beta 7 ? On your first message the screenshot show the tab exception selected, but can-you make please a screenshot with stack trace ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
1 year 1 week ago - 1 year 1 week ago #5 by webgobe
Good question: I amusing the very last available version, but check the screenshoot attached:
Shows up an ancient version number, 1.5.9. 
But in fact is pkg_kunena_v6.0.0-BETA7_2022-01-18.
In mean time I tried to solve another problem, and I made some changes, so can't reproduce the original error message, now is showing something else. Check screenshoot no. 2.  
Let me explain from where this whole thing started:
AFTER upgrade the Kunena main index page looked like in screenshoot no.3

 

When, in fact should look like in screenshoot no. 4.


 


I realized that it is something wrong with the access rights for the categories, and this is how I discovered the original error. Since the site was live when I discovered the error I could not wait to be fixed - the Forum is not that much used - and tried to fix it on the fly, first via the Categories menu, and later by changing things in the

Internet craftsman carrying on the heritage of European manufacturing traditions through original Web designs. If you want a great looking, handmade, custom-tailored Joomla site, look no further. We can provide a one-stop shopping experience that offers design, programming, maintenance, protection.
Attachments:
Last edit: 1 year 1 week ago by webgobe.

Please Log in or Create an account to join the conversation.

More
1 year 1 week ago #6 by webgobe
Update: after fooled around in the database (well, a bit more, I installed a pristine Joomla 4 with latest Kunena, looked to the settings and making the changes) things are looking OK.
Probably the update script failed to take over the existing settings in the database, and that caused the problems. worth looking into. If you wish, I can send you the pre-update database of Kunena to check why and what has gone wrong.

Internet craftsman carrying on the heritage of European manufacturing traditions through original Web designs. If you want a great looking, handmade, custom-tailored Joomla site, look no further. We can provide a one-stop shopping experience that offers design, programming, maintenance, protection.

Please Log in or Create an account to join the conversation.

More
1 year 1 week ago #7 by xillibit

I realized that it is something wrong with the access rights for the categories, and this is how I discovered the original error. Since the site was live when I discovered the error I could not wait to be fixed - the Forum is not that much used - and tried to fix it on the fly, first via the Categories menu, and later by changing things in the
What did-you had changed in database to fix it ?

Update: after fooled around in the database (well, a bit more, I installed a pristine Joomla 4 with latest Kunena, looked to the settings and making the changes) things are looking OK.
Probably the update script failed to take over the existing settings in the database, and that caused the problems. worth looking into. If you wish, I can send you the pre-update database of Kunena to check why and what has gone wrong.
yes, i'am interested to have your pre-update database of kunena, you can send it on florian [at] kunena.org

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
1 year 1 week ago #8 by webgobe
BTW, there is an error here:
<query mode="silenterror">ALTER TABLE `#__kunena_categories` CHANGE ttopic_ordering opicOrdering varchar(16) NOT NULL default 'lastpost';</query>

it is the

Internet craftsman carrying on the heritage of European manufacturing traditions through original Web designs. If you want a great looking, handmade, custom-tailored Joomla site, look no further. We can provide a one-stop shopping experience that offers design, programming, maintenance, protection.
The following user(s) said Thank You: xillibit

Please Log in or Create an account to join the conversation.

More
1 year 1 week ago #9 by xillibit
Thanks i have just fixed this query

In mean time I tried to solve another problem, and I made some changes, so can't reproduce the original error message, now is showing something else. Check screenshoot no. 2.  
 
For the issue on getGroupName() method, are-you still able to reproduce it ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
1 year 1 week ago #10 by webgobe
Database export sent. as for what I did: first of all, if you compare the screenshoot above with this one, you will see, that I did 2 things - probably in the wrong order, but worked.
First I have reset the values for accesstype, access, pub_access, etc. - generally the access related fields to the values I have saw in the database of the pristine Kunena install (with demo content). This already fixed most of issues. Then, after the Categories menu in the live sine began to work, I tried to do my needed adjustments - and discovered that most of the changes in the install\, I decided to manually operate the changes in the database, and that fixed the remaining problems. And in the process I discovered the error in that XML file wich caused, probably at least some of problems I had experienced. 

Internet craftsman carrying on the heritage of European manufacturing traditions through original Web designs. If you want a great looking, handmade, custom-tailored Joomla site, look no further. We can provide a one-stop shopping experience that offers design, programming, maintenance, protection.
Attachments:

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.293 seconds