Kunena 6.3.2 released

The Kunena team has announce the arrival of Kunena 6.3.2 [K 6.3.2] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Solved The requested page can't be found

More
2 years 5 months ago #1 by Leen
I also have after update with the pkg_kunena_v6.0.0-BETA7-DEV_2022-01-11.zip
When I want to reply to a topic I get this error message The requested page can't be found
Code:
Kunena\Forum\Libraries\Route\KunenaRoute::stringURLSafe(): Argument #1 ($string) must be of type string, null given, called in /home/mysite/domains/mydomain/public_html/components/com_kunena/src/ Service/Router.php on line 239
This message contains confidential information

Database collation check: The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |
       

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 256M | Max file upload: 

Kunena menu details:

Warning: Spoiler!

Joomla default template details : cassiopeia | author: Joomla! Project | version: 1.0 | creationdate: February 2017

Kunena default template details : Aurelia | author: Kunena Team | version: 6.0.0-BETA7-DEV | creationdate: 2022-01-11

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.0.0-BETA7-DEV-GIT | 2022-01-11 [ Git Repository ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.6.4+build.2022.01.04.22.00.38.045bcf7e0

Third-party SEF components: None

Plugins: None

Modules: None

 

L.v.d.A
The following user(s) said Thank You: xillibit

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #2 by Leen
ha I just found out that the Quick replay button works and you can answer

L.v.d.A

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #3 by xillibit
Hello,

I have just made a fix for this issue : github.com/Kunena/Kunena-Forum/commit/f8...f0a00dcd51b9f4477c04

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago - 2 years 5 months ago #4 by Leen
i tried on live site but so far solution still not working. (maybe I edited the wrong file)
the Quick replay button works
Code:
The requested page can't be found. An error has occurred while processing your request. You may not be able to visit this page because of: an out-of-date bookmark/favourite a mistyped address a search engine that has an out-of-date listing for this site you have no access to this page Go to the Home Page If difficulties persist, please contact the website administrator and report the error below. 404 View not found [name, type, prefix]: topic, html, site Call stack # Function Location 1 () JROOT/libraries/src/MVC/Controller/BaseController.php:898 2 Joomla\CMS\MVC\Controller\BaseController->getView() JROOT/libraries/kunena/src/Controller/KunenaController.php:430 3 Kunena\Forum\Libraries\Controller\KunenaController->display() JROOT/libraries/kunena/src/Controller/KunenaController.php:349 4 Kunena\Forum\Libraries\Controller\KunenaController->executeTask() JROOT/libraries/kunena/src/Controller/KunenaController.php:240 5 Kunena\Forum\Libraries\Controller\KunenaController->execute() JROOT/components/com_kunena/src/Dispatcher/Dispatcher.php:113 6 Kunena\Forum\Site\Dispatcher\Dispatcher->dispatch() JROOT/libraries/src/Component/ComponentHelper.php:389 7 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/SiteApplication.php:206 8 Joomla\CMS\Application\SiteApplication->dispatch() JROOT/libraries/src/Application/SiteApplication.php:245 9 Joomla\CMS\Application\SiteApplication->doExecute() JROOT/libraries/src/Application/CMSApplication.php:278 10 Joomla\CMS\Application\CMSApplication->execute() JROOT/includes/app.php:63 11 require_once() JROOT/index.php:32

L.v.d.A
Attachments:
Last edit: 2 years 5 months ago by Leen.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #5 by xillibit
Hello,

My fix above was to fix the following error :

I also have after update with the pkg_kunena_v6.0.0-BETA7-DEV_2022-01-11.zip
When I want to reply to a topic I get this error message The requested page can't be found
Code:
Kunena\Forum\Libraries\Route\KunenaRoute::stringURLSafe(): Argument #1 ($string) must be of type string, null given, called in /home/mysite/domains/mydomain/public_html/components/com_kunena/src/ Service/Router.php on line 239
 
For the issue related to the buttons, what is the link on each button when you over them ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #6 by Leen
I only took screenshots because I wasn't sure which rules to use.

L.v.d.A

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #7 by xillibit

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

Time to create page: 0.775 seconds