Kunena 6.2.4 Released

The Kunena team has announce the arrival of Kunena 6.2.4 [K 6.2.4] which is now available for download as a native Joomla extension for J! 4.3.x/4.4.x/5.0.x. This version addresses most of the issues that were discovered in K 6.1 / K 6.2 and issues discovered during the last development stages of K 6.2

Solved New Install - No sample data and no editor

More
2 years 1 month ago - 2 years 1 month ago #1 by Horton
Just starting to learn the interface I have installed and reinstalled the latest build for Joomla 4 (Beta 6)

When I install I can see the button on the dashboard but nothing happens when I click it. 

When I try to create a post I can type in the subject line but then there is no editor to enter the body of the post.

Is there a production version that works with Joomla 4? 
Last edit: 2 years 1 month ago by Horton.

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #2 by rich

When I try to create a post I can type in the subject line but then there is no editor to enter the body of the post.

Where, you see a subject line if you don't have sample data installed? Please read this:  docs.kunena.org/en/basics/installation/installation-k6-0

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #3 by Horton
I have installed Kunena 6 onto two different Joomla 4 test sites.
As per the instructions I was able to add the admin module with sample data to one of them. ( I have used Joomla for 10+ years and never before had to add a module to the back end so this was not obvious )

On the second site, when I try to add the sample data nothing happens. I mean the module never appears. (whatever)

Test data or not - I still can not create a new topic on the site with the test data. I get the button to create the topic, I get the text box for the subject line but I do not get the text box for the actual post. Is it likely that this is just because I need to learn & tweak additional user and category settings? It is a rough start so far.

My question

Ideas????

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #4 by rich
Kunena does not install a module for its sample data. You have this problem with both test pages? If you have installed Kunena + sample data + created Kunena menu, it is ready to use.
If you don't have an editor, that's a different problem. What Joomla template are you using? Is it a new Joomla installation or an updated site?

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #5 by Horton
It is not a new install of Joomla. It is up to date - a restored copy of my production site that originated with Joomla 2.5 ten + years ago. 

As for the site template, I am using the current version of Isotope from RocketTheme - (Gantry 5). Do I need to use a Kunena specific template for basic functionality????

Between the two sites, one of them let me install the sample data as prescribed. IDK what is wrong with the other but I think that is a different issue.

See attachment. You will see there is no editor window. 
Attachments:

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #6 by rich

Do I need to use a Kunena specific template for basic functionality????

No, but conflicts with extensions can always occur. This can be templates, optimization tools or another extensions. Also, scripts or CSS codes sometimes cause problems. But most conflicts can be fixed if you know the cause.
Change to the Joomla Standardtemlate and check if the error is gone. Or if you have a page optimization tool, disable it and test the editor.

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #7 by Horton
Still stuck. I changed the site template to Cassiopeia.
Any time I try to create a new thread I can create a title but can't enter text in the body of the post. Could it be my core Joomla security settings?
I know Kunena works and want to migrate over but not getting anywhere. Thinking about setting up a Joomla 3 site just so I can play with the previous version of Kunena.

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #8 by rich

Still stuck. I changed the site template to Cassiopeia.
Any time I try to create a new thread I can create a title but can't enter text in the body of the post. Could it be my core Joomla security settings?

Anything is possible, but I'm thinking more on an extension. Use a process of elimination. Deactivate your extensions, and when the error is gone, enable one after the other, and test each time. This way you can find the cause.

Thinking about setting up a Joomla 3 site just so I can play with the previous version of Kunena.

Which Kunena version is installed on your old forum?
If you want to migrate it to Kunena 6.0, you need Kunena 5.2.1 or higher on Joomla 3.10 as a minimum version.
Depending on what version your old forum has, there may be different steps needed to upgrade it to v5.1.x (5.2.x).
So it is important that you update your old forum first. After that, upgrading to Kunena 6.0 should not be another problem.

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #9 by Horton
Yea I feel pretty dumb. The problem was Akeeba Admin Tools. I had forgotten how locked down the site was.

Please Log in or Create an account to join the conversation.

Time to create page: 0.348 seconds