Kunena 6.0.8 Released (17 Jan 2023)

The Kunena team has announce the arrival of Kunena 6.0.8 [K 6.0.8] which is now available for download as a native Joomla extension for J! 4.2.x. This version addresses most of the issues that were discovered in K 6.0 and issues discovered during the development stages of K 6.0.

Solved Joomla 4.0-rc6 : Upgrade from Kunena 5.2.6 to K 6.0 fails

More
1 year 5 months ago - 1 year 5 months ago #1 by Gindi
It is not possible to install Kunena 6.0 on my localhost with Joomla4RC6 and Kunena 5.2.6
Kunena 6RC1:
Code:
success Die Paket-Installation wurde abgeschlossen. Es ist ein Fehler aufgetreten. 0 Return value of Kunena\Forum\Libraries\Config\KunenaConfig::getInstance() must be an instance of Kunena\Forum\Libraries\Config\KunenaConfig or null, instance of __PHP_Incomplete_Class returned

The Website is frozen, after shutdown and restart no Joomla screen with Message
Code:
1054 Unknown column 'sampleData' in 'field list'

On Usersite i get this messge:
Code:
Die angeforderte Seite konnte nicht gefunden werden.
Code:
0 Return value of Kunena\Forum\Libraries\Config\KunenaConfig::getInstance() must be an instance of Kunena\Forum\Libraries\Config\KunenaConfig or null, instance of __PHP_Incomplete_Class returned
After shutdown and restart  Message
Code:
1054 Unknown column 'sampleData' in 'field list'

On installed Joomla4RC6 and Kunena 5.2.6 if i select "Forum" on the start-page i get the message
Code:
Die angeforderte Seite konnte nicht gefunden werden 0 Method renderError() is not defined

On Adminsite select Kunena:
Code:
Dashboard wird normal angezeigt. Kategorien, Benutzer, Anhang: 0 Unknown fetch type '8' Emoticons, Ränge, Templates: 500 behavior::tooltip not found. Konfiguration: 0 Unknown fetch type '8' Plugins wird normal angezeigt Protokolle, Statistiken, Papierkorb: 500 behavior::tooltip not found. Tools: Menü wird angezeigt. Tools – Konfigurationsbericht: 500 behavior::tooltip not found. Tools – Forum säubern: 0 Unknown fetch type '8' Tools – Benutzer synchronisieren: wird normal angezeigt. Tools – Statistiken neu zählen: wird normal angezeigt. Tools – Menüverwaltung: wird normal angezeigt. Tools – AW: Präfix entfernen: wird normal angezeigt. Tools – IP Adressen bereinigen: wird normal angezeigt. Tools – Diagnose: funktioniert normal. Anchor Tools – Kunena deinstallieren: Sorry, there was a problem we could not recover from. AnchorThe server returned a "500 - Whoops, looks like something went wrong." AnchorHelp me resolve this
 The Configuration-Report from Joomla310RC2 (must be the same as in Joomla4RC6 Kunena 5.2.6)

This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |
       

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 512M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: 4/30/2012

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.6.6 | creationdate: 2021-07-25

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.2.6 | 2021-07-25 [ Melia ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: UddeIM 4.0

Third-party SEF components: None

Plugins: None

Modules: None


Try to install Kunena 6.0RC2 with message
Code:
Erweiterung „Update“: Erweiterungsspezifische Installationsroutine ist fehlgeschlagen. Fehler bei der Paket-Installation.
Can you show me a way to install Kunena 6.0?
Greetings
gindi
Last edit: 1 year 5 months ago by rich. Reason: Configuration report correct inserted
The following user(s) said Thank You: rich

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #2 by rich
Thanks for testing. 
Your steps Joomla 3.9 to J 3.10 to J4.0 are ok, but Blue Eagle and Uddeim will not run on Joomla 4.0.
But the upgrade also not works, if you have a clean Joomla 6.0 without these extensions. 
It seems, currently it's not possible to upgrade from K.5.2 to K6.0 without errors. This error must correct.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #3 by rich
Please try it with the beta3 version from today (13 September).

Please Log in or Create an account to join the conversation.

Time to create page: 0.320 seconds