×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

Question Slow execution of open, search and reply after move to 5.1.12.1

More
3 months 2 days ago - 3 months 2 days ago #1 by djb
I have been a long term user of Kunena and found it to be a very reliable and key part of my site, angloboerwar.com.

I recently updated to J3.9.8 and K5.1.12.1. All my extensions that use the Joomla update are up to date.

Since the upgrade, Kunena is a lot slower in key areas. Navigating the forum is as fast as usual but I am seeing delays when opening, searching, replying or cancelling. It is taking 18 seconds to register a 'thank you'. It is taking 15 - 20 seconds to open a thread. The steps of clicking on reply and then clicking cancel will take 30 seconds to complete. If I open a different thread and then go back to the first one within a few seconds it will take 15 seconds again. I have tried different cache setting and currently use conservative. All the functions of the forum work but now take a long time to complete.

This is not a wider issue as the performance of the non-Kunena parts of my site is normal. It is not a loading issue as it happens with one or two people on the forum. I have 60k messages in the forum.
Kunena diagnostics does not report any issues.

I have disabled UddeIM without any affect.

I am seeking help with where to look next for the source of this problem.

With thanks
David

This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 256M | Max file upload: 2M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: 4/30/2012

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.5.2 | creationdate: 2018-12-11

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.12.1 | 2019-04-22 [ Kerberos ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: UddeIM 3.9

Third-party SEF components: None

Plugins: Search - Kunena Search 5.1.1

Modules: Kunena Latest 5.1.1 | Kunena Stats 5.1.1 | Kunena Search 5.1.1

Last edit: 3 months 2 days ago by djb.

Please Log in or Create an account to join the conversation.

More
3 months 1 day ago #2 by rich
The problem occurs when a topic contains pictures. All functions become slow when an image has to be loaded. An user had already this problem and solved this with a server setting. Unfortunately, he did not tell us what setting it was.
The other pages are fast because are not contains big images. I saw you've changed the template, but it will not help. You have a very long idle time for loading the images, thats the problem.

Please Log in or Create an account to join the conversation.

More
3 months 1 day ago #3 by rich
Addition: I see this error on your page.
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; plgContentMultithumb has a deprecated constructor in /.../plugins/content/multithumb/multithumb.php on line 20
Pleasse disable this plugin and try it again.

Please Log in or Create an account to join the conversation.

More
3 months 1 day ago #4 by djb
Thank you for your reply.

I have been doing more testing today with different cache setting, different templates, turning on/off other modules without any change.

As you say, the time to load is dependent on the images on the page. If there are no images, load time is good:

Time to create page: 0.307 seconds

I have a thread with multiple images and the results for this page are:

Time to create page: 40.744 seconds

The problem does not depend on how many images there are in the thread, only on how many are being display on the screen when the thread loads. For example, a thread containing 303 posts but with only 3 text posts that load when the thread loads, open in 0.4 seconds.

Turning the Kunena cache on or off makes no difference. This is the case if the cache as set to 3 minutes and the same thread is loaded and then reloaded immediately. In both cases the time to load is 40 seconds.

This problem was not evident before this version of Kunena so is it possible to identify what change is causing it please?

I presume I cannot revert to the previous version?

It is possible to ask the user what action was taken to prevent it?

My forum uses a lot of images and I am seeing usage of my site drop off these last 2 weeks probably caused by a degree of frustration on the load times. Presumably many Kunena users are affected by this issue in the latest version? A solution would be much appreciated.

With thanks
David

Please Log in or Create an account to join the conversation.

More
3 months 1 day ago #5 by djb
I did turn off Multithumb and retested once I cleared the cache. The slow loading was still evident.

Please Log in or Create an account to join the conversation.

More
3 months 1 day ago - 3 months 1 day ago #6 by rich

Presumably many Kunena users are affected by this issue in the latest version?

Altogether this problem has been reported three or four times. But it was before this Kunena version and the last question about this problem was this topic in German language here (1 year ago). www.kunena.org/forum/36-German/150018-dr...r-eingebunden-werden
Which worked version you had installed previously?

What happens, if you set in the Joomla Global Configuration -> tab Server > "Error Reporting = Maximum" and in the Kunena Configuration (tab General) "Enable Debug Mode = Yes" ? Maybe you can see the error.
Last edit: 3 months 1 day ago by rich.

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago - 2 months 4 weeks ago #7 by djb
Rich,

Thank you for your suggestion.

I have turned on debugging and loaded a page containing images. The information points to the afterRenderComponent as the process taking the time.

Does that help at all?

With thanks
David




Time to create page: 40.780 seconds


Time: 30.15 ms / 30.15 ms Memory: 1.711 MB / 2.10 MB Application: afterLoad
Time: 139.33 ms / 169.48 ms Memory: 7.109 MB / 9.21 MB Application: afterInitialise
Time: 49.49 ms / 218.97 ms Memory: 1.656 MB / 10.86 MB Application: afterRoute
Time: 3.50 ms / 222.47 ms Memory: 0.018 MB / 10.88 MB Application: beforeRenderComponent com_kunena
Time: 108.15 ms / 330.61 ms Memory: 4.208 MB / 15.09 MB Application: Before Access::preloadComponents (all components)
Time: 1.46 ms / 332.07 ms Memory: 0.059 MB / 15.15 MB Application: After Access::preloadComponents (all components)
Time: 0.06 ms / 332.13 ms Memory: 0.000 MB / 15.15 MB Application: Before Access::getAssetRules (id:2833 name:com_kunena)
Time: 1.14 ms / 333.27 ms Memory: 0.026 MB / 15.17 MB Application: After Access::getAssetRules (id:2833 name:com_kunena)
Time: 40671.28 ms / 41004.55 ms Memory: 7.065 MB / 22.24 MB Application: afterRenderComponent com_kunena
Time: 3.33 ms / 41007.89 ms Memory: 0.024 MB / 22.26 MB Application: afterDispatch
Time: 8.10 ms / 41015.99 ms Memory: 0.072 MB / 22.33 MB Application: beforeRenderModule mod_breadcrumbs (Breadcrumb)
Time: 3.02 ms / 41019.01 ms Memory: 0.060 MB / 22.39 MB Application: afterRenderModule mod_breadcrumbs (Breadcrumb)
Time: 0.05 ms / 41019.06 ms Memory: 0.000 MB / 22.39 MB Application: Before Access::getAssetRules (id:1 name:root.1)
Time: 0.02 ms / 41019.08 ms Memory: 0.002 MB / 22.39 MB Application: After Access::getAssetRules (id:1 name:root.1)
Time: 2.20 ms / 41021.29 ms Memory: 0.080 MB / 22.47 MB Application: beforeRenderModule mod_menu (Main Menu)
Time: 9.14 ms / 41030.43 ms Memory: 0.200 MB / 22.67 MB Application: afterRenderModule mod_menu (Main Menu)
Time: 3.84 ms / 41034.27 ms Memory: 0.000 MB / 22.65 MB Application: beforeRenderModule mod_login (Login or create an account)
Time: 5.16 ms / 41039.42 ms Memory: 0.027 MB / 22.67 MB Application: afterRenderModule mod_login (Login or create an account)
Time: 3.79 ms / 41043.22 ms Memory: 0.015 MB / 22.69 MB Application: beforeRenderModule mod_menu (topmenu)
Time: 3.68 ms / 41046.90 ms Memory: 0.031 MB / 22.72 MB Application: afterRenderModule mod_menu (topmenu)
Time: 3.86 ms / 41050.76 ms Memory: 0.000 MB / 22.72 MB Application: beforeRenderModule mod_search (Search)
Time: 3.03 ms / 41053.80 ms Memory: 0.023 MB / 22.74 MB Application: afterRenderModule mod_search (Search)
Time: 22.39 ms / 41076.19 ms Memory: 0.484 MB / 23.23 MB Application: afterRender

Database

Queries total: 35.07 ms

Memory usage
24.15 MB (25,327,248 Bytes)

Database queries
65 Queries Logged 35.07 ms
Last edit: 2 months 4 weeks ago by djb.

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #8 by ssh
@djb I'm not saying this will solve your problem, because I'm not sure what your problem is.
But after see your website, I notice several things that are slowing down your site.

I would suggest to you:
1. Enable gzip compression
2. Leverage browser caching
3. Combine images using CSS sprites
4. Minify CSS

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #9 by ssh
Also, I would suggest to:
Reinstall Joomla again to override any defective file
Reinstall Kunena again to override any defective file
Repair database via phpMyAdmin
Optimize database via phpMyAdmin
Clear all cookies in your browser (Ctrl + Shift + Del)
Clear all cache in your browser (Ctrl + F5)
Upgrade to PHP 7.3.7 (if not done yet)
Upgrade to MySQL 5.7.26 (if not done yet)
Upgrade to SSD (if still using traditional hard drives)

Also, make sure your server does have a defective hard drive
More ideas after your reply

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago - 2 months 3 weeks ago #10 by djb
ssh,

Many thanks for your messages. These are useful suggestions that will speed up most sites.

You reminded me that I have disables JCH Optimise as part of my testing so I have re-enabled that which will cover items 3 and 4 on your list.

My version of PHP is 7.2.20.

I will continue to work through your list. I think the problem has its root with the last version of the forum and I see a new version has been released so I will install that now ...

With thanks again
David
Last edit: 2 months 3 weeks ago by djb.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.116 seconds