×
Kunena 5.1.12.1 Released - Security release (22 Apr 2019)

The Kunena team has announce the arrival of Kunena 5.1.12.1 [K 5.1.12.1] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a security release.

Question Error Messages when posting and viewing forum topics

More
2 weeks 2 days ago #1 by Rhia9397
Hello,

I am new to Joomla and new to Kunena. I am testing my new website and the Kunena forum on it. I have found 2 problems so far:

1) I have created a test user and posted a couple of messages with it. Both times, after posting the message, the "user" was taken to a blank page with a 404 Error message on the page tab stating that the page does not exist. However, the posts were created in the relevant category. The problem is that the same error appeared when clicking on the messages/posts in the forum.

2) The appearance in the forum is misaligned. Sometimes fields do not align with each other and look out of place and messy.

I have searched the forum and googled extensively, but I can't find a solution that works. Please note, I am not the most technical of people, but I do try. My configuration report is below. If it's not the right one, please let me know.

Many thanks in advance! :)


This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 50000 seconds | Max execution memory: -1 | Max file upload: 64M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : rachel_free | author: WarpTheme.com | version: 2.0.0 | creationdate: December 2018

Kunena default template details : Crypsis | author: Kunena Team | version: 5.1.12.1 | creationdate: 2019-04-22

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.12.1 | 2019-04-22 [ Kerberos ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
2 weeks 2 days ago #2 by rich
There are two problems.
1. You have edited the menu item "Forum" in the Kunena menu. It must be the Kunena menu item Homepage otherwise you get errors.
2. The main problem that you use a Joomla bootstrap 4 template. Currently we have still not a template which works with bootstrap 4, but we work on it.

Please Log in or Create an account to join the conversation.

More
2 weeks 2 days ago #3 by Rhia9397
Hi Rich,

Many thanks for your help. I can post now! You really made my day. Thanks so much!

Regarding using bootstrap 4, (I don't know what a bootstrap is :blush:) could I switch to a bootstrap that works better...? It's probably a stupid question...

Thanks again for all your help and your hard work. You made my day! :)

Please Log in or Create an account to join the conversation.

More
2 weeks 2 days ago - 2 weeks 2 days ago #4 by rich

Regarding using bootstrap 4, (I don't know what a bootstrap is

Short answer: Bootstrap is a CSS Framework, from where Kunena get the fundamental style informations. But this can only work when the Kunena template is adjusted on this bootstrap version.

could I switch to a bootstrap that works better...?

I don't think, that the Joomla template offers a option where you can switch the bootstrap version. In principle you can try only with another template, Kunena works with bootstrap 2 and with bootstrap 3.
There is a an option in the Kunena template setting "Backend -> Kunena -> Template -> Crypsis -> tab Advanced ->
Load Bootstrap css", but this option loads the default bootstrap 2 files and will not help. On the contrary, I think you get a conflict beetwen bootstrap 2 and 4.
Last edit: 2 weeks 2 days ago by rich.

Please Log in or Create an account to join the conversation.

More
2 weeks 2 days ago #5 by Rhia9397
Thank you very much for taking the time to explain and to help me, Rich. I really appreciate it!:)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.119 seconds