×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Question 0 - Argument 1 passed to ComponentKunenaControllerApplicationHomeDefaultDisplay

More
1 year 6 months ago - 1 year 6 months ago #1 by Baronet
Hello, I was recently forced to make some updates to a Joomla site, and upgraded Kunena to version 5 . Since then I'm getting this error:

0 - Argument 1 passed to ComponentKunenaControllerApplicationHomeDefaultDisplay::getDefaultMenuItem() must be an instance of Joomla\CMS\Menu\SiteMenu, instance of JMenuSite given, called in /home/vanmini/public_html/components/com_kunena/controller/application/home/default/display.php on line 56

The site uses an Arstisteer Template.

Here is the page link: vancouverminiclub.ca/forum.html

Any help would be appreciated.

Thank you.

Report Config in attachment

This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 256M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : VMCMar182015 | author:


| version: 2.0 | creationdate: 2015-03-18

Kunena default template details : Crypsis | author: Kunena Team | version: 5.1.10.1 | creationdate: 2019-03-04

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.1.10.1 | 2019-03-04 [ Janus ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 1 year 6 months ago by Baronet. Reason: Configuration report correct added.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #2 by rich

Report Config in attachment

Please not as attachment, all users could download this file. Ive removed the file. docs.kunena.org/en/faq/configuration-report

You can install the Nightly Build (Kunena 5.1), it should solves your problem. Go to our download page and scroll down, then you see it.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #3 by Baronet
Thank you Rich,
I've install the Nightly build Kunena 5.1.11-DEV, cleared the cache, but the problem persists. the error has now moved to line 58:

0 - Argument 1 passed to ComponentKunenaControllerApplicationHomeDefaultDisplay::getDefaultMenuItem() must be an instance of Joomla\CMS\Menu\AbstractMenu, instance of JMenuSite given, called in /home/vanmini/public_html/components/com_kunena/controller/application/home/default/display.php on line 58

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago - 1 year 6 months ago #4 by rich
Please check your main menu. You have the correct menu item to the fotum trashed and created a wrong menu item to the forum.
The menu item in the trash with ID 167 is the corectly menu item and
the menu item in the main menu with ID 124 is wrong

If you this not repair, you can't go to the forum.
Last edit: 1 year 6 months ago by rich.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #5 by 810
try else: line 48 to :
$menu = Factory::getApplication()->getMenu();


And add this to line 13:
use Joomla\CMS\Factory;

Please Log in or Create an account to join the conversation.

More
1 year 2 weeks ago #6 by oystercafe
I had the same issue, I tried solution above but it didn't work.
Here is the Configuration Report.
This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 16M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : jcprotostar | author: Kyle Ledbetter | version: 1.0 | creationdate: 4/30/2012

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.5.2 | creationdate: 2018-12-11

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.1.15-DEV | 2019-09-08 [ Internal ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 5.1.1

Please Log in or Create an account to join the conversation.

More
10 months 4 weeks ago - 10 months 4 weeks ago #7 by Wiz
Hi,

I have exact same problem.

Fresh install of Joomla! 3.9.12
Kunena 5.1.15
PayPlan 4.0.14
Default Protostar template

It only works well if I disable my PayPlans System plugin.




Kunena always the best!
Attachments:
Last edit: 10 months 4 weeks ago by Wiz.

Please Log in or Create an account to join the conversation.

More
10 months 4 weeks ago #8 by rich
I do not know this plugin. Is this feature also needed on the forum pages? If not, disable it on the forum pages. You can do it with a plugin such as this: extensions.joomla.org/extension/js-css-control/

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.434 seconds