×
Kunena 5.2 RC 1 Released (25 Oct 2020)

The Kunena team is thrilled to announce the first public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Question Kunena menu bar disapears

More
1 year 8 months ago #1 by sarrene
Good day,
I have a rather perplexing problem. I am working on a new updated site and moving one of our games forums over from phpbb3 to kunena. ( I have used Kunena since the first iteration years ago).

My problem is this, when I disable the jump box, i also lose the kunena menu. I am not sure how or why. I have done several tests and reinstalled several times to no avail. This is 100% reproducible for me on two different servers and development/test sites.

Steps I have taken:
- Deleted the alias in my main menu (and dumped the trash)
-- then create new alias in my main menu
- Rebuilt the Kunena Menu
- Deleted the Kunena menu
-- then used the Rebuild menu option
- Uninstalled Kunena and removed all db tables
- Reinstalled Kunena (and no menu with a reinstall of kunana
- read many many threads and followed the Kunena Menu info on the documentation many times.

The only thing that works at first is a full clean install of Joomla and then Kunena. As soon as I disable the jump box, I lose the menu for good.

I have tested with custom templates as well as both Crypsis templates. I have tried with a fresh Joomla install using protostar (no custom edits or anything touched)

No other components or plugins installed.

Kunena version on two test sites: 5.1.9


Please note I have an older version on a few live sites (I have not updated to the latest yet) that does not have this issue. Could this be something I am missing or something up with this latest version?
I am at this time at a complete loss.

Thank you and regards!

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #2 by rich
Replied by rich on topic Kunena menu bar disapears
You mean the setting option "Enable Category Jump"? Please create a configuration report, maybe I can reproduce this problem.
If you want to disable this category jump, you can do it also with a workaround. Add this following code in your Kunena template custom.less

select#catid {
    display: none;
}

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #3 by sarrene
Replied by sarrene on topic Kunena menu bar disapears
This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 45 seconds | Max execution memory: 512M | Max file upload: 24M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : charity | author: Shape5.com | version: 1.0.3 | creationdate: January 28th, 2019

Kunena default template details : Kcombo | author: Roundtheme | version: 2.0.0 | creationdate: 09/11/2018

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.1.9 | 2019-02-15 [ Kerberos ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #4 by rich
Replied by rich on topic Kunena menu bar disapears
As long the error is not localisated, please use both default templates Protostar and Crypsis. But I see in your Kcombo template options 3 different enabled bootstrap.css
Maybe you find here the problem. Are the menu items also lost in the mobile view?

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #5 by sarrene
Replied by sarrene on topic Kunena menu bar disapears
Good afternoon,
Thanks for the reply. I was using both default templates, and every single combination I could think of. the menu is present in mobile view.

For now, I just hard coded it into a custom html file to get around this. I have no idea what is going on. Both servers are up to date and I do not have the problem with the other sites using Kunena. It is completely baffling to me.

Still baffled!

p.s.
For other users with a similar question: (something I did not add in the above)
One other thing for anyone that might have similar (this is also not my problem) and for them to look into: Check your server cache settings as well. If you have any caching or something similar, dump/refresh and try again. For me, this was and always is the first thing I try.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.159 seconds