×
Kunena 5.1.2 Released - Security Release (15 Jul 2018)

The Kunena team has announce the arrival of Kunena 5.1.2 [K 5.1.2] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

Question Problem with email

More
1 week 2 days ago #21 by bikeboy
Replied by bikeboy on topic Problem with email
I have reinstalled 5.0.14_2018-03-14 version and the email notifications are now working fine - I believe there is something in the 5.1.1 release which is causing the problem mentioned here. At least I have a working forum again.
The following user(s) said Thank You: fiat4x4.gr

Please Log in or Create an account to join the conversation.

More
5 days 23 hours ago #22 by djos
Replied by djos on topic Problem with email
Why do developers ignore such a serious bug?

Please Log in or Create an account to join the conversation.

More
3 days 20 hours ago #23 by fiat4x4.gr
Replied by fiat4x4.gr on topic Problem with email
Kunena 5.1.2 doesn't resolve the problem...

Please Log in or Create an account to join the conversation.

More
3 days 20 hours ago #24 by 810
Replied by 810 on topic Problem with email
we are still investigating the issue.
The following user(s) said Thank You: fiat4x4.gr

Please Log in or Create an account to join the conversation.

More
3 days 7 hours ago - 3 days 7 hours ago #25 by Kubik-Rubik
Replied by Kubik-Rubik on topic Problem with email

810 wrote: we are still investigating the issue.


Hey 810,

encountered the same issue and can give you some insights.

First my temporary workaround so that the emails are sent again:

\KunenaEmail::send (libraries/kunena/email/email.php)

foreach ($chunks as $emails)
{
    try
    {
        \Joomla\CMS\Factory::getMailer()->sendMail(\Joomla\CMS\Factory::getApplication()->get('mailfrom'), \Joomla\CMS\Factory::getApplication()->get('fromname'), $emails, $mail->Subject, $mail->Body, true);
 
    }
    catch (Exception $e)
    {
        $success = false;
        \Joomla\CMS\Log\Log::add($e->getMessage(), \Joomla\CMS\Log\Log::ERROR, 'kunena');
    }
}

Attention: For me this is sufficient because I'm the only notification receiver and don't need to hide email addresses in BCC etc.

The problem is that you don't set the proper default mailer in the current Kunena code. I use SMTP but if you check the object that was created by Kunena, you see that the SMTP data is not set properly (in fact the mailer is set to "mail" which does not work on my server due to security settings):



You need to specify the SMTP values explicitly, this is how it is done in the Factory class correctly and thus my workaround works as expected. Just take a look into this function \Joomla\CMS\Factory::createMailer (libraries/src/Factory.php).

My suggestion: Either use \Joomla\CMS\Factory::getMailer() or set the mailer properly.

Have success!

Kubik-Rubik Joomla! Extensions
joomla-extensions.kubik-rubik.de
Attachments:
Last edit: 3 days 7 hours ago by Kubik-Rubik.

Please Log in or Create an account to join the conversation.

More
3 days 3 hours ago #26 by 810
Replied by 810 on topic Problem with email
@fiat4x4.gr could you test the nightly build. Its should be ok now.

Please Log in or Create an account to join the conversation.

More
2 days 9 hours ago #27 by fiat4x4.gr
Replied by fiat4x4.gr on topic Problem with email
Thank you very much, but my knowledge is by far less than yours. It's all seems Greek to me...:laugh: I'll wait the 5.1.3 update that probably will resolve the problem.

Please Log in or Create an account to join the conversation.

More
1 day 2 hours ago #28 by 810
Replied by 810 on topic Problem with email
on the bottom of the download page, you have the nightly builds, that you can install.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.216 seconds