×
Kunena 5.2 RC 1 Released (25 Oct 2020)

The Kunena team is thrilled to announce the first public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Question Posting an answer does not work

More
2 years 5 months ago - 2 years 5 months ago #1 by straetch
When a user clicks on Reply to a topic, the edit screen is shown.
The user enters the text, but when the Submit button is clicked, nothing happens. The edit screen remains open.
When the forum is closed and reopened, the edits are lost en no new topic is created.
This happens with all users. Same result with Captcha removed.
Editing of an existing topic by the super-user works.
I updated to the latest 5.1.0 RC7 with the corresponding language pack (dutch).
I also wanted to update to the latest stable blue-eagle-5-v1-0-5 Blue Eagle template (purchased), but that failed, so I am on blue-eagle-5-v1-5-0-rc1. See seperate post.
EDIT: Switching to Crypsis3 template does not solve the issue.
Last edit: 2 years 5 months ago by straetch.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #2 by straetch
Additional information:
The Submit button is unresponsive only when a registered user is logged in.
When the user is a guest or is not logged in, the Submit button is active and the post is saved as expected.
Strange.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #3 by 810
Replied by 810 on topic Posting an answer does not work
Could you try the nightly build, me made some js fixes. its on our download page

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #4 by straetch
I installed the nightly build pkg_kunena_v5.1.1-DEV_2018-05-19.zip on my test site.
No improvement: the Submit button is still unresponsive.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #5 by xillibit
Hello,

Do-you have a link to your site with a test account ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago - 2 years 5 months ago #6 by straetch
I made a temporary test account for you:
This message contains confidential information


The site is in dutch, but that should not be a problem in this case ("Antwoord" = "Reply"; "Toevoegen" = "Submit").

This message contains confidential information


You can add posts as you need to, I will clean it up later when I will destroy the user account.

To login:
On the left menu, last item (Toegang leden), you can login/out with the standard Joomla form.

You will see that posts can be added when the user is not logged in and the "Toevoegen" button is unresponsive when logged in.


I have plugin EasyCalcCheckPlus installed, but deactivated it for Kunena forum. Deactivating the plugin makes no difference.

A consideration after the above problem is resolved:
How can I show Google recaptcha only for guest users and not for logged-on registered users.
Last edit: 2 years 5 months ago by straetch.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #7 by straetch
Maybe this helps.
If I enable debug mode, I get everywhere (i.e. category list, topics list, within each post):

Notice: Undefined variable: name in libraries/kunena/user/user.php on line 444

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.125 seconds