×
Blue Eagle 5 v1.6.2 has been Released for Kunena 5.2 (20 Jan 2021)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.6.2 which is now available for download. This version addresses most of the issues that were discovered in development.

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with

Question ERR ID:36731 & ERR ID: 36728

More
2 months 4 days ago #1 by KZQ
Hello Folks,
I'm way out of my depth here so I'm asking: Is this a bug in Kunena? I'm running Kunena 5.1.29 in Joomla 3.9.23.

"Exception throw at line 665 in file \/home\/kzride5\/public_html\/libraries\/joomla\/database\/driver\/mysqli.php with message You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 1"

"Exception throw at line 665 in file \/home\/kzride5\/public_html\/libraries\/joomla\/database\/driver\/mysqli.php with message Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8mb4_general_ci,COERCIBLE) for operation '='"

Thank you

Please Log in or Create an account to join the conversation.

More
2 months 4 days ago #2 by KZQ
Replied by KZQ on topic ERR ID:36731 & ERR ID: 36728
Just realized that those ID numbers are mine not Kunena's. 37K errors. I've got some work to do.
Bill

Please Log in or Create an account to join the conversation.

More
2 months 1 day ago #3 by KZQ
Replied by KZQ on topic ERR ID:36731 & ERR ID: 36728
I checked the character set it's set to UTf-8 multibyte. I actually tried to reset it to UTF-8 multibyte and crashed the database. After I restored the database I used Admin tools to repair and optomize the tables. However I'm still getting the same error in the logs. Somehow this error is also related to some strange notifications about topic subscriptions that, according to Kunena, do not exist.
Any help will be greatly appreciated.
Bill

Here's my configuration report:
This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |
       

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 256M | Max file upload: 256M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : js_wylia2 | author: Joomlashack | version: 2.2.17 | creationdate: November 26 2020

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.5.2 | creationdate: 2018-12-11

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.1.19 | 2020-08-15 [ Tethys ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: UddeIM 4.0

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
2 months 1 day ago #4 by rich
Replied by rich on topic ERR ID:36731 & ERR ID: 36728

I checked the character set it's set to UTf-8 multibyte. I actually tried to reset it to UTF-8 multibyte and crashed the database. After I restored the database I used Admin tools to repair and optomize the tables

I'm sorry, but I don't understand this correctly. You have reset to UTF-8 multibyte, but this crashes the database. 
Then you have restored and optimized your database. Which collation has this database now?

"Exception throw at line 665 in file \/home\/kzride5\/public_html\/libraries\/joomla\/database\/driver\/mysqli.php with message You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 1"

This error can occur, such as when users add emojis in the messages and the collation is'nt correctly in the table #__kuena_messages_text. But it is not enough if you change the table collation only. The collation must be also changed for the columns in the tables.

Have you read this topic?
The following user(s) said Thank You: KZQ

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.271 seconds