×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Solved Internal Error when replying or quoting

More
3 weeks 6 days ago #1 by larbut
Some of my members are reporting Errors when replying or quoting.
The back end Log shows this error message:

"Exception throw at line 665 in file \/home\/admin\/public_html\/libraries\/joomla\/database\/driver\/mysqli.php with message Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8mb4_general_ci,COERCIBLE) for operation '='"

As far as I can see the error is not permanent, and it certainly does not affect all users.

Any help on this is much appreciated!


Configuration report: (PHP 7.1.33)

This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 256M | Max file upload: 16M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : rt_nuance | author: RocketTheme, LLC | version: 1.7 | creationdate: September 27, 2017

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.5.2 | creationdate: 2018-12-11

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.15 | 2019-10-27 [ Oberon ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 2.4.2 | UddeIM 4.0

Third-party SEF components: sh404sef 4.10.0.3607

Plugins: Search - Kunena Search 5.1.1

Modules: Kunena Latest 5.1.1 | Kunena Search 5.1.1

Please Log in or Create an account to join the conversation.

More
3 weeks 6 days ago #2 by rich
Probably users get this error, if they want to insert Emojis. The collation of your database do not allow Emojis. Thee error comes from the table #__kunena_messages_text. You need the collation utf8mb4_general_ci.
www.kunena.org/forum/general-questions-a...bile-device-keyboard

If you know it how you can change it then change the table collation along with column collation for the Kunena tables.
Otherwise you can do it with the Admin Tools (it needs only one click) to change it to UTF-8 multibyte.
Important! Make a database backup before you change somethings in the database.
The following user(s) said Thank You: larbut

Please Log in or Create an account to join the conversation.

More
3 weeks 6 days ago #3 by larbut
Thank you, that was it.
The table had correct collation, but the column did not.
I changed column collation in phpmyadmin and now that users can use the mobile device keyboard's emojis.

-Lars

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.148 seconds