×
Blue Eagle (1.5.0) for K5.1 is released (20 Jul 2018)

Please update the Kunena Blue Eagle to 1.5.0 if you use Kunena 5.1.
We made several bug fixes and improvements. Also Blue Eagle has now all the features from Crypsis.
Download: www.kunena.org/download/templates/category/blue-eagle-5

Solved Topic title tag ERROR after upgrade to 5.1

More
2 months 1 week ago #1 by riffi67
Hello, i've upgraded my kunena forum to version 5.1 and, after upgrade, all topic title show the <em> tag like as you can see in the attached image.

How can i solve?

Thanks
Attachments:

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago - 2 months 1 week ago #2 by Dirk
I have exactly the same problem, after updated to 5.1.0 (the theme I use is "Crypsisb3")

The generated code is:
<div class="badger-left badger-info message-published" data-badger="<em>Sample-Topic</em> was created by <em>Sample Username</em>">
    <div class="kmessage">
        <div class="kmsg">
           sample Message ... blah ...blah			
        </div>
    </div>
</div>
Last edit: 2 months 1 week ago by Dirk.

Please Log in or Create an account to join the conversation.

More
2 months 6 days ago #3 by Kubik-Rubik
Hi!

Go to "Extensions" - "Language(s)" - "Overrides" and create two new overrides for your front end language (e.g. English (en-GB) - Site) overwriting the following two constants:

COM_KUNENA_MESSAGE_CREATED_NEW
COM_KUNENA_MESSAGE_REPLIED_NEW

Remove all em tags in both language strings.

Example:

Replied by <em>%1$s</em> on topic <em>%2$s</em>

should be

Replied by %1$s on topic %2$s

Have success!

Kubik-Rubik Joomla! Extensions
joomla-extensions.kubik-rubik.de

Please Log in or Create an account to join the conversation.

More
2 months 6 days ago #4 by riffi67

Kubik-Rubik wrote: Hi!

Go to "Extensions" - "Language(s)" - "Overrides" and create two new overrides for your front end language (e.g. English (en-GB) - Site) overwriting the following two constants:

COM_KUNENA_MESSAGE_CREATED_NEW
COM_KUNENA_MESSAGE_REPLIED_NEW

Remove all em tags in both language strings.

Example:

Replied by <em>%1$s</em> on topic <em>%2$s</em>

should be

Replied by %1$s on topic %2$s

Have success!


Ok, thanks a lot!

Please Log in or Create an account to join the conversation.

More
2 months 1 day ago - 2 months 1 day ago #5 by eSilverStrike
I have the same issue.

While the fix above will remove the em tags it doesn't fix the underline issue since the name and title of the post are suppose to be emphasized. The title of the post at some point must switch to html entities (and convert the language string as well) when it should not for HTML tags.

Has a bug been added to Kunena regarding this issue with the Crypsisb3 template? (since it seems to work fine in the template kunena.org uses)
Last edit: 2 months 1 day ago by eSilverStrike. Reason: grammer

Please Log in or Create an account to join the conversation.

More
2 months 1 day ago #6 by Kubik-Rubik
Hi eSilverStrike,
this issue was already fixed with this commit: github.com/Kunena/Kunena-Forum/commit/5b...fb59a38b45180288292f
You can apply the changes manually or wait for the next update.
Cheers

Kubik-Rubik Joomla! Extensions
joomla-extensions.kubik-rubik.de
The following user(s) said Thank You: eSilverStrike

Please Log in or Create an account to join the conversation.

More
2 months 23 hours ago #7 by 810
Or you can install the nightly build from the download page.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.111 seconds