×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question Internal Server Error when clicking on user profiles

More
2 years 11 months ago - 2 years 11 months ago #1 by WinniePooh
Hello everyone,

I've updated my site from version 4.12 to the newest release (5.0.10) and I'm experiencing internal server errors when I click on somebody's profile as administrator. The problem doesn't occur when I visit the profile as guest or when I'm logged in as normal user. In my nginx error.log I get following message:
PHP message: PHP Fatal error:  Call to undefined method JApplicationSite::isClient() in [...]/libraries/kunena/attachment/attachment.php on line 241
The mentioned line in the attachment.php has following content:
if (JFactory::getApplication()->isClient('administrator'))
{
	$url = $url;
}
else
{
	$url = JURI::base() . $url;
}
When I comment this part out and let only $url = JURI::base() . $url; in I get no error as logged in administrator. Is this a safe workaround or is there a bigger problem when I use this on a live site?

Edit: Here some information about my site:
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Disabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 200 seconds | Max execution memory: 128M | Max file upload: 20M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : - | author: - | version: 1.0 | creationdate: 2014-01-31

Kunena default template details : NTS KPraxis | author: Nice Theme Store | version: 5.0.0 Beta | creationdate: 2017-02-04

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.0.10 | 2017-06-30 [ Junco ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: UddeIM 3.7

Third-party SEF components: sh404sef 4.8.1.3465

Plugins: None

Modules: None


Regards
Last edit: 2 years 11 months ago by WinniePooh.

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago - 2 years 11 months ago #2 by xillibit
Hello,

Please upgrade to Joomla! 3.7.3 to fix the issue or in /libraries/kunena/attachment/attachment.php on line 241 replace this part :
if (JFactory::getApplication()->isClient('administrator'))

by this part :

if (JFactory::getApplication()->isAdmin())

I don't provide support by PM, because this can be useful for someone else.
Last edit: 2 years 11 months ago by xillibit.
The following user(s) said Thank You: WinniePooh

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago - 2 years 11 months ago #3 by WinniePooh
Thank you xillibit. An update to Joomla 3.7.3 has fixed the problem. But now another small problem has occured. When the SEF urls are disabled in Joomla I get a 404 component not found error. It's not severe for me because it's enabled on my production site, but it would be nice if I could solve that on my development site.

Edit: The URL looks like this:
.../index.php?option=com_kunena&view=home&defaultmenu=395&Itemid=394
When I remove the "amp;" I can access the site. How does this "amp;" came into the URL?
Last edit: 2 years 11 months ago by WinniePooh.

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #4 by WinniePooh
It would be nice if someone could reply to my problem. As I mentioned it isn't very severe, but for my development site it is important to solve that.

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #5 by xillibit

WinniePooh wrote: Thank you xillibit. An update to Joomla 3.7.3 has fixed the problem. But now another small problem has occured. When the SEF urls are disabled in Joomla I get a 404 component not found error. It's not severe for me because it's enabled on my production site, but it would be nice if I could solve that on my development site.

Edit: The URL looks like this:

.../index.php?option=com_kunena&view=home&defaultmenu=395&Itemid=394
When I remove the "amp;" I can access the site. How does this "amp;" came into the URL?

Do-you have this issue only with Kunena or with others components as well ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #6 by WinniePooh
I'm using also K2 and the URLs in the articles there are working. Only Kunena is showing that behaviour.

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago - 2 years 11 months ago #7 by WinniePooh
Hello, it would be cool if someone could review the problem with the URL. The component com_content also doesn't suffer from the "amp;" in the URL. An update to Joomla 3.7.4 didn't solve the problem.
Last edit: 2 years 11 months ago by WinniePooh.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.173 seconds