×
Blue Eagle 1.5.2 Released (11 Dec 2018)

The Kunena team has announce the arrival of Kunena Blue Eagle 1.5.2 which is now available for download as a native Joomla extension for Kunena 5.1. This version addresses most of the issues that were discovered in K 1.5.1 and issues discovered during the development stages of K 1.5.2.

Question Rendering Error in layout Topic/List: Property "headerText" is not defined

More
1 year 9 months ago #1 by intouchweb
After updating to the latest version of Kunena Forum I get an Internal Server error when clicking on the RSS feed icon. After turning on debug and repeating I see the following error :
Rendering Error in layout Topic/List: Property "headerText" is not defined in /path/public_html/components/com_kunena/template/crypsis/layouts/topic/list/default.php on line 24
Layout was rendered in path/public_html/libraries/kunena/view.php on line 161
can someone please advise?

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #2 by titchagcreation
Hello,

I have the same problem with Joomla 3.7.4 and Kunena 5.0.10.
"Rendering Error in layout Message/List: Property "headerText" is not defined in /path/public_html/components/com_kunena/template/crypsisb3/layouts/message/list/default.php on line 23
Layout was rendered in /home/web-sites/modelio.org.j3x.test/libraries/kunena/view.php on line 161"

Any idea?

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #3 by Fedor
I have:
Rendering Error in layout Topic/List: Property "headerText" is not defined in /var/www/www-root/data/www/nlp.space/components/com_kunena/template/canvas/layouts/topic/list/default.php on line 24
Layout was rendered in /var/www/www-root/data/www/nlp.space/libraries/kunena/layout/base.php on line 183

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #4 by xillibit
Hello,

Can-you give me please your default Kunena template ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #5 by 810
where, om which page do you get that error. Like what are the menu item options.

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago - 1 year 3 months ago #6 by titchagcreation
Actually, I was using the default link provided by Kunena for displaying the RSS.

In my Joomla Global Configuration I have:
- SEF URLs: Yes
- Use URL Rewriting: Yes
- Adds Suffix to URL: YEs
- Unicode Aliases: No

When I was disabling SEF URLs I had no problems accessing the RSS.
With SEF URLs set to yes, this is the RSS link provided by the Kunena Forum: www.websiteaddress.com/forum/topics/posts.feed . This leads to the error I had.
For our users, I gave the following link: www.websiteaddress.com/forum/topics/posts?format=feed for accessing the RSS and this is working.
So I think there is a problem with the Kunena router for this link.

Additional information: I'm using this template crypsisb3 (I had the same problem with crypsis).
Last edit: 1 year 3 months ago by titchagcreation.

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #7 by 810
ok did you clicked on the index page, or the rss link on the bottom on a topic. Then i can locate the issue maybe

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #8 by 810
could you try the nightly build, its on the download page.
I think i got it fixed already. Because i get website.com/forum/topics/mode-topics.feed

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #9 by titchagcreation
I will try it.
The RSS link was on the bottom of the forum (just below the breadcrumbs).

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.116 seconds