×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question Forum index reporting "1 pending message(s)" when there are none.

More
3 years 5 months ago #1 by eSilverStrike
I am using Kunena 5.0.6 (my issue was happening in older versions as well) and I have a small forum and I notice that in the forum index, 2 of my forum categories are reporting:

1 pending message(s)

Clicking on this brings me to the Unapproved Posts page which shows:

No Posts

I usually approve/disapprove a post right away when I am notified via email so I don't think I am missing any posts but obviously either I am or the pending messages count is off or something.

I did search the forum for this issue and in Kunena 3 it was recommended to do a search of unapproved posts in the search page putting a * in the keywords. Doing this doesn't work anymore as it states the keyword must be 3 characters long.

Any ideas on how to fix this?

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #2 by 810
I think you need to change the filter to show all posts. I think there is a old message still unpublished

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #3 by eSilverStrike
Do you mean search for "Normal Posts" (there is no "all posts"). Also the keyword trick of * doesn't work as it requires a keyword of at least 3 characters.

I did find the issue though and you were right there was some old messages.
In the one category there was a post I had edited for formatting but not approved, so it was still pending (but did not show in the pending list).
The other category has a spam post filled with Russian characters that for some reason I could not edit or delete. When I tried the page would just reload. I did use the "permanent delete" option and that worked.

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #4 by 810


i meant top right, change "month" to "all"
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #5 by eSilverStrike
Oh okay, sorry for my misunderstanding.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 1.792 seconds