×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Question Cannot create new topic - Fatal Error: Class 'KunenaSpamRecaptcha' not found

More
3 years 10 months ago #1 by oestek
We've been doing some maintenance on our site, but now we cannot create a new topic in any category on our forum.

Here's the error:

500 Internal Server Error

Fatal Error was detected!

The error was detected in the Kunena Component.

Fatal Error: Class 'KunenaSpamRecaptcha' not found in components/com_kunena/views/topic/view.html.php on line 194

Any ideas? I cannot seem to find anything about the KunenaSpamRecaptcha. Thanks!

URL: www.v8tvshow.com/forum

Configuration:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 512M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: 4/30/2012

Kunena default template details : Crypsis | author: Kunena Team | version: 5.0.3 | creationdate: 2016-10-23

Kunena version detailed: Kunena 5.0.3 | 2016-10-23 [ Dibatag ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: Search - Kunena Search 5.0.1 | Content - Kunena Discuss 5.0.1

Modules: Kunena Latest 5.0.1 | Kunena Stats 5.0.1 | Kunena Login 5.0.1

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #2 by 810
The following user(s) said Thank You: oestek

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #3 by oestek
Thank you! I removed the code as instructed, and no longer receive the error. However, now I click the "create new topic" button and the page simply refreshes, with no new topic created.

Thoughts?

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #4 by 810
There are some issues with joomla sessions.

Try this:
backend - system - global confgurations - system tab - Session Settings set to database

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #5 by oestek

810 wrote: There are some issues with joomla sessions.

Try this:
backend - system - global confgurations - system tab - Session Settings set to database


I've tried the Session Settings as .php and database, neither has an effect.

Thank you!

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #6 by 810
ok, then turn of memcache cache

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #7 by oestek
All cache have been disabled and cleared, still no success.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #8 by 810
try to update php to 5.6 or 7.0

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #9 by oestek
I would consider upgrading, but this worked fine two days ago. The mission was to try to speed up the posting time on the forum, and in the process of disabling / deleting some unused extension, we lost the ability to post.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #10 by oestek
Hmm... also cannot reply to topics.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.164 seconds