×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Solved Connexion status not working with french language

More
4 years 5 days ago - 4 years 1 day ago #1 by Spyki
Hello,

when I install the french language on Joomla (3.6.2) the forum member status (kunena 5.0.2) no longer works.
(Same problem on my test site and on my production site)

Thank you for your help.

This message contains confidential information
Last edit: 4 years 1 day ago by Spyki. Reason: Changing the subject title

Please Log in or Create an account to join the conversation.

More
4 years 5 days ago #2 by xillibit
Hello,

I have checked on your site but i can't see the issue because you have set english has default language and i can't change it. Maybe make some screenshots like that we can see the issue.

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
4 years 1 day ago - 4 years 1 day ago #3 by Spyki
you can log into administrator and make any changes you want on the test site.

As soon as you change the language for the first time, the status (Online, Away, Busy and Invisible) no longer work in the connection menu of the forum.

the problem appears when you change the language for the first time.
Then, even if one switches back to English, the status still does not work.

This message contains confidential information


Thank you for your help
Last edit: 4 years 1 day ago by Spyki. Reason: changing the subject title

Please Log in or Create an account to join the conversation.

More
4 years 7 hours ago #4 by Spyki
Hi,

The update to Kunena 5.0.3 does not solve the problem of the connection status remains on away although it is online, busy or invisible

Do you have a solution ?
Thank you

Please Log in or Create an account to join the conversation.

More
4 years 6 hours ago #5 by 810
You need to logout then login again, then its working, this is because the user cookie must be changed. And it can only be changed if you logout then login again.

Please Log in or Create an account to join the conversation.

More
4 years 6 hours ago #6 by Spyki
Please log on my forum and try to change your connection status.

every time you click Online, Away, Busy or invisible, the connection status does not change in the user profile.

Even after disconnection and reconnection, it's the same.
(Sometimes it happens that it changes once but no more)

There is no problem when using kunena only with the English version.

Please Log in or Create an account to join the conversation.

More
4 years 6 hours ago #7 by 810
Fixed by setting the joomla session to database instead of PHP
The following user(s) said Thank You: Spyki

Please Log in or Create an account to join the conversation.

More
4 years 5 hours ago #8 by Spyki

810 wrote: Fixed by setting the joomla session to database instead of PHP


it also works on my production site

[Solved]

Thank you

Please Log in or Create an account to join the conversation.

More
4 years 5 hours ago #9 by Spyki
the problem is that now jfuploader displays an error message when using database instead of PHP.

The Joomla session handler is set to 'database'. This means that Joomla and JFUploader do not use the same session. Since JFUploader version 3 data from the Joomla session is merged at each call. Therefore old restrictions do not exist anymore (Configuration not active right away, no reload of profiles at multiple usage) if JFUploader does use the internal session workaround (See howto 12). When you set System -> Global Configuration -> System -> Session Settings -> Session Handler to 'none' Joomla and JFUploader do use the same session. It is than possilbe to use variables that are set by the flash. This is e.g. interesting if you want to use the session variable 'TFU_LAST_UPLOADS' which is an array that contains the file names of the last upload.
PLEASE NOTE: If you cannot login to Joomla after changing the setting to 'none' the php session handling is not working properly and you can change this back at 'configuration.php'.


is there a solution to operate the connection status kunena with PHP instead to database ?

Please Log in or Create an account to join the conversation.

More
4 years 5 hours ago #10 by 810
You can enable it, but you need to logout after you changed the status after 5 times, looks like there is a limit for it.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.132 seconds