×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question Missing attachments in K5.0.1

More
3 years 9 months ago - 3 years 9 months ago #1 by WHStables
I just upgraded my test site this morning and it seems the last few months of attachments are missing on the forum. They show up in the profiles but without the preview. Seems like it involves everyone on the forum also. There is a screen shot of a post and a shot of a profile.

Any help would be appreciated.

Attachments:
Last edit: 3 years 9 months ago by WHStables.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #2 by 810
Replied by 810 on topic Missing attachments in K5.0.1
maybe its just hidden by css, do you have a link?

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #3 by WHStables
The images for over a year are all still there, the past few months are all that is missing.

Do you mean a link to a page on the test site?


This is a recent post with the pics missing - Missing pics post

This is an earlier post that seems fine - No problem pics post

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #4 by WHStables
It seems that the pics in the backend without a size are the ones missing. All of the pics for the past few months that have no physical size when looked at in the Kunena Forum:Attachments section are the ones not showing. It is from all members past a certain date. Probably something weird, story of my life lol. :pinch:

Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #5 by WHStables
I recently uploaded a new pic to the test site and it has a physical size and works also.

I hope I'm not wasting anyone's time but thought this info may help.

Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #6 by 810
Replied by 810 on topic Missing attachments in K5.0.1
ok, I see the issue, you have enabled the protected images feature.

Then you need use sef.

Go to backend - system - global configuration

Search Engine Friendly URLs = yes
Use URL Rewriting = yes
Adds Suffix to URL = no
Unicode Aliases = yes

then rename the file on your root from your site:

htaccess.txt to .htaccess
The following user(s) said Thank You: WHStables

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #7 by WHStables
I already have a htaccess.txt and .htaccess file in the root for my site. What should I do as I can't rename the one now with one already there?

The protect images has been on for a long time (over a year) as well but the only images missing is from the past few months. Maybe I just don't know enough.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #8 by 810
Replied by 810 on topic Missing attachments in K5.0.1
Ok, then change only the settings.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #9 by WHStables
I changed just the settings and every section I try to go into on the forum gave me a - Error 404 - Not Found
The document you are looking for may have been removed or re-named. Please contact the web site owner for further assistance.

I tried disabling the Protected Attachments and that didn't work either.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #10 by 810
Replied by 810 on topic Missing attachments in K5.0.1
because your html is incorrect for protected attachments:
https://testsite.wheelhorsestables.com/index.php/forum

should be:
https://testsite.wheelhorsestables.com/forum

www.inmotionhosting.com/support/edu/joom...ngs/remove-index-php

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.933 seconds