×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Solved Recent Topics Time Period not working

More
3 years 3 weeks ago - 3 years 3 weeks ago #1 by kunenauser40
Hi, I have latest Joomla / Kunena installed.

In Joomla backend at Kunena Configuration - Frontend - Recent Topics Time Period, I changed the time period from month to year.

Then the number of posts in the recent topics raised correctly e.g. from 80 posts before (month) now raised to 800 posts (year).



But the problem starts when you press the next button to see the next 25 posts then the number of Recent Topics returns to month option and shows again 80 posts instead of 800 that was correctly, it shows only in the first time you enter to forum the correct numbers of post and if you press the Next or the "2" box to show you the next page of posts, the number returns to month posts and also the boxes decreased because it thinks that there is no more "Next" number to show new pages of posts.



I use JotCache, but I cleared cache and retest it, also I disabled completely the plugin Jotcache but still the same problem.

Is this a bug or it is a conflict in my joomla configuration only?

Thanks
Attachments:
Last edit: 3 years 3 weeks ago by kunenauser40.

Please Log in or Create an account to join the conversation.

More
3 years 3 weeks ago #2 by 810
its a bug, i saw also on this site this issue. will add a ticket for it.
The following user(s) said Thank You: kunenauser40

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #3 by kunenauser40
Hi again,
will this bug be fixed in kunena 5.1 ?
Because I downloaded and installed the 5.1 beta 1 but still the problem remains! Is this bug officially in the "bug list" so to be planned to be fixed ?
Thanks!

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #4 by rich

Is this bug officially in the "bug list" so to be planned to be fixed ?

Yes, this bug is in the bug list. But this bug exists in Kunena 5.0, so he will be fixed first in K5.0.

Check your menu item Recent Topics, you have the same options as in the configuration. Maybe it works, if you set the time period in the menu item.
The following user(s) said Thank You: kunenauser40

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #5 by kunenauser40

rich wrote:

Is this bug officially in the "bug list" so to be planned to be fixed ?

Check your menu item Recent Topics, you have the same options as in the configuration. Maybe it works, if you set the time period in the menu item.


Thanks rich, I did this and it worked :)

So to know and the other users how to fix this :

First : We change in Kunena Configuration - Frontend - Recent Topics Time Period to "Year"

Second : We change in the Menu - Kunena Menu - Recent Topics - Main Settings - Recent Topics Time to "Year"

Thanks again rich!!!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.495 seconds