×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

Solved Search component error message in back-end oj joomla

More
3 years 3 months ago - 3 years 3 months ago #1 by NewbieNr1
I can't access the search component anymore. I get this error talking about Kunena.

An error has occurred.
0 Call to undefined method JApplicationAdministrator::getParams()

Call stack
# Function Location
1 KunenaBbcodeLibrary->DoArticle() JROOT/libraries/kunena/external/nbbc/nbbc.php:2680
2 NBBC_BBCode->DoTag() JROOT/libraries/kunena/external/nbbc/nbbc.php:2941
3 NBBC_BBCode->Internal_ParseEndTagToken() JROOT/libraries/kunena/external/nbbc/nbbc.php:3075
4 NBBC_BBCode->Parse() JROOT/libraries/kunena/html/parser.php:117
5 KunenaHtmlParser::parseBBCode() JROOT/plugins/search/kunena/kunena.php:160
6 plgSearchKunena() JROOT/libraries/joomla/event/dispatcher.php:165
7 JEventDispatcher->trigger() JROOT/libraries/joomla/application/base.php:106
8 JApplicationBase->triggerEvent() JROOT/administrator/components/com_search/models/searches.php:151
9 SearchModelSearches->getItems() JROOT/libraries/legacy/view/legacy.php:422
10 JViewLegacy->get() JROOT/administrator/components/com_search/views/searches/view.html.php:37
11 SearchViewSearches->display() JROOT/libraries/legacy/controller/legacy.php:671
12 JControllerLegacy->display() JROOT/administrator/components/com_search/controller.php:42
13 SearchController->display() JROOT/libraries/legacy/controller/legacy.php:709
14 JControllerLegacy->execute() JROOT/administrator/components/com_search/search.php:18
15 require_once() JROOT/libraries/cms/component/helper.php:394
16 JComponentHelper::executeComponent() JROOT/libraries/cms/component/helper.php:369
17 JComponentHelper::renderComponent() JROOT/libraries/cms/application/administrator.php:98
18 JApplicationAdministrator->dispatch() JROOT/libraries/cms/application/administrator.php:156
19 JApplicationAdministrator->doExecute() JROOT/libraries/cms/application/cms.php:265
20 JApplicationCms->execute() JROOT/administrator/index.php:51


The error is caused by your "kunena" extension - once I disabled the "System - Kunena Forum" plugin then it works again.

Can you guys help me sort this out please? It seems that the search component works well in the front-end.
Last edit: 3 years 3 months ago by NewbieNr1.

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #2 by xillibit
Hello,

Can-you put here please your Kunena report configuration ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #3 by NewbieNr1
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 768M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : rt_galatea | author: RocketTheme, LLC | version: 1.2.0 | creationdate: March 14, 2017

Kunena default template details : Crypsis | author: Kunena Team | version: 5.0.9 | creationdate: 2017-05-26

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.0.9 | 2017-05-26 [ Ibis ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: sh404sef 4.9.2.3552

Plugins: Search - Kunena Search 5.0.3 | Content - Kunena Discuss 5.0.3

Modules: None

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #4 by rich
You had this errors earlier not on your page (see your other topics). What have you changed or installed in the meantime?

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #5 by NewbieNr1
I have been thinking of this to. All I can think of is:
- downloaded Kunena Discuss plugin
- made som small custom css changes to my RocketTheme template (I have discussed with them too and they also think it is a Kunena problem)
- purge all the urls with sh404SEF and made som small changens to SEF urls for Kunena menu items (I have discussed with them too and they also think it is a Kunena problem)

Please Log in or Create an account to join the conversation.

More
3 years 3 months ago #6 by NewbieNr1
It seems I have fixed it.

I disabled the kunena search plugin, then I was able to go into joomla search component, then reset the search terms, then enabled the kunena search plugin, then it was working! :)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.138 seconds